ocaml/0005-Merge-pull-request-11860-from-Octachron-index_for_st.patch
Richard W.M. Jones 68671b2fe6 OCaml 5.0
2023-07-10 22:08:39 +01:00

69 lines
2.2 KiB
Diff

From 848e28fc6f3f3c9802b23c00f2d77f568c761667 Mon Sep 17 00:00:00 2001
From: Gabriel Scherer <gabriel.scherer@gmail.com>
Date: Tue, 3 Jan 2023 17:41:12 +0100
Subject: [PATCH 05/18] Merge pull request #11860 from
Octachron/index_for_stdlib
documentation: sort modules alphabetically
fixes #11857
(cherry picked from commit 14004c6d4bedadb7215ded2c77230270e52307ff)
---
api_docgen/Makefile.docfiles | 24 +++++++++++++++---------
1 file changed, 15 insertions(+), 9 deletions(-)
diff --git a/api_docgen/Makefile.docfiles b/api_docgen/Makefile.docfiles
index 0c2412b192..f12830b1ec 100644
--- a/api_docgen/Makefile.docfiles
+++ b/api_docgen/Makefile.docfiles
@@ -26,10 +26,6 @@ define capitalize
$(foreach m,$(1),$(call capitalize_one,$m))
endef
-define sort
-$(shell $(OCAMLDEP) -sort $(1))
-endef
-
runtime_events_MLIS := runtime_events.mli
str_MLIS := str.mli
unix_MLIS := unix.mli unixLabels.mli
@@ -62,10 +58,8 @@ endif
libref_TEXT=Ocaml_operators Format_tutorial
libref_C=$(call capitalize,$(libref))
-PARSING_MLIS := $(call sort, \
- $(notdir $(wildcard $(ROOTDIR)/parsing/*.mli))\
-)
-UTILS_MLIS := $(call sort,$(notdir $(wildcard $(ROOTDIR)/utils/*.mli)))
+PARSING_MLIS := $(notdir $(wildcard $(ROOTDIR)/parsing/*.mli))
+UTILS_MLIS := $(notdir $(wildcard $(ROOTDIR)/utils/*.mli))
DRIVER_MLIS := pparse.mli
compilerlibref_MLIS= \
@@ -76,8 +70,20 @@ compilerlibref=$(compilerlibref_MLIS:%.mli=%)
compilerlibref_TEXT=Compiler_libs
compilerlibref_C=$(call capitalize,$(compilerlibref))
-ALL_LIBREF= $(libref_TEXT:%=libref/%) $(libref:%=libref/%)
+ALL_LIBREF= \
+ $(sort $(libref_TEXT:%=libref/%)) \
+ $(sort $(filter-out libref/camlinternal%, $(libref:%=libref/%))) \
+ $(sort $(filter libref/camlinternal%, $(libref:%=libref/%)))
+
ALL_COMPILERLIBREF= \
$(compilerlibref_TEXT:%=compilerlibref/%) \
$(compilerlibref:%=compilerlibref/%)
+# Note that the output of $(wildcard ...) is sorted alphabetically.
+# The compilerlibs index will be thus be sorted first by category:
+# - text documentation
+# - parsing modules
+# - utils modules
+# - driver modules
+# And then alphabetically inside each category.
+
ALL_DOC= $(ALL_LIBREF) $(ALL_COMPILERLIBREF)
--
2.41.0