129153b851
NOTE: I did not build this package because it will cause dependency problems (requiring every other OCaml package in F35 to be rebuilt). If there is a mass rebuild of Rawhide then that would be a good time to rebuild it.
44 lines
1.1 KiB
Diff
44 lines
1.1 KiB
Diff
From 5cc71dbb0f25d4c5b444f099965b93149577ee8f Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Fri, 26 Apr 2019 16:16:29 +0100
|
|
Subject: [PATCH 3/4] configure: Remove incorrect assumption about
|
|
cross-compiling.
|
|
|
|
See https://github.com/ocaml/ocaml/issues/8647#issuecomment-487094390
|
|
---
|
|
configure.ac | 11 ++++++-----
|
|
1 file changed, 6 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 213392b25..c7e594b5d 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -529,10 +529,11 @@ AS_IF(
|
|
|
|
# Are we building a cross-compiler
|
|
|
|
-AS_IF(
|
|
- [test x"$host" = x"$target"],
|
|
- [cross_compiler=false],
|
|
- [cross_compiler=true])
|
|
+#AS_IF(
|
|
+# [test x"$host" = x"$target"],
|
|
+# [cross_compiler=false],
|
|
+# [cross_compiler=true])
|
|
+cross_compiler=false
|
|
|
|
# Checks for programs
|
|
|
|
@@ -1072,7 +1073,7 @@ AS_CASE([$arch],
|
|
|
|
# Assembler
|
|
|
|
-AS_IF([test -n "$host_alias"], [toolpref="${host_alias}-"], [toolpref=""])
|
|
+#AS_IF([test -n "$host_alias"], [toolpref="${host_alias}-"], [toolpref=""])
|
|
|
|
# We first compute default values for as and aspp
|
|
# If values have been given by the user then they take precedence over
|
|
--
|
|
2.32.0
|
|
|