ocaml/0005-configure-Allow-user-defined-C-compiler-flags.patch
Richard W.M. Jones 77bcef6197 OCaml 4.08.1+rc2.
Include fix for miscompilation of off_t on 32 bit architectures.
2019-07-30 08:54:03 +01:00

28 lines
765 B
Diff

From 4af3619375230488b370e5b3d5a8f48cef688607 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:44:18 +0100
Subject: [PATCH 5/9] configure: Allow user defined C compiler flags.
---
configure.ac | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/configure.ac b/configure.ac
index 5bb061162..6e37ff6c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -553,6 +553,10 @@ AS_CASE([$host],
internal_cflags="$gcc_warnings"],
[common_cflags="-O"])])
+# Allow CFLAGS and LDFLAGS to be added.
+common_cflags="$common_cflags $CFLAGS"
+oc_ldflags="$oc_ldflags $LDFLAGS"
+
internal_cppflags="-DCAML_NAME_SPACE $internal_cppflags"
# Enable SSE2 on x86 mingw to avoid using 80-bit registers.
--
2.22.0.rc3