772b17b666
This is no longer needed now we found another way to work around build notes breakage.
28 lines
735 B
Diff
28 lines
735 B
Diff
From 9d3722c87ab15dfbc4e1a934e09ddc8253712d9c Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Tue, 29 May 2012 20:44:18 +0100
|
|
Subject: [PATCH 16/17] configure: Allow user defined C compiler flags.
|
|
|
|
---
|
|
configure.ac | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index a7974b0426..8068de3cfc 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -670,6 +670,10 @@ AS_CASE([$host],
|
|
internal_cflags="$cc_warnings"],
|
|
[common_cflags="-O"])])
|
|
|
|
+# Allow CFLAGS and LDFLAGS to be added.
|
|
+common_cflags="$common_cflags $CFLAGS"
|
|
+cclibs="$cclibs $LDFLAGS"
|
|
+
|
|
# Enable SSE2 on x86 mingw to avoid using 80-bit registers.
|
|
AS_CASE([$host],
|
|
[i686-*-mingw32],
|
|
--
|
|
2.41.0
|
|
|