ocaml/0008-Fix-incorrect-variable-from-runtime-Makefile-merge.patch
Richard W.M. Jones 772b17b666 Drop downstream 0017-configure-Only-use-OC_-for-building-executables.patch
This is no longer needed now we found another way to work around build
notes breakage.
2023-07-11 17:46:39 +01:00

34 lines
1.1 KiB
Diff

From 2eccdd3cd78624b0f2664d6152afbcae167f6f8b Mon Sep 17 00:00:00 2001
From: David Allsopp <david.allsopp@metastack.com>
Date: Mon, 20 Feb 2023 20:27:58 +0000
Subject: [PATCH 08/17] Fix incorrect variable from runtime/Makefile merge
Wrong CPPFLAGS used when assembling with ASPP.
---
Makefile | 9 +++++++++
1 file changed, 9 insertions(+)
diff --git a/Makefile b/Makefile
index bb2c245eab..3ea3296c7f 100644
--- a/Makefile
+++ b/Makefile
@@ -952,6 +952,15 @@ ASPP_ERROR = \
runtime/%.o: runtime/%.S
$(ASPP) $(OC_ASPPFLAGS) -o $@ $< || $(ASPP_ERROR)
+# $(OC_DEBUG_CPPFLAGS) and $(OC_INSTR_CPPFLAGS) are still used in the two
+# recipes just below instead of the correct $(ocamlrund_CPPFLAGS) and
+# $(ocamlruni_CPPFLAGS). This has been fixed on trunk, but in the
+# 5.0 maintenance branch here we just define default values for those OC_*
+# variables to avoid an undefined-variable warning, preserving exactly the
+# (somewhat strange) behaviour of the 5.0.0 release.
+OC_DEBUG_CPPFLAGS ?=
+OC_INSTR_CPPFLAGS ?=
+
runtime/%.d.o: runtime/%.S
$(ASPP) $(OC_ASPPFLAGS) $(OC_DEBUG_CPPFLAGS) -o $@ $< || $(ASPP_ERROR)
--
2.41.0