ocaml/0006-Allow-installing-in-folder-with-space-in-name-11590.patch
Richard W.M. Jones 772b17b666 Drop downstream 0017-configure-Only-use-OC_-for-building-executables.patch
This is no longer needed now we found another way to work around build
notes breakage.
2023-07-11 17:46:39 +01:00

43 lines
1.2 KiB
Diff

From a3cd42bc03ed0fc706bb7364fdb14b29b1925600 Mon Sep 17 00:00:00 2001
From: David Allsopp <david.allsopp@metastack.com>
Date: Wed, 4 Jan 2023 16:33:28 +0000
Subject: [PATCH 06/17] Allow installing in folder with space in name (#11590)
- fix(build): Repair make install (in man/Makefile)
---
Changes | 8 ++++++++
man/Makefile | 4 ++--
2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/Changes b/Changes
index 776f6e7a45..438c0f3ec2 100644
--- a/Changes
+++ b/Changes
@@ -1,3 +1,11 @@
+OCaml 5.0 maintenance version
+-----------------------------
+
+### Build system:
+
+- #11590: Allow installing to a destination path containing spaces.
+ (Élie Brami, review by Sébastien Hinderer and David Allsopp)
+
OCaml 5.0 (16 December 2022)
----------------------------
diff --git a/man/Makefile b/man/Makefile
index 36d3126563..10cc8bbe41 100644
--- a/man/Makefile
+++ b/man/Makefile
@@ -22,5 +22,5 @@ MANPAGES = $(addsuffix .1,\
.PHONY: install
install:
- $(MKDIR) $(INSTALL_PROGRAMS_MAN_DIR)
- $(INSTALL_DATA) $(MANPAGES) $(INSTALL_PROGRAMS_MAN_DIR)
+ $(MKDIR) '$(INSTALL_PROGRAMS_MAN_DIR)'
+ $(INSTALL_DATA) $(MANPAGES) '$(INSTALL_PROGRAMS_MAN_DIR)'
--
2.41.0