3237fd89d4
resolves: rhbz#1975167
44 lines
1.1 KiB
Diff
44 lines
1.1 KiB
Diff
From 3318c5b805d8d6ae1d571f18f682c9f701b712e2 Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Fri, 26 Apr 2019 16:16:29 +0100
|
|
Subject: [PATCH 3/6] configure: Remove incorrect assumption about
|
|
cross-compiling.
|
|
|
|
See https://github.com/ocaml/ocaml/issues/8647#issuecomment-487094390
|
|
---
|
|
configure.ac | 11 ++++++-----
|
|
1 file changed, 6 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 5153853b7..4e97474a2 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -511,10 +511,11 @@ AS_IF(
|
|
|
|
# Are we building a cross-compiler
|
|
|
|
-AS_IF(
|
|
- [test x"$host" = x"$target"],
|
|
- [cross_compiler=false],
|
|
- [cross_compiler=true])
|
|
+#AS_IF(
|
|
+# [test x"$host" = x"$target"],
|
|
+# [cross_compiler=false],
|
|
+# [cross_compiler=true])
|
|
+cross_compiler=false
|
|
|
|
# Checks for programs
|
|
|
|
@@ -1021,7 +1022,7 @@ AS_CASE([$arch],
|
|
|
|
# Assembler
|
|
|
|
-AS_IF([test -n "$host_alias"], [toolpref="${host_alias}-"], [toolpref=""])
|
|
+#AS_IF([test -n "$host_alias"], [toolpref="${host_alias}-"], [toolpref=""])
|
|
|
|
# We first compute default values for as and aspp
|
|
# If values have been given by the user then they take precedence over
|
|
--
|
|
2.32.0
|
|
|