1837515a64
- The language is now officially called OCaml (not Objective Caml, O'Caml etc) - Rebase patches on top: . New ARM backend patch no longer required, since upstream. . Replacement config.guess, config.sub no longer required, since upstream versions are newer. . ppc64 backend known not to work; will fix shortly. - New tool: ocamloptp (ocamlopt profiler). - New VERSION file in ocaml-runtime package. - New ocaml-compiler-libs subpackage. - Rearrange ExclusiveArch alphanumerically. - alpha, ia64 native backends have been removed upstream, so they are no longer supported as native compiler targets. - Remove defattr.
29 lines
938 B
Diff
29 lines
938 B
Diff
From a46d9a5dd1cb05ee6f32ca41acd35acb536a90de Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Tue, 5 Jun 2012 22:49:17 +0100
|
|
Subject: [PATCH 4/5] Link dllthreads.so with -lpthread so that pthread_atfork
|
|
is included statically.
|
|
|
|
See:
|
|
https://lists.fedoraproject.org/pipermail/ppc/2012-June/001655.html
|
|
---
|
|
otherlibs/systhreads/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/otherlibs/systhreads/Makefile b/otherlibs/systhreads/Makefile
|
|
index 3d3f8fb..fb0ae87 100644
|
|
--- a/otherlibs/systhreads/Makefile
|
|
+++ b/otherlibs/systhreads/Makefile
|
|
@@ -30,7 +30,7 @@ all: libthreads.a threads.cma
|
|
allopt: libthreadsnat.a threads.cmxa
|
|
|
|
libthreads.a: $(BYTECODE_C_OBJS)
|
|
- $(MKLIB) -o threads $(BYTECODE_C_OBJS)
|
|
+ $(MKLIB) -o threads $(BYTECODE_C_OBJS) -lpthread
|
|
|
|
st_stubs_b.o: st_stubs.c st_posix.h
|
|
$(BYTECC) -O -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS) \
|
|
--
|
|
1.7.10
|
|
|