OCaml 4.10.0+beta1.
This commit is contained in:
parent
71ffd8d204
commit
f986cb165c
@ -1,14 +1,14 @@
|
||||
From 065c173840d0c379c26376b1de6363736043c969 Mon Sep 17 00:00:00 2001
|
||||
From 1f575196cc7c26a1edc016bca8f7ff052636186b Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 24 Jun 2014 10:00:15 +0100
|
||||
Subject: [PATCH 09/13] Don't add rpaths to libraries.
|
||||
Subject: [PATCH 1/5] Don't add rpaths to libraries.
|
||||
|
||||
---
|
||||
tools/Makefile | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/Makefile b/tools/Makefile
|
||||
index 84ddd79fb..796821968 100644
|
||||
index 18aead935..e374c05ee 100644
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -153,8 +153,8 @@ $(call byte_and_opt,ocamlmklib,ocamlmklibconfig.cmo config.cmo \
|
||||
@ -23,5 +23,5 @@ index 84ddd79fb..796821968 100644
|
||||
> ocamlmklibconfig.ml
|
||||
|
||||
--
|
||||
2.23.0
|
||||
2.24.1
|
||||
|
@ -1,52 +0,0 @@
|
||||
From 6207460e793f8c5538bfd8164fa3078f7300b57a Mon Sep 17 00:00:00 2001
|
||||
From: Florian Angeletti <florian.angeletti@inria.fr>
|
||||
Date: Tue, 17 Sep 2019 14:35:00 +0200
|
||||
Subject: [PATCH 01/13] increment version number after tagging 4.09.0
|
||||
|
||||
---
|
||||
VERSION | 2 +-
|
||||
configure | Bin 542920 -> 542985 bytes
|
||||
ocaml-variants.opam | 4 ++--
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/VERSION b/VERSION
|
||||
index 7128cac1f..ff541f87c 100644
|
||||
--- a/VERSION
|
||||
+++ b/VERSION
|
||||
@@ -1,4 +1,4 @@
|
||||
-4.09.0
|
||||
+4.09.1+dev0
|
||||
|
||||
# The version string is the first line of this file.
|
||||
# It must be in the format described in stdlib/sys.mli
|
||||
diff --git a/configure b/configure
|
||||
index 85fb6842dffc1ba52a07895aefa7d49f7f383d17..c364be4e3a365e01c667023ea23238037446a3c3 100755
|
||||
GIT binary patch
|
||||
delta 189
|
||||
zcmX>xQL%H9;)HruL+zB*vW@kPP7u~4XE_LCvz&8XD3m#8#&>QgbMlgF5>RI5-Yp&w
|
||||
z=5|>&Ml~Hauu%rn8#gjaOph^Ql!r=I8!_gwL)h&vEg6BB35c12m}UD*OIB{E&Fx>R
|
||||
iS%H{s`<H6=WlRwD(}4#2Zhv0Kt_d|@yFeTJjza*mO+t16
|
||||
|
||||
delta 120
|
||||
zcmeC2q<CVY;)ME*Esai-xt!%T>pItkZr(8CJNM=_ORh;U8cg?LW0c>#eD4&G?G9{=
|
||||
zYC1rXkJ^k9(_4%f<+raeV$5T2m$qUAVkRJF24a@&(pIe8PVL$?tU%1RUAu;T8Pjy2
|
||||
TUf=D?_3WDL+XLI!cN_u$b;&5C
|
||||
|
||||
diff --git a/ocaml-variants.opam b/ocaml-variants.opam
|
||||
index 30d48eb24..5410d1f4c 100644
|
||||
--- a/ocaml-variants.opam
|
||||
+++ b/ocaml-variants.opam
|
||||
@@ -1,8 +1,8 @@
|
||||
opam-version: "2.0"
|
||||
-version: "4.09.0"
|
||||
+version: "4.09.1+trunk"
|
||||
synopsis: "OCaml development version"
|
||||
depends: [
|
||||
- "ocaml" {= "4.09.0" & post}
|
||||
+ "ocaml" {= "4.09.1" & post}
|
||||
"base-unix" {post}
|
||||
"base-bigarray" {post}
|
||||
"base-threads" {post}
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,17 +1,17 @@
|
||||
From aab08177e52b9951b5e95c949c7b61c690a0efd7 Mon Sep 17 00:00:00 2001
|
||||
From 122b350037d93e9f44357b215d5ecfbadb8d8fa5 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 29 May 2012 20:44:18 +0100
|
||||
Subject: [PATCH 10/13] configure: Allow user defined C compiler flags.
|
||||
Subject: [PATCH 2/5] configure: Allow user defined C compiler flags.
|
||||
|
||||
---
|
||||
configure.ac | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index c2f185373..547640906 100644
|
||||
index 90e6a041e..2f7e829e5 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -549,6 +549,10 @@ AS_CASE([$host],
|
||||
@@ -590,6 +590,10 @@ AS_CASE([$host],
|
||||
internal_cflags="$gcc_warnings"],
|
||||
[common_cflags="-O"])])
|
||||
|
||||
@ -23,5 +23,5 @@ index c2f185373..547640906 100644
|
||||
|
||||
# Enable SSE2 on x86 mingw to avoid using 80-bit registers.
|
||||
--
|
||||
2.23.0
|
||||
2.24.1
|
||||
|
@ -1,27 +0,0 @@
|
||||
From c1db490f8d92e7b5f1a4685cd9a095f24429bb3e Mon Sep 17 00:00:00 2001
|
||||
From: Gabriel Scherer <gabriel.scherer@gmail.com>
|
||||
Date: Thu, 19 Sep 2019 15:40:49 +0200
|
||||
Subject: [PATCH 02/13] mark the release in the Changes
|
||||
|
||||
---
|
||||
Changes | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index d4b8a994d..e95ae5e49 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -1,5 +1,8 @@
|
||||
-OCaml 4.09.0
|
||||
-------------
|
||||
+OCaml 4.09 maintenance branch:
|
||||
+------------------------------
|
||||
+
|
||||
+OCaml 4.09.0 (19 September 2019):
|
||||
+---------------------------------
|
||||
|
||||
(Changes that can break existing programs are marked with a "*")
|
||||
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,46 +0,0 @@
|
||||
From 1204abd71a4ef585dbb70ba68a5879856d24c1a9 Mon Sep 17 00:00:00 2001
|
||||
From: Gabriel Scherer <gabriel.scherer@gmail.com>
|
||||
Date: Fri, 20 Sep 2019 10:58:09 +0200
|
||||
Subject: [PATCH 03/13] Merge pull request #8954 from
|
||||
Armael/fix-toplevel-submsg-locs
|
||||
|
||||
Fix error submessages in the toplevel: do not display dummy locations
|
||||
|
||||
(cherry picked from commit 8f7708a0fbc3e1199ccf04a6b9e1ba8e0f0d5254)
|
||||
---
|
||||
Changes | 4 ++++
|
||||
parsing/location.ml | 3 ++-
|
||||
2 files changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index e95ae5e49..355cb1a94 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -1,6 +1,10 @@
|
||||
OCaml 4.09 maintenance branch:
|
||||
------------------------------
|
||||
|
||||
+- #8953, #8954: Fix error submessages in the toplevel: do not display
|
||||
+ dummy locations
|
||||
+ (Armaël Guéneau, review by Gabriel Scherer)
|
||||
+
|
||||
OCaml 4.09.0 (19 September 2019):
|
||||
---------------------------------
|
||||
|
||||
diff --git a/parsing/location.ml b/parsing/location.ml
|
||||
index 25cba42c7..ab823d36f 100644
|
||||
--- a/parsing/location.ml
|
||||
+++ b/parsing/location.ml
|
||||
@@ -752,7 +752,8 @@ let terminfo_toplevel_printer (lb: lexbuf): report_printer =
|
||||
in
|
||||
let pp_main_loc _ _ _ _ = () in
|
||||
let pp_submsg_loc _ _ ppf loc =
|
||||
- Format.fprintf ppf "%a:@ " print_loc loc in
|
||||
+ if not loc.loc_ghost then
|
||||
+ Format.fprintf ppf "%a:@ " print_loc loc in
|
||||
{ batch_mode_printer with pp; pp_main_loc; pp_submsg_loc }
|
||||
|
||||
let best_toplevel_printer () =
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 272b31bbd8c35a613f035465441ac5a34de8450e Mon Sep 17 00:00:00 2001
|
||||
From 4481368be15b3dbd07c9ed8a3194194fe8594fc5 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Fri, 26 Apr 2019 16:16:29 +0100
|
||||
Subject: [PATCH 11/13] configure: Remove incorrect assumption about
|
||||
Subject: [PATCH 3/5] configure: Remove incorrect assumption about
|
||||
cross-compiling.
|
||||
|
||||
See https://github.com/ocaml/ocaml/issues/8647#issuecomment-487094390
|
||||
@ -10,10 +10,10 @@ See https://github.com/ocaml/ocaml/issues/8647#issuecomment-487094390
|
||||
1 file changed, 6 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 547640906..9ee8dcaae 100644
|
||||
index 2f7e829e5..ed6e0b0ca 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -461,10 +461,11 @@ AS_IF(
|
||||
@@ -505,10 +505,11 @@ AS_IF(
|
||||
|
||||
# Are we building a cross-compiler
|
||||
|
||||
@ -29,7 +29,7 @@ index 547640906..9ee8dcaae 100644
|
||||
|
||||
# Checks for programs
|
||||
|
||||
@@ -927,7 +928,7 @@ AS_IF([test $arch != "none" && $arch64 ],
|
||||
@@ -970,7 +971,7 @@ AS_IF([test $arch != "none" && $arch64 ],
|
||||
|
||||
# Assembler
|
||||
|
||||
@ -39,5 +39,5 @@ index 547640906..9ee8dcaae 100644
|
||||
# We first compute default values for as and aspp
|
||||
# If values have been given by the user then they take precedence over
|
||||
--
|
||||
2.23.0
|
||||
2.24.1
|
||||
|
@ -1,102 +0,0 @@
|
||||
From 987e819b8fb8e36e660340931270a2ade02c439e Mon Sep 17 00:00:00 2001
|
||||
From: Gabriel Scherer <gabriel.scherer@gmail.com>
|
||||
Date: Thu, 26 Sep 2019 21:46:03 +0200
|
||||
Subject: [PATCH 04/13] Merge pull request #8979 from
|
||||
gasche/fix-Makefile.menhir
|
||||
|
||||
Fix tools/check-parser-uptodate-or-warn.sh
|
||||
|
||||
(cherry picked from commit f075ab6fdeedc8d53ececd1184d69a1cc35c0fd5)
|
||||
---
|
||||
Changes | 3 +++
|
||||
Makefile | 6 +++---
|
||||
tools/check-parser-uptodate-or-warn.sh | 21 +++++++++++++++++----
|
||||
3 files changed, 23 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index 355cb1a94..63cac3ef9 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -5,6 +5,9 @@ OCaml 4.09 maintenance branch:
|
||||
dummy locations
|
||||
(Armaël Guéneau, review by Gabriel Scherer)
|
||||
|
||||
+- #8965, #8979: Alpine build failure caused by check-parser-uptodate-or-warn.sh
|
||||
+ (Gabriel Scherer and David Allsopp, report by Anton Kochkov)
|
||||
+
|
||||
OCaml 4.09.0 (19 September 2019):
|
||||
---------------------------------
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 47548c79d..7ac446f62 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1076,10 +1076,10 @@ parsing/camlinternalMenhirLib.mli: boot/menhir/menhirLib.mli
|
||||
|
||||
parsing/parser.ml: boot/menhir/parser.ml parsing/parser.mly \
|
||||
tools/check-parser-uptodate-or-warn.sh
|
||||
- @tools/check-parser-uptodate-or-warn.sh
|
||||
- cat $< | sed "s/MenhirLib/CamlinternalMenhirLib/g" > $@
|
||||
+ @-tools/check-parser-uptodate-or-warn.sh
|
||||
+ sed "s/MenhirLib/CamlinternalMenhirLib/g" $< > $@
|
||||
parsing/parser.mli: boot/menhir/parser.mli
|
||||
- cat $< | sed "s/MenhirLib/CamlinternalMenhirLib/g" > $@
|
||||
+ sed "s/MenhirLib/CamlinternalMenhirLib/g" $< > $@
|
||||
|
||||
|
||||
partialclean:: partialclean-menhir
|
||||
diff --git a/tools/check-parser-uptodate-or-warn.sh b/tools/check-parser-uptodate-or-warn.sh
|
||||
index 5502eae54..2f07619a6 100755
|
||||
--- a/tools/check-parser-uptodate-or-warn.sh
|
||||
+++ b/tools/check-parser-uptodate-or-warn.sh
|
||||
@@ -15,6 +15,9 @@
|
||||
#* *
|
||||
#**************************************************************************
|
||||
|
||||
+# stop early if we are not on a development version
|
||||
+grep -Fq '+dev' VERSION || exit 0
|
||||
+
|
||||
# We try to warn if the user edits parsing/parser.mly but forgets to
|
||||
# rebuild the generated parser. Our heuristic is to use the file
|
||||
# modification timestamp, but just testing
|
||||
@@ -24,15 +27,20 @@
|
||||
# seconds after boot/menhir/parser.ml.
|
||||
|
||||
# mtime(): access a file's last modification time as a timestamp,
|
||||
-# using either GNU coreutils' stat --format, or BSD/macos stat -f.
|
||||
+# using either
|
||||
+# GNU coreutils' stat --format, or
|
||||
+# busybox's stat -c, or
|
||||
+# BSD/macOS stat -f.
|
||||
# Default to 0 if 'stat' is not available.
|
||||
|
||||
stat . 2>/dev/null 1>/dev/null
|
||||
if test $? != 0
|
||||
then MTIME=""
|
||||
-elif test -n "$(stat --version 2>/dev/null | grep coreutils)"
|
||||
+elif stat --version 2>/dev/null | grep -Fq 'coreutils'
|
||||
then MTIME="stat --format %Y"
|
||||
-else MTIME="stat -f %m"
|
||||
+elif stat 2>&1 | grep -Fq 'busybox'
|
||||
+then MTIME="stat -c %Y"
|
||||
+else MTIME="stat -f %m" # BSD stat?
|
||||
fi
|
||||
|
||||
mtime() {
|
||||
@@ -45,7 +53,12 @@ mtime() {
|
||||
# The check itself
|
||||
SOURCE_MTIME=$(mtime parsing/parser.mly)
|
||||
GENERATED_MTIME=$(mtime boot/menhir/parser.ml)
|
||||
-if test $SOURCE_MTIME -gt $(( $GENERATED_MTIME + 10 ))
|
||||
+if test -z "$SOURCE_MTIME" -o -z "$GENERATED_MTIME"
|
||||
+then
|
||||
+ echo
|
||||
+ tput setaf 3; tput bold; printf "Warning: "; tput sgr0
|
||||
+ echo "Failed to check if boot/menhir/parser.ml is up-to-date."
|
||||
+elif test "$SOURCE_MTIME" -gt $(( GENERATED_MTIME + 10 ))
|
||||
then
|
||||
echo
|
||||
tput setaf 3; tput bold; printf "Warning: "; tput sgr0
|
||||
--
|
||||
2.23.0
|
||||
|
28
0004-Remove-configure-from-.gitattributes.patch
Normal file
28
0004-Remove-configure-from-.gitattributes.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 95c9c4486c1c23cc735d4986d1b3e6b812514184 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sat, 18 Jan 2020 11:31:27 +0000
|
||||
Subject: [PATCH 4/5] Remove configure from .gitattributes.
|
||||
|
||||
It's not a binary file.
|
||||
---
|
||||
.gitattributes | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/.gitattributes b/.gitattributes
|
||||
index 9be9e33a0..5df88ab4e 100644
|
||||
--- a/.gitattributes
|
||||
+++ b/.gitattributes
|
||||
@@ -29,10 +29,6 @@
|
||||
|
||||
/boot/menhir/parser.ml* -diff
|
||||
|
||||
-# configure is declared as binary so that it doesn't get included in diffs.
|
||||
-# This also means it will have the correct Unix line-endings, even on Windows.
|
||||
-/configure binary
|
||||
-
|
||||
# 'union' merge driver just unions textual content in case of conflict
|
||||
# http://krlmlr.github.io/using-gitattributes-to-avoid-merge-conflicts/
|
||||
/.mailmap merge=union
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 46230ada6483449154c465243edd80d9e539b73a Mon Sep 17 00:00:00 2001
|
||||
From 17f5c84a20466e9ef6f1821a45b88e6bb0df8102 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Nicol=C3=A1s=20Ojeda=20B=C3=A4r?= <n.oje.bar@gmail.com>
|
||||
Date: Mon, 18 Nov 2019 01:13:30 +0100
|
||||
Subject: [PATCH 12/13] Add riscv64 backend
|
||||
Subject: [PATCH 5/5] Add riscv64 backend
|
||||
|
||||
(cherry picked from commit c8a361f586c21eca25108ee79c495bb480a1c3f3)
|
||||
---
|
||||
@ -13,12 +13,12 @@ Subject: [PATCH 12/13] Add riscv64 backend
|
||||
asmcomp/riscv/reload.ml | 16 +
|
||||
asmcomp/riscv/scheduling.ml | 19 +
|
||||
asmcomp/riscv/selection.ml | 71 ++++
|
||||
configure | Bin 542985 -> 543184 bytes
|
||||
configure | 10 +-
|
||||
configure.ac | 11 +-
|
||||
runtime/caml/stack.h | 5 +
|
||||
runtime/riscv.S | 427 +++++++++++++++++++++
|
||||
testsuite/tools/asmgen_riscv.S | 87 +++++
|
||||
13 files changed, 1762 insertions(+), 3 deletions(-)
|
||||
13 files changed, 1770 insertions(+), 5 deletions(-)
|
||||
create mode 100644 asmcomp/riscv/CSE.ml
|
||||
create mode 100644 asmcomp/riscv/arch.ml
|
||||
create mode 100644 asmcomp/riscv/emit.mlp
|
||||
@ -1318,22 +1318,45 @@ index 000000000..62fccb648
|
||||
+
|
||||
+let fundecl f = (new selector)#emit_fundecl f
|
||||
diff --git a/configure b/configure
|
||||
index c364be4e3a365e01c667023ea23238037446a3c3..75f1d15cb6847544bdf00c5fd8d12ce958072e21 100755
|
||||
GIT binary patch
|
||||
delta 168
|
||||
zcmeC2q<CSnVnYjK3sVbo3(FQ(q4#V>nZ?OvTGQXWV%3~J?<K3)c8&L}uXzO&tgRK4
|
||||
zHMkTM!1BgM(+_@S6%zq-tQB(eQ&MwmVKRMxSjAbvoau#sSS6G&6`7e>D->52m!#&}
|
||||
m=49rTR!pz&Ws}`*@R#+WI9m-^c{{%-8xXT^=NIMpWefm-I6Vgd
|
||||
|
||||
delta 67
|
||||
zcmcaGS+R4HVnYjK3sVbo3(FQ(q4(40y<`>J9{!&7H7_IAbVhe}>Fw|SvOW@@t|-E$
|
||||
WI9*SajjjE^C<wD}|1ZjM(HH<?7Z~RN
|
||||
|
||||
index eb5f3a685..76fd3331b 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -13509,6 +13509,8 @@ if test x"$enable_shared" != "xno"; then :
|
||||
natdynlink=true ;; #(
|
||||
aarch64-*-freebsd*) :
|
||||
natdynlink=true ;; #(
|
||||
+ riscv*-*-linux*) :
|
||||
+ natdynlink=true ;; #(
|
||||
*) :
|
||||
;;
|
||||
esac
|
||||
@@ -13649,7 +13651,11 @@ fi; system=elf ;; #(
|
||||
aarch64-*-freebsd*) :
|
||||
arch=arm64; system=freebsd ;; #(
|
||||
x86_64-*-cygwin*) :
|
||||
- arch=amd64; system=cygwin
|
||||
+ arch=amd64; system=cygwin ;; #(
|
||||
+ riscv32-*-linux*) :
|
||||
+ arch=riscv; model=riscv32; system=linux ;; #(
|
||||
+ riscv64-*-linux*) :
|
||||
+ arch=riscv; model=riscv64; system=linux
|
||||
;; #(
|
||||
*) :
|
||||
;;
|
||||
@@ -13861,7 +13867,7 @@ esac ;; #(
|
||||
*,freebsd) :
|
||||
default_as="${toolpref}as"
|
||||
default_aspp="${toolpref}cc -c" ;; #(
|
||||
- amd64,*|arm,*|arm64,*|i386,*) :
|
||||
+ amd64,*|arm,*|arm64,*|i386,*|riscv,*) :
|
||||
default_as="${toolpref}as"
|
||||
case $ocaml_cv_cc_vendor in #(
|
||||
clang-*) :
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 9ee8dcaae..070944e7a 100644
|
||||
index ed6e0b0ca..0a1ad8f86 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -800,7 +800,8 @@ AS_IF([test x"$enable_shared" != "xno"],
|
||||
@@ -841,7 +841,8 @@ AS_IF([test x"$enable_shared" != "xno"],
|
||||
[arm*-*-freebsd*], [natdynlink=true],
|
||||
[earm*-*-netbsd*], [natdynlink=true],
|
||||
[aarch64-*-linux*], [natdynlink=true],
|
||||
@ -1343,7 +1366,7 @@ index 9ee8dcaae..070944e7a 100644
|
||||
|
||||
# Try to work around the Skylake/Kaby Lake processor bug.
|
||||
AS_CASE(["$CC,$host"],
|
||||
@@ -891,7 +892,11 @@ AS_CASE([$host],
|
||||
@@ -934,7 +935,11 @@ AS_CASE([$host],
|
||||
[aarch64-*-freebsd*],
|
||||
[arch=arm64; system=freebsd],
|
||||
[x86_64-*-cygwin*],
|
||||
@ -1356,7 +1379,7 @@ index 9ee8dcaae..070944e7a 100644
|
||||
)
|
||||
|
||||
AS_IF([test x"$enable_native_compiler" = "xno"],
|
||||
@@ -977,7 +982,7 @@ AS_CASE(["$arch,$system"],
|
||||
@@ -1020,7 +1025,7 @@ AS_CASE(["$arch,$system"],
|
||||
[*,freebsd],
|
||||
[default_as="${toolpref}as"
|
||||
default_aspp="${toolpref}cc -c"],
|
||||
@ -1366,7 +1389,7 @@ index 9ee8dcaae..070944e7a 100644
|
||||
AS_CASE([$ocaml_cv_cc_vendor],
|
||||
[clang-*], [default_aspp="${toolpref}clang -c -Wno-trigraphs"],
|
||||
diff --git a/runtime/caml/stack.h b/runtime/caml/stack.h
|
||||
index 0c4aab159..20945a900 100644
|
||||
index cb8b77922..1d1305c8d 100644
|
||||
--- a/runtime/caml/stack.h
|
||||
+++ b/runtime/caml/stack.h
|
||||
@@ -70,6 +70,11 @@
|
||||
@ -1908,5 +1931,5 @@ index 000000000..8b34a40f8
|
||||
+caml_c_call:
|
||||
+ jr t2
|
||||
--
|
||||
2.23.0
|
||||
2.24.1
|
||||
|
@ -1,51 +0,0 @@
|
||||
From 3ef8ce701db0a010771c62171fc7ae355214ed05 Mon Sep 17 00:00:00 2001
|
||||
From: David Allsopp <david.allsopp@metastack.com>
|
||||
Date: Thu, 26 Sep 2019 13:51:08 +0100
|
||||
Subject: [PATCH 05/13] Run whole of gen_primitives.sh with LC_ALL=C
|
||||
|
||||
Fixes #8985. Assuming the locale has been generated, running
|
||||
LC_COLLATE=sv_SE.UTF-8 make world failed previously since the w
|
||||
character is not matched in [a-z] in this locale.
|
||||
---
|
||||
Changes | 4 ++++
|
||||
runtime/gen_primitives.sh | 5 ++++-
|
||||
2 files changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index 63cac3ef9..257a75e3d 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -8,6 +8,10 @@ OCaml 4.09 maintenance branch:
|
||||
- #8965, #8979: Alpine build failure caused by check-parser-uptodate-or-warn.sh
|
||||
(Gabriel Scherer and David Allsopp, report by Anton Kochkov)
|
||||
|
||||
+- #8985, #8986: fix generation of the primitives when the locale collation is
|
||||
+ incompatible with C.
|
||||
+ (David Allsopp, review by Nicolás Ojeda Bär, report by Sebastian Rasmussen)
|
||||
+
|
||||
OCaml 4.09.0 (19 September 2019):
|
||||
---------------------------------
|
||||
|
||||
diff --git a/runtime/gen_primitives.sh b/runtime/gen_primitives.sh
|
||||
index e3ca2779b..63365a7fb 100755
|
||||
--- a/runtime/gen_primitives.sh
|
||||
+++ b/runtime/gen_primitives.sh
|
||||
@@ -17,6 +17,9 @@
|
||||
|
||||
# duplicated from $(ROOTDIR)/runtime/Makefile
|
||||
|
||||
+# #8985: the meaning of character range a-z depends on the locale, so force C
|
||||
+# locale throughout.
|
||||
+export LC_ALL=C
|
||||
(
|
||||
for prim in \
|
||||
alloc array compare extern floats gc_ctrl hash intern interp ints io \
|
||||
@@ -27,4 +30,4 @@
|
||||
done
|
||||
sed -n -e 's/^CAMLprim_int64_[0-9](\([a-z0-9_][a-z0-9_]*\)).*/caml_int64_\1\
|
||||
caml_int64_\1_native/p' ints.c
|
||||
-) | LC_ALL=C sort | uniq
|
||||
+) | sort | uniq
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 8995e5828ebfe933b74d0c3704c0524a63c73467 Mon Sep 17 00:00:00 2001
|
||||
From: Florian Angeletti <florian.angeletti@inria.fr>
|
||||
Date: Fri, 27 Sep 2019 17:15:26 +0200
|
||||
Subject: [PATCH 06/13] Merge pull request #8988 from Octachron/fix_ocamlnat
|
||||
|
||||
Fix ocamlnat
|
||||
|
||||
(cherry picked from commit afb90bdf7476a92c024eee2e5745ed85200c654b)
|
||||
---
|
||||
toplevel/opttoploop.ml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/toplevel/opttoploop.ml b/toplevel/opttoploop.ml
|
||||
index 0d1f73921..0174a9ab5 100644
|
||||
--- a/toplevel/opttoploop.ml
|
||||
+++ b/toplevel/opttoploop.ml
|
||||
@@ -257,7 +257,7 @@ let load_lambda ppf ~module_ident ~required_globals lam size =
|
||||
else
|
||||
Asmgen.compile_implementation_flambda
|
||||
~required_globals ~backend ~toplevel:need_symbol fn ~ppf_dump:ppf
|
||||
- (Flambda_middle_end.middle_end ~ppf_dump:ppf ~prefixname:"" ~backend ~size
|
||||
+ (Flambda_middle_end.middle_end ~ppf_dump:ppf ~prefixname:fn ~backend ~size
|
||||
~module_ident ~module_initializer:slam ~filename:"toplevel");
|
||||
Asmlink.call_linker_shared [fn ^ ext_obj] dll;
|
||||
Sys.remove (fn ^ ext_obj);
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,45 +0,0 @@
|
||||
From fa36269c5752bfb8f4b65dd0f9a2dd8f9c9eeb8f Mon Sep 17 00:00:00 2001
|
||||
From: David Allsopp <david.allsopp@metastack.com>
|
||||
Date: Tue, 6 Aug 2019 09:23:06 +0100
|
||||
Subject: [PATCH 07/13] Fix failure to install tools links
|
||||
|
||||
In --disable-installing-bytecode-programs mode, the .opt version of the
|
||||
tools is installed, but the symlink for the tool itself is not created.
|
||||
|
||||
(cherry picked from commit 705739fa54260b7a0e6cbba0b5a99e52c79f9c09)
|
||||
---
|
||||
Changes | 5 +++++
|
||||
tools/Makefile | 1 +
|
||||
2 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index 257a75e3d..3fdc31a5f 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -1,6 +1,11 @@
|
||||
OCaml 4.09 maintenance branch:
|
||||
------------------------------
|
||||
|
||||
+- #8855, #8858: Links for tools not created when installing with
|
||||
+ --disable-installing-byecode-programs (e.g. ocamldep.opt installed, but
|
||||
+ ocamldep link not created)
|
||||
+ (David Allsopp, report by Thomas Leonard)
|
||||
+
|
||||
- #8953, #8954: Fix error submessages in the toplevel: do not display
|
||||
dummy locations
|
||||
(Armaël Guéneau, review by Gabriel Scherer)
|
||||
diff --git a/tools/Makefile b/tools/Makefile
|
||||
index afefc4d83..84ddd79fb 100644
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -242,6 +242,7 @@ else
|
||||
do \
|
||||
if test -f "$$i".opt; then \
|
||||
$(INSTALL_PROG) "$$i.opt" "$(INSTALL_BINDIR)/$$i.opt$(EXE)"; \
|
||||
+ (cd "$(INSTALL_BINDIR)/" && $(LN) "$$i.opt$(EXE)" "$$i$(EXE)"); \
|
||||
fi; \
|
||||
done
|
||||
endif
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 308ea9a8d526160e2b45f16d63a0aee70984b814 Mon Sep 17 00:00:00 2001
|
||||
From: Gabriel Scherer <gabriel.scherer@gmail.com>
|
||||
Date: Sun, 29 Sep 2019 19:33:29 +0200
|
||||
Subject: [PATCH 08/13] Merge pull request #8996 from dra27/win-reconfigure
|
||||
|
||||
Windows supports make reconfigure now
|
||||
|
||||
(cherry picked from commit c71997a167c3670d202c6ecaf830c6a25b4b95b8)
|
||||
---
|
||||
Makefile | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 7ac446f62..90583f1bc 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -326,11 +326,9 @@ endif
|
||||
utils/config.ml: utils/config.mlp Makefile.config utils/Makefile Makefile
|
||||
$(MAKE) -C utils config.ml
|
||||
|
||||
-ifeq "$(UNIX_OR_WIN32)" "unix"
|
||||
.PHONY: reconfigure
|
||||
reconfigure:
|
||||
./configure $(CONFIGURE_ARGS)
|
||||
-endif
|
||||
|
||||
.PHONY: partialclean
|
||||
partialclean::
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,41 +0,0 @@
|
||||
From 76a56065047f9160b0db2491c8f303c9dee6cb59 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 5 Dec 2019 18:07:29 +0000
|
||||
Subject: [PATCH 13/13] Revert "increment version number after tagging 4.09.0"
|
||||
|
||||
Downgrade version number back to 4.09.0 for Fedora.
|
||||
|
||||
This reverts commit 6207460e793f8c5538bfd8164fa3078f7300b57a.
|
||||
---
|
||||
VERSION | 2 +-
|
||||
ocaml-variants.opam | 4 ++--
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/VERSION b/VERSION
|
||||
index ff541f87c..7128cac1f 100644
|
||||
--- a/VERSION
|
||||
+++ b/VERSION
|
||||
@@ -1,4 +1,4 @@
|
||||
-4.09.1+dev0
|
||||
+4.09.0
|
||||
|
||||
# The version string is the first line of this file.
|
||||
# It must be in the format described in stdlib/sys.mli
|
||||
diff --git a/ocaml-variants.opam b/ocaml-variants.opam
|
||||
index 5410d1f4c..30d48eb24 100644
|
||||
--- a/ocaml-variants.opam
|
||||
+++ b/ocaml-variants.opam
|
||||
@@ -1,8 +1,8 @@
|
||||
opam-version: "2.0"
|
||||
-version: "4.09.1+trunk"
|
||||
+version: "4.09.0"
|
||||
synopsis: "OCaml development version"
|
||||
depends: [
|
||||
- "ocaml" {= "4.09.1" & post}
|
||||
+ "ocaml" {= "4.09.0" & post}
|
||||
"base-unix" {post}
|
||||
"base-bigarray" {post}
|
||||
"base-threads" {post}
|
||||
--
|
||||
2.23.0
|
||||
|
36
ocaml.spec
36
ocaml.spec
@ -26,12 +26,11 @@
|
||||
# Architectures where parallel builds fail.
|
||||
#%global no_parallel_build_arches aarch64
|
||||
|
||||
%global rcver %{nil}
|
||||
#global rcver +rc2
|
||||
%global rcver +beta1
|
||||
|
||||
Name: ocaml
|
||||
Version: 4.09.0
|
||||
Release: 13%{?dist}
|
||||
Version: 4.10.0
|
||||
Release: 0.beta1.0%{?dist}
|
||||
|
||||
Summary: OCaml compiler and programming environment
|
||||
|
||||
@ -39,7 +38,7 @@ License: QPL and (LGPLv2+ with exceptions)
|
||||
|
||||
URL: http://www.ocaml.org
|
||||
|
||||
Source0: http://caml.inria.fr/pub/distrib/ocaml-4.09/ocaml-%{version}%{rcver}.tar.xz
|
||||
Source0: http://caml.inria.fr/pub/distrib/ocaml-4.10/ocaml-%{version}%{rcver}.tar.xz
|
||||
|
||||
# IMPORTANT NOTE:
|
||||
#
|
||||
@ -50,31 +49,22 @@ Source0: http://caml.inria.fr/pub/distrib/ocaml-4.09/ocaml-%{version}%{rc
|
||||
#
|
||||
# https://pagure.io/fedora-ocaml
|
||||
#
|
||||
# Current branch: fedora-32-4.09.0
|
||||
# Current branch: fedora-32-4.10.0-beta1
|
||||
#
|
||||
# ALTERNATIVELY add a patch to the end of the list (leaving the
|
||||
# existing patches unchanged) adding a comment to note that it should
|
||||
# be incorporated into the git repo at a later time.
|
||||
#
|
||||
|
||||
# Upstream patches after 4.09.0 was released.
|
||||
Patch0001: 0001-increment-version-number-after-tagging-4.09.0.patch
|
||||
Patch0002: 0002-mark-the-release-in-the-Changes.patch
|
||||
Patch0003: 0003-Merge-pull-request-8954-from-Armael-fix-toplevel-sub.patch
|
||||
Patch0004: 0004-Merge-pull-request-8979-from-gasche-fix-Makefile.men.patch
|
||||
Patch0005: 0005-Run-whole-of-gen_primitives.sh-with-LC_ALL-C.patch
|
||||
Patch0006: 0006-Merge-pull-request-8988-from-Octachron-fix_ocamlnat.patch
|
||||
Patch0007: 0007-Fix-failure-to-install-tools-links.patch
|
||||
Patch0008: 0008-Merge-pull-request-8996-from-dra27-win-reconfigure.patch
|
||||
# Fedora-specific downstream patches.
|
||||
Patch0009: 0009-Don-t-add-rpaths-to-libraries.patch
|
||||
Patch0010: 0010-configure-Allow-user-defined-C-compiler-flags.patch
|
||||
Patch0011: 0011-configure-Remove-incorrect-assumption-about-cross-co.patch
|
||||
Patch0001: 0001-Don-t-add-rpaths-to-libraries.patch
|
||||
Patch0002: 0002-configure-Allow-user-defined-C-compiler-flags.patch
|
||||
Patch0003: 0003-configure-Remove-incorrect-assumption-about-cross-co.patch
|
||||
Patch0004: 0004-Remove-configure-from-.gitattributes.patch
|
||||
# Out of tree patch for RISC-V support.
|
||||
# https://github.com/nojb/riscv-ocaml
|
||||
Patch0012: 0012-Add-riscv64-backend.patch
|
||||
# Resets the version number back to 4.09.0.
|
||||
Patch0013: 0013-Revert-increment-version-number-after-tagging-4.09.0.patch
|
||||
Patch0005: 0005-Add-riscv64-backend.patch
|
||||
|
||||
BuildRequires: git
|
||||
BuildRequires: gcc
|
||||
@ -378,10 +368,10 @@ find $RPM_BUILD_ROOT \( -name '*.cmt' -o -name '*.cmti' \) -a -delete
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jan 07 2020 Richard W.M. Jones <rjones@redhat.com> - 4.09.0-13
|
||||
- Bump release and rebuild.
|
||||
* Sat Jan 18 2020 Richard W.M. Jones <rjones@redhat.com> - 4.10.0-0.beta1
|
||||
- OCaml 4.10.0+beta1.
|
||||
|
||||
* Tue Jan 07 2020 Richard W.M. Jones <rjones@redhat.com> - 4.09.0-12
|
||||
* Tue Jan 07 2020 Richard W.M. Jones <rjones@redhat.com> - 4.09.0-13
|
||||
- Bump release and rebuild.
|
||||
|
||||
* Tue Jan 07 2020 Richard W.M. Jones <rjones@redhat.com> - 4.09.0-4
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ocaml-4.09.0.tar.xz) = 5cd745802ee53ab85ee676a20fbb28985ba68965df1d7242de5763d982b0a744951da742615fe478c4d3c98b34531632e3a71de89da6c717ccd90cc01e6fff26
|
||||
SHA512 (ocaml-4.10.0+beta1.tar.xz) = 97be0fcf6dee2309c43bca86ace21c83dc5b36bac34b70144a06f36883d7bd5bc457d3e95c6ac47a2ec5e3262058d3be39fc2559f118e4e6b58ec5970ffa88dc
|
||||
|
Loading…
Reference in New Issue
Block a user