Rebuild for major new upstream release of 3.11.0 for Fedora 11.
This commit is contained in:
parent
71268b23d4
commit
f7302e68d1
@ -1,4 +1,4 @@
|
||||
ocaml-3.10-refman.html.tar.gz
|
||||
ocaml-3.10-refman.info.tar.gz
|
||||
ocaml-3.10-refman.pdf
|
||||
ocaml-3.10.2.tar.bz2
|
||||
ocaml-3.11.0+beta1.tar.bz2
|
||||
ocaml-3.11-refman.html.tar.gz
|
||||
ocaml-3.11-refman.info.tar.gz
|
||||
ocaml-3.11-refman.pdf
|
||||
|
@ -1,35 +0,0 @@
|
||||
diff -up ocaml-3.10.0/otherlibs/labltk/support/cltkImg.c.tclver ocaml-3.10.0/otherlibs/labltk/support/cltkImg.c
|
||||
--- ocaml-3.10.0/otherlibs/labltk/support/cltkImg.c.tclver 2008-01-04 18:56:47.000000000 +0100
|
||||
+++ ocaml-3.10.0/otherlibs/labltk/support/cltkImg.c 2008-01-04 19:06:45.000000000 +0100
|
||||
@@ -98,7 +98,7 @@ camltk_setimgdata_native (value imgname,
|
||||
pib.offset[0] = 0;
|
||||
pib.offset[1] = 1;
|
||||
pib.offset[2] = 2;
|
||||
- Tk_PhotoPutBlock(ph,&pib,Int_val(x),Int_val(y),Int_val(w),Int_val(h)
|
||||
+ Tk_PhotoPutBlock(cltclinterp,ph,&pib,Int_val(x),Int_val(y),Int_val(w),Int_val(h)
|
||||
#if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 4 || TK_MAJOR_VERSION > 8)
|
||||
, TK_PHOTO_COMPOSITE_SET
|
||||
#endif
|
||||
diff -up ocaml-3.10.0/otherlibs/labltk/tkanim/tkAnimGIF.c.tclver ocaml-3.10.0/otherlibs/labltk/tkanim/tkAnimGIF.c
|
||||
--- ocaml-3.10.0/otherlibs/labltk/tkanim/tkAnimGIF.c.tclver 2008-01-04 19:08:28.000000000 +0100
|
||||
+++ ocaml-3.10.0/otherlibs/labltk/tkanim/tkAnimGIF.c 2008-01-04 19:08:37.000000000 +0100
|
||||
@@ -334,7 +334,7 @@ FileReadGIF(interp, f, fileName, formatS
|
||||
goto error;
|
||||
}
|
||||
}
|
||||
- Tk_PhotoPutBlock(photoHandle, &block, 0, 0, imageWidth, imageHeight
|
||||
+ Tk_PhotoPutBlock(interp, photoHandle, &block, 0, 0, imageWidth, imageHeight
|
||||
#if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 4 || TK_MAJOR_VERSION > 8)
|
||||
, TK_PHOTO_COMPOSITE_SET
|
||||
#endif
|
||||
diff -up ocaml-3.10.0/configure.tclver ocaml-3.10.0/configure
|
||||
--- ocaml-3.10.0/configure.tclver 2008-01-04 18:37:25.000000000 +0100
|
||||
+++ ocaml-3.10.0/configure 2008-01-04 18:38:54.000000000 +0100
|
||||
@@ -1342,6 +1342,7 @@ if test $has_tk = true; then
|
||||
8.2) tclmaj=8 tclmin=2 tkmaj=8 tkmin=2 ;;
|
||||
8.3) tclmaj=8 tclmin=3 tkmaj=8 tkmin=3 ;;
|
||||
8.4) tclmaj=8 tclmin=4 tkmaj=8 tkmin=4 ;;
|
||||
+ 8.5) tclmaj=8 tclmin=5 tkmaj=8 tkmin=5 ;;
|
||||
*) echo "This version is not known."; has_tk=false ;;
|
||||
esac
|
||||
else
|
@ -1,23 +0,0 @@
|
||||
diff -ur ocaml-3.10.1.orig/byterun/unix.c ocaml-3.10.1/byterun/unix.c
|
||||
--- ocaml-3.10.1.orig/byterun/unix.c 2007-11-20 15:47:41.000000000 +0000
|
||||
+++ ocaml-3.10.1/byterun/unix.c 2008-05-08 11:54:11.000000000 +0100
|
||||
@@ -346,6 +346,10 @@
|
||||
|
||||
#include <sys/mman.h>
|
||||
|
||||
+#ifndef MAP_32BIT /* Fedora bug 445545 */
|
||||
+#define MAP_32BIT 0
|
||||
+#endif
|
||||
+
|
||||
char *caml_aligned_mmap (asize_t size, int modulo, void **block)
|
||||
{
|
||||
char *raw_mem;
|
||||
@@ -354,7 +358,7 @@
|
||||
|
||||
Assert (modulo < Page_size);
|
||||
raw_mem = (char *) mmap(last_addr, size + Page_size, PROT_READ | PROT_WRITE,
|
||||
- MAP_PRIVATE | MAP_ANONYMOUS, -1, 0);
|
||||
+ MAP_32BIT | MAP_PRIVATE | MAP_ANONYMOUS, -1, 0);
|
||||
if (raw_mem == MAP_FAILED) return NULL;
|
||||
last_addr = raw_mem + size + 2 * Page_size;
|
||||
*block = raw_mem;
|
@ -1,299 +0,0 @@
|
||||
Index: asmcomp/alpha/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/alpha/emit.mlp,v
|
||||
retrieving revision 1.42
|
||||
diff -u -r1.42 emit.mlp
|
||||
--- asmcomp/alpha/emit.mlp 16 Apr 2006 23:28:14 -0000 1.42
|
||||
+++ asmcomp/alpha/emit.mlp 9 Jun 2008 17:34:32 -0000
|
||||
@@ -858,4 +858,6 @@
|
||||
`{emit_symbol lbl_frame}:\n`;
|
||||
` .quad {emit_int (List.length !frame_descriptors)}\n`;
|
||||
List.iter emit_frame !frame_descriptors;
|
||||
- frame_descriptors := []
|
||||
+ frame_descriptors := [];
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmcomp/amd64/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/amd64/emit.mlp,v
|
||||
retrieving revision 1.15
|
||||
diff -u -r1.15 emit.mlp
|
||||
--- asmcomp/amd64/emit.mlp 11 Jan 2008 16:13:11 -0000 1.15
|
||||
+++ asmcomp/amd64/emit.mlp 9 Jun 2008 17:34:32 -0000
|
||||
@@ -752,4 +752,6 @@
|
||||
efa_label_rel = (fun lbl ofs ->
|
||||
` .long ({emit_label lbl} - .) + {emit_int32 ofs}\n`);
|
||||
efa_def_label = (fun l -> `{emit_label l}:\n`);
|
||||
- efa_string = (fun s -> emit_string_directive " .asciz " s) }
|
||||
+ efa_string = (fun s -> emit_string_directive " .asciz " s) };
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmcomp/arm/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/arm/emit.mlp,v
|
||||
retrieving revision 1.19
|
||||
diff -u -r1.19 emit.mlp
|
||||
--- asmcomp/arm/emit.mlp 11 Jan 2008 16:13:11 -0000 1.19
|
||||
+++ asmcomp/arm/emit.mlp 9 Jun 2008 17:34:33 -0000
|
||||
@@ -673,4 +673,6 @@
|
||||
`{emit_symbol lbl}:\n`;
|
||||
` .word {emit_int (List.length !frame_descriptors)}\n`;
|
||||
List.iter emit_frame !frame_descriptors;
|
||||
- frame_descriptors := []
|
||||
+ frame_descriptors := [];
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmcomp/hppa/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/hppa/emit.mlp,v
|
||||
retrieving revision 1.20
|
||||
diff -u -r1.20 emit.mlp
|
||||
--- asmcomp/hppa/emit.mlp 16 Apr 2006 23:28:14 -0000 1.20
|
||||
+++ asmcomp/hppa/emit.mlp 9 Jun 2008 17:34:34 -0000
|
||||
@@ -1037,4 +1037,6 @@
|
||||
` .long {emit_int (List.length !frame_descriptors)}\n`;
|
||||
List.iter emit_frame !frame_descriptors;
|
||||
frame_descriptors := [];
|
||||
- emit_imports()
|
||||
+ emit_imports();
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmcomp/i386/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/i386/emit.mlp,v
|
||||
retrieving revision 1.40
|
||||
diff -u -r1.40 emit.mlp
|
||||
--- asmcomp/i386/emit.mlp 11 Jan 2008 16:13:11 -0000 1.40
|
||||
+++ asmcomp/i386/emit.mlp 9 Jun 2008 17:34:34 -0000
|
||||
@@ -986,4 +986,6 @@
|
||||
if use_ascii_dir
|
||||
then emit_string_directive " .ascii " s
|
||||
else emit_bytes_directive " .byte " s) };
|
||||
- if macosx then emit_external_symbols ()
|
||||
+ if macosx then emit_external_symbols ();
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmcomp/ia64/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/ia64/emit.mlp,v
|
||||
retrieving revision 1.17
|
||||
diff -u -r1.17 emit.mlp
|
||||
--- asmcomp/ia64/emit.mlp 13 Jul 2004 12:18:53 -0000 1.17
|
||||
+++ asmcomp/ia64/emit.mlp 9 Jun 2008 17:34:36 -0000
|
||||
@@ -1324,4 +1324,6 @@
|
||||
emit_define_symbol (Compilenv.make_symbol (Some "frametable"));
|
||||
` data8 {emit_int (List.length !frame_descriptors)}\n`;
|
||||
List.iter emit_frame !frame_descriptors;
|
||||
- frame_descriptors := []
|
||||
+ frame_descriptors := [];
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmcomp/mips/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/mips/emit.mlp,v
|
||||
retrieving revision 1.18
|
||||
diff -u -r1.18 emit.mlp
|
||||
--- asmcomp/mips/emit.mlp 5 Jan 2004 20:25:56 -0000 1.18
|
||||
+++ asmcomp/mips/emit.mlp 9 Jun 2008 17:34:36 -0000
|
||||
@@ -591,4 +591,6 @@
|
||||
`{emit_symbol lbl}:\n`;
|
||||
` .word {emit_int (List.length !frame_descriptors)}\n`;
|
||||
List.iter emit_frame !frame_descriptors;
|
||||
- frame_descriptors := []
|
||||
+ frame_descriptors := [];
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmcomp/power/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/power/emit.mlp,v
|
||||
retrieving revision 1.26
|
||||
diff -u -r1.26 emit.mlp
|
||||
--- asmcomp/power/emit.mlp 9 Nov 2007 15:06:57 -0000 1.26
|
||||
+++ asmcomp/power/emit.mlp 9 Jun 2008 17:34:37 -0000
|
||||
@@ -961,4 +961,6 @@
|
||||
` .long ({emit_label lbl} - .) + {emit_int32 ofs}\n`);
|
||||
efa_def_label = (fun l -> `{emit_label l}:\n`);
|
||||
efa_string = (fun s -> emit_bytes_directive " .byte " (s ^ "\000"))
|
||||
- }
|
||||
+ };
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmcomp/sparc/emit.mlp
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmcomp/sparc/emit.mlp,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 emit.mlp
|
||||
--- asmcomp/sparc/emit.mlp 16 Apr 2006 23:28:15 -0000 1.24
|
||||
+++ asmcomp/sparc/emit.mlp 9 Jun 2008 17:34:37 -0000
|
||||
@@ -772,4 +772,6 @@
|
||||
` .word {emit_int (List.length !frame_descriptors)}\n`;
|
||||
List.iter emit_frame !frame_descriptors;
|
||||
emit_size lbl;
|
||||
- frame_descriptors := []
|
||||
+ frame_descriptors := [];
|
||||
+ (* Mark stack as non-executable for GNU tools. *)
|
||||
+ ` .section .note.GNU-stack,\"\",%progbits; .previous\n`
|
||||
Index: asmrun/alpha.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/alpha.S,v
|
||||
retrieving revision 1.29
|
||||
diff -u -r1.29 alpha.S
|
||||
--- asmrun/alpha.S 3 Jan 2004 12:51:18 -0000 1.29
|
||||
+++ asmrun/alpha.S 9 Jun 2008 17:34:38 -0000
|
||||
@@ -438,3 +438,7 @@
|
||||
.word -1 /* negative frame size => use callback link */
|
||||
.word 0 /* no roots here */
|
||||
.align 3
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/amd64.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/amd64.S,v
|
||||
retrieving revision 1.11
|
||||
diff -u -r1.11 amd64.S
|
||||
--- asmrun/amd64.S 29 Jan 2007 12:10:52 -0000 1.11
|
||||
+++ asmrun/amd64.S 9 Jun 2008 17:34:38 -0000
|
||||
@@ -366,3 +366,7 @@
|
||||
.align 16
|
||||
caml_absf_mask:
|
||||
.quad 0x7FFFFFFFFFFFFFFF, 0xFFFFFFFFFFFFFFFF
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/arm.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/arm.S,v
|
||||
retrieving revision 1.16
|
||||
diff -u -r1.16 arm.S
|
||||
--- asmrun/arm.S 29 Feb 2008 14:21:21 -0000 1.16
|
||||
+++ asmrun/arm.S 9 Jun 2008 17:34:38 -0000
|
||||
@@ -342,3 +342,7 @@
|
||||
.short -1 /* negative frame size => use callback link */
|
||||
.short 0 /* no roots */
|
||||
.align 2
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/hppa.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/hppa.S,v
|
||||
retrieving revision 1.26
|
||||
diff -u -r1.26 hppa.S
|
||||
--- asmrun/hppa.S 16 Apr 2006 23:28:15 -0000 1.26
|
||||
+++ asmrun/hppa.S 9 Jun 2008 17:34:38 -0000
|
||||
@@ -532,3 +532,7 @@
|
||||
.long L104 + 3 /* return address into callback */
|
||||
.short -1 /* negative frame size => use callback link */
|
||||
.short 0 /* no roots */
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/i386.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/i386.S,v
|
||||
retrieving revision 1.49
|
||||
diff -u -r1.49 i386.S
|
||||
--- asmrun/i386.S 11 Jan 2008 16:13:11 -0000 1.49
|
||||
+++ asmrun/i386.S 9 Jun 2008 17:34:39 -0000
|
||||
@@ -424,3 +424,7 @@
|
||||
hlt ; hlt ; hlt ; hlt ; hlt
|
||||
.subsections_via_symbols
|
||||
#endif
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/ia64.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/ia64.S,v
|
||||
retrieving revision 1.13
|
||||
diff -u -r1.13 ia64.S
|
||||
--- asmrun/ia64.S 3 Jan 2004 12:51:19 -0000 1.13
|
||||
+++ asmrun/ia64.S 9 Jun 2008 17:34:39 -0000
|
||||
@@ -528,3 +528,7 @@
|
||||
|
||||
.common caml_saved_bsp#, 8, 8
|
||||
.common caml_saved_rnat#, 8, 8
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/m68k.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/m68k.S,v
|
||||
retrieving revision 1.15
|
||||
diff -u -r1.15 m68k.S
|
||||
--- asmrun/m68k.S 3 Jan 2004 12:51:19 -0000 1.15
|
||||
+++ asmrun/m68k.S 9 Jun 2008 17:34:39 -0000
|
||||
@@ -242,3 +242,7 @@
|
||||
.long L107 | return address into callback
|
||||
.word -1 | negative frame size => use callback link
|
||||
.word 0 | no roots here
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/power-aix.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/power-aix.S,v
|
||||
retrieving revision 1.15
|
||||
diff -u -r1.15 power-aix.S
|
||||
--- asmrun/power-aix.S 3 Jan 2004 12:51:19 -0000 1.15
|
||||
+++ asmrun/power-aix.S 9 Jun 2008 17:34:40 -0000
|
||||
@@ -511,3 +511,7 @@
|
||||
.csect caml_callback3_exn[DS]
|
||||
caml_callback3_exn:
|
||||
.long .caml_callback3_exn, TOC[tc0], 0
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/power-elf.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/power-elf.S,v
|
||||
retrieving revision 1.18
|
||||
diff -u -r1.18 power-elf.S
|
||||
--- asmrun/power-elf.S 3 Jan 2004 12:51:19 -0000 1.18
|
||||
+++ asmrun/power-elf.S 9 Jun 2008 17:34:40 -0000
|
||||
@@ -419,3 +419,6 @@
|
||||
.short -1 /* negative size count => use callback link */
|
||||
.short 0 /* no roots here */
|
||||
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/power-rhapsody.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/power-rhapsody.S,v
|
||||
retrieving revision 1.15
|
||||
diff -u -r1.15 power-rhapsody.S
|
||||
--- asmrun/power-rhapsody.S 29 Jan 2007 12:10:52 -0000 1.15
|
||||
+++ asmrun/power-rhapsody.S 9 Jun 2008 17:34:40 -0000
|
||||
@@ -472,3 +472,7 @@
|
||||
.short -1 /* negative size count => use callback link */
|
||||
.short 0 /* no roots here */
|
||||
.align X(2,3)
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
Index: asmrun/sparc.S
|
||||
===================================================================
|
||||
RCS file: /caml/ocaml/asmrun/sparc.S,v
|
||||
retrieving revision 1.26
|
||||
diff -u -r1.26 sparc.S
|
||||
--- asmrun/sparc.S 6 Oct 2004 06:33:25 -0000 1.26
|
||||
+++ asmrun/sparc.S 9 Jun 2008 17:34:41 -0000
|
||||
@@ -405,3 +405,7 @@
|
||||
.type Caml_raise_exception, #function
|
||||
.type Caml_system__frametable, #object
|
||||
#endif
|
||||
+
|
||||
+#if defined(__ELF__)
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
@ -14,7 +14,7 @@ diff -uNr ocaml-3.10.1/asmcomp/power64/arch.ml ocaml-3.10.1.ppc64/asmcomp/power6
|
||||
+(* *)
|
||||
+(***********************************************************************)
|
||||
+
|
||||
+(* $Id: arch.ml,v 1.11 2004/06/19 16:13:32 xleroy Exp $ *)
|
||||
+(* $Id: ocaml-3.11.0-ppc64.patch,v 1.1 2008/11/20 15:30:55 rjones Exp $ *)
|
||||
+
|
||||
+(* Specific operations for the PowerPC processor *)
|
||||
+
|
||||
@ -102,7 +102,7 @@ diff -uNr ocaml-3.10.1/asmcomp/power64/emit.mlp ocaml-3.10.1.ppc64/asmcomp/power
|
||||
+(* *)
|
||||
+(***********************************************************************)
|
||||
+
|
||||
+(* $Id: emit.mlp,v 1.21 2004/06/19 17:39:34 xleroy Exp $ *)
|
||||
+(* $Id: ocaml-3.11.0-ppc64.patch,v 1.1 2008/11/20 15:30:55 rjones Exp $ *)
|
||||
+
|
||||
+(* Emission of PowerPC assembly code *)
|
||||
+
|
||||
@ -1095,7 +1095,7 @@ diff -uNr ocaml-3.10.1/asmcomp/power64/proc.ml ocaml-3.10.1.ppc64/asmcomp/power6
|
||||
+(* *)
|
||||
+(***********************************************************************)
|
||||
+
|
||||
+(* $Id: proc.ml,v 1.12 2004/06/19 17:39:35 xleroy Exp $ *)
|
||||
+(* $Id: ocaml-3.11.0-ppc64.patch,v 1.1 2008/11/20 15:30:55 rjones Exp $ *)
|
||||
+
|
||||
+(* Description of the Power PC *)
|
||||
+
|
||||
@ -1344,7 +1344,7 @@ diff -uNr ocaml-3.10.1/asmcomp/power64/reload.ml ocaml-3.10.1.ppc64/asmcomp/powe
|
||||
+(* *)
|
||||
+(***********************************************************************)
|
||||
+
|
||||
+(* $Id: reload.ml,v 1.3 1999/11/17 18:56:46 xleroy Exp $ *)
|
||||
+(* $Id: ocaml-3.11.0-ppc64.patch,v 1.1 2008/11/20 15:30:55 rjones Exp $ *)
|
||||
+
|
||||
+(* Reloading for the PowerPC *)
|
||||
+
|
||||
@ -1366,7 +1366,7 @@ diff -uNr ocaml-3.10.1/asmcomp/power64/scheduling.ml ocaml-3.10.1.ppc64/asmcomp/
|
||||
+(* *)
|
||||
+(***********************************************************************)
|
||||
+
|
||||
+(* $Id: scheduling.ml,v 1.6 2004/06/19 16:13:33 xleroy Exp $ *)
|
||||
+(* $Id: ocaml-3.11.0-ppc64.patch,v 1.1 2008/11/20 15:30:55 rjones Exp $ *)
|
||||
+
|
||||
+(* Instruction scheduling for the Power PC *)
|
||||
+
|
||||
@ -1436,7 +1436,7 @@ diff -uNr ocaml-3.10.1/asmcomp/power64/selection.ml ocaml-3.10.1.ppc64/asmcomp/p
|
||||
+(* *)
|
||||
+(***********************************************************************)
|
||||
+
|
||||
+(* $Id: selection.ml,v 1.6 2004/06/19 16:13:33 xleroy Exp $ *)
|
||||
+(* $Id: ocaml-3.11.0-ppc64.patch,v 1.1 2008/11/20 15:30:55 rjones Exp $ *)
|
||||
+
|
||||
+(* Instruction selection for the Power PC processor *)
|
||||
+
|
||||
@ -1560,7 +1560,7 @@ diff -uNr ocaml-3.10.1/asmrun/power64-elf.S ocaml-3.10.1.ppc64/asmrun/power64-el
|
||||
+/* */
|
||||
+/*********************************************************************/
|
||||
+
|
||||
+/* $Id: power-elf.S,v 1.18 2004/01/03 12:51:19 doligez Exp $ */
|
||||
+/* $Id: ocaml-3.11.0-ppc64.patch,v 1.1 2008/11/20 15:30:55 rjones Exp $ */
|
||||
+
|
||||
+#define Addrglobal(reg,glob) \
|
||||
+ addis reg, 0, glob@ha; \
|
||||
@ -2052,18 +2052,18 @@ diff -uNr ocaml-3.10.1/asmrun/stack.h ocaml-3.10.1.ppc64/asmrun/stack.h
|
||||
#ifdef TARGET_m68k
|
||||
#define Saved_return_address(sp) *((intnat *)((sp) - 4))
|
||||
#define Callback_link(sp) ((struct caml_context *)((sp) + 8))
|
||||
diff -uNr ocaml-3.10.1/configure ocaml-3.10.1.ppc64/configure
|
||||
--- ocaml-3.10.1/configure 2008-01-04 08:26:38.000000000 -0500
|
||||
+++ ocaml-3.10.1.ppc64/configure 2008-02-29 09:07:05.000000000 -0500
|
||||
@@ -590,6 +590,7 @@
|
||||
diff -uNr ocaml-3.11.0+beta1/configure ocaml-3.11.0+beta1.ppc64/configure
|
||||
--- ocaml-3.11.0+beta1/configure.ppc64 2008-11-18 15:46:57.000000000 +0000
|
||||
+++ ocaml-3.11.0+beta1/configure 2008-11-18 15:49:19.000000000 +0000
|
||||
@@ -632,6 +632,7 @@
|
||||
hppa2.0*-*-hpux*) arch=hppa; system=hpux;;
|
||||
hppa*-*-linux*) arch=hppa; system=linux;;
|
||||
hppa*-*-gnu*) arch=hppa; system=gnu;;
|
||||
+ powerpc64-*-linux*) arch=power64; model=ppc64; system=elf;;
|
||||
powerpc*-*-linux*) arch=power; model=ppc; system=elf;;
|
||||
powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
|
||||
powerpc-*-rhapsody*) arch=power; model=ppc; system=rhapsody;;
|
||||
powerpc-*-darwin*) arch=power; system=rhapsody
|
||||
@@ -612,7 +613,7 @@
|
||||
@@ -655,7 +656,7 @@
|
||||
|
||||
if $arch64; then
|
||||
case "$arch,$model" in
|
||||
@ -2072,11 +2072,12 @@ diff -uNr ocaml-3.10.1/configure ocaml-3.10.1.ppc64/configure
|
||||
arch=none; model=default; system=unknown;;
|
||||
esac
|
||||
fi
|
||||
@@ -670,6 +671,7 @@
|
||||
i386,*,*) aspp='gcc'; asppflags='-c -DSYS_$(SYSTEM)';;
|
||||
hppa,*,*) aspp="$cc"; asppflags='-traditional -c -DSYS_$(SYSTEM)';;
|
||||
power,*,elf) aspp='gcc'; asppflags='-c';;
|
||||
+ power64,*,elf) aspp='gcc'; asppflags='-c';;
|
||||
power,*,bsd) aspp='gcc'; asppflags='-c -DSYS_$(SYSTEM)';;
|
||||
power,*,rhapsody) aspp="$bytecc"; asppflags='-c';;
|
||||
arm,*,linux) aspp='gcc'; asppflags='-c -DSYS_$(SYSTEM)';;
|
||||
@@ -712,6 +713,8 @@
|
||||
aspp='as -n32 -O2';;
|
||||
power,*,elf) as='as -u -m ppc'
|
||||
aspp='gcc -c';;
|
||||
+ power64,*,elf) as='as -u -m ppc64'
|
||||
+ aspp='gcc -c';;
|
||||
power,*,bsd) as='as'
|
||||
aspp='gcc -c';;
|
||||
power,*,rhapsody) as="as -arch $model"
|
12
ocaml-3.11.0-rpath.patch
Normal file
12
ocaml-3.11.0-rpath.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- ocaml-3.11.0+beta1.orig/tools/Makefile.shared 2007-11-22 22:14:43.000000000 +0000
|
||||
+++ ocaml-3.11.0+beta1/tools/Makefile.shared 2008-11-18 15:42:44.000000000 +0000
|
||||
@@ -107,9 +107,6 @@
|
||||
sed -e "s|%%BINDIR%%|$(BINDIR)|" \
|
||||
-e "s|%%SUPPORTS_SHARED_LIBRARIES%%|$(SUPPORTS_SHARED_LIBRARIES)|" \
|
||||
-e "s|%%MKSHAREDLIB%%|$(MKSHAREDLIB)|" \
|
||||
- -e "s|%%BYTECCRPATH%%|$(BYTECCRPATH)|" \
|
||||
- -e "s|%%NATIVECCRPATH%%|$(NATIVECCRPATH)|" \
|
||||
- -e "s|%%MKSHAREDLIBRPATH%%|$(MKSHAREDLIBRPATH)|" \
|
||||
-e "s|%%RANLIB%%|$(RANLIB)|" \
|
||||
ocamlmklib.mlp >> ocamlmklib.ml
|
||||
|
@ -1,7 +1,7 @@
|
||||
#!/bin/sh -
|
||||
# OCaml-specific "find-requires" for RPM.
|
||||
# By Richard W.M. Jones <rjones@redhat.com>
|
||||
# $Id: ocaml-find-requires.sh,v 1.2 2007/09/03 14:35:10 rjones Exp $
|
||||
# $Id: ocaml-find-requires.sh,v 1.3 2007/09/06 11:49:59 rjones Exp $
|
||||
|
||||
#set -x
|
||||
|
||||
@ -63,6 +63,7 @@ while read md5sum module; do
|
||||
echo "ocaml($module) = $md5sum"
|
||||
done |
|
||||
grep -Ev "$ignore_modules_re" |
|
||||
grep -Ev "^ocaml\((Annot|Asttypes|Outcometree|Cmo_format|Parsetree)\) =" |
|
||||
sort -u
|
||||
|
||||
if [ -n "$emit_compiler_version" ]; then
|
||||
|
48
ocaml.spec
48
ocaml.spec
@ -1,27 +1,39 @@
|
||||
%define _default_patch_fuzz 2
|
||||
|
||||
Name: ocaml
|
||||
Version: 3.10.2
|
||||
Release: 5%{?dist}
|
||||
Version: 3.11.0+beta1
|
||||
Release: 1%{?dist}
|
||||
|
||||
Summary: Objective Caml compiler and programming environment
|
||||
|
||||
Group: Development/Languages
|
||||
License: QPL and (LGPLv2+ with exceptions)
|
||||
|
||||
URL: http://www.ocaml.org
|
||||
Source0: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-%{version}.tar.bz2
|
||||
Source1: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.10-refman.html.tar.gz
|
||||
Source2: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.10-refman.pdf
|
||||
Source3: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.10-refman.info.tar.gz
|
||||
|
||||
Source0: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-%{version}.tar.bz2
|
||||
Source1: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-3.11-refman.html.tar.gz
|
||||
Source2: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-3.11-refman.pdf
|
||||
Source3: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-3.11-refman.info.tar.gz
|
||||
Source4: ocaml-find-requires.sh
|
||||
Source5: ocaml-find-provides.sh
|
||||
Patch0: ocaml-rpath.patch
|
||||
|
||||
Patch0: ocaml-3.11.0-rpath.patch
|
||||
Patch1: ocaml-user-cflags.patch
|
||||
Patch2: ocaml-3.10.0-tclver.patch
|
||||
Patch3: ocaml-3.10.1-ppc64.patch
|
||||
Patch4: ocaml-3.10.1-map32bit.patch
|
||||
Patch5: ocaml-3.11-dev12-no-executable-stack.patch
|
||||
|
||||
# Not needed, this is upstream since 3.11.0:
|
||||
#Patch2: ocaml-3.10.0-tclver.patch
|
||||
|
||||
# Support for PPC64 platform by David Woodhouse:
|
||||
Patch3: ocaml-3.11.0-ppc64.patch
|
||||
|
||||
# Not needed because the GC allocator was completely rewritten:
|
||||
#Patch4: ocaml-3.10.1-map32bit.patch
|
||||
# A similar fix went upstream in 3.11.0:
|
||||
#Patch5: ocaml-3.11-dev12-no-executable-stack.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: gdbm-devel
|
||||
BuildRequires: tcl-devel
|
||||
@ -49,9 +61,10 @@ Provides: ocaml(compiler) = %{version}
|
||||
ExclusiveArch: alpha armv4l %{ix86} ia64 x86_64 ppc sparc ppc64
|
||||
|
||||
%define _use_internal_dependency_generator 0
|
||||
%define __find_requires %{SOURCE4} -i Asttypes -i Outcometree -i Cmo_format -i Parsetree -c -f %{buildroot}%{_bindir}/ocamlobjinfo
|
||||
%define __find_requires %{SOURCE4} -c -f %{buildroot}%{_bindir}/ocamlobjinfo
|
||||
%define __find_provides %{SOURCE5} -f %{buildroot}%{_bindir}/ocamlobjinfo
|
||||
|
||||
|
||||
%description
|
||||
Objective Caml is a high-level, strongly-typed, functional and
|
||||
object-oriented programming language from the ML family of languages.
|
||||
@ -189,10 +202,10 @@ man pages and info files.
|
||||
%setup -q -T -D -a 3
|
||||
%patch0 -p1 -b .rpath
|
||||
%patch1 -p1 -b .cflags
|
||||
%patch2 -p1 -b .tclver
|
||||
#%patch2 -p1 -b .tclver
|
||||
%patch3 -p1 -b .ppc64
|
||||
%patch4 -p1 -b .map32bit
|
||||
%patch5 -p0 -b .noexecstack
|
||||
#%patch4 -p1 -b .map32bit
|
||||
#%patch5 -p0 -b .noexecstack
|
||||
|
||||
cp %{SOURCE2} refman.pdf
|
||||
|
||||
@ -295,10 +308,12 @@ fi
|
||||
%{_libdir}/ocaml/ld.conf
|
||||
%{_libdir}/ocaml/Makefile.config
|
||||
%{_libdir}/ocaml/*.a
|
||||
%{_libdir}/ocaml/*.cmxs
|
||||
%{_libdir}/ocaml/*.cmxa
|
||||
%{_libdir}/ocaml/*.cmx
|
||||
%{_libdir}/ocaml/*.mli
|
||||
%{_libdir}/ocaml/*.o
|
||||
%{_libdir}/ocaml/libcamlrun_shared.so
|
||||
%{_libdir}/ocaml/vmthreads/*.mli
|
||||
%{_libdir}/ocaml/vmthreads/*.a
|
||||
%{_libdir}/ocaml/threads/*.a
|
||||
@ -431,6 +446,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Nov 18 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11.0+beta1-1
|
||||
- Rebuild for major new upstream release of 3.11.0 for Fedora 11.
|
||||
|
||||
* Thu Aug 29 2008 Richard W.M. Jones <rjones@redhat.com> - 3.10.2-5
|
||||
- Rebuild with patch fuzz.
|
||||
|
||||
|
8
sources
8
sources
@ -1,4 +1,4 @@
|
||||
663b31c8ea364a531aa325a5b06a2763 ocaml-3.10-refman.html.tar.gz
|
||||
f80b52b8bc4b10ed557808fc899acf3a ocaml-3.10-refman.info.tar.gz
|
||||
c3e00bc2c4aad3f538b4bcefade98908 ocaml-3.10-refman.pdf
|
||||
d86f8f8aa4574fa60dd6f89044580307 ocaml-3.10.2.tar.bz2
|
||||
77cc67933e451354b6d1ef0ace4f5dc5 ocaml-3.11.0+beta1.tar.bz2
|
||||
7e20778259f87ab5e7cb60d2a17c657c ocaml-3.11-refman.html.tar.gz
|
||||
3fcfedf63a852f502a10eac547c9042d ocaml-3.11-refman.info.tar.gz
|
||||
076a163e511e575fc384ad96394760a2 ocaml-3.11-refman.pdf
|
||||
|
Loading…
Reference in New Issue
Block a user