New upstream version 3.12.1.
This commit is contained in:
parent
bf42ecab33
commit
a334c49ca0
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ ocaml-3.11.2.tar.bz2
|
||||
/ocaml-3.12-refman.html.tar.gz
|
||||
/ocaml-3.12-refman.info.tar.gz
|
||||
/ocaml-3.12-refman.pdf
|
||||
/ocaml-3.12.1.tar.gz
|
||||
|
@ -1,66 +0,0 @@
|
||||
From: Stephane Glondu <steph@glondu.net>
|
||||
Date: Tue, 8 Mar 2011 21:17:40 +0100
|
||||
Subject: [PATCH] Fix ocamlopt w.r.t. binutils 2.21
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Bug: http://caml.inria.fr/mantis/view.php?id=5237
|
||||
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=617404
|
||||
Authors: Eric Cooper, spiralvoice
|
||||
Reviewed-by: Stéphane Glondu <steph@glondu.net>
|
||||
---
|
||||
asmcomp/amd64/emit.mlp | 13 +++++++------
|
||||
asmcomp/i386/emit.mlp | 6 +++---
|
||||
2 files changed, 10 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/asmcomp/amd64/emit.mlp b/asmcomp/amd64/emit.mlp
|
||||
index 4a3f844..525c6e6 100644
|
||||
--- a/asmcomp/amd64/emit.mlp
|
||||
+++ b/asmcomp/amd64/emit.mlp
|
||||
@@ -679,17 +679,18 @@ let fundecl fundecl =
|
||||
emit_all true fundecl.fun_body;
|
||||
List.iter emit_call_gc !call_gc_sites;
|
||||
emit_call_bound_errors ();
|
||||
+ begin match Config.system with
|
||||
+ "linux" | "gnu" ->
|
||||
+ ` .type {emit_symbol fundecl.fun_name},@function\n`;
|
||||
+ ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
|
||||
+ | _ -> ()
|
||||
+ end;
|
||||
if !float_constants <> [] then begin
|
||||
if macosx
|
||||
then ` .literal8\n`
|
||||
else ` .section .rodata.cst8,\"a\",@progbits\n`;
|
||||
List.iter emit_float_constant !float_constants
|
||||
- end;
|
||||
- match Config.system with
|
||||
- "linux" | "gnu" ->
|
||||
- ` .type {emit_symbol fundecl.fun_name},@function\n`;
|
||||
- ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
|
||||
- | _ -> ()
|
||||
+ end
|
||||
|
||||
(* Emission of data *)
|
||||
|
||||
diff --git a/asmcomp/i386/emit.mlp b/asmcomp/i386/emit.mlp
|
||||
index 2992f29..0b1252c 100644
|
||||
--- a/asmcomp/i386/emit.mlp
|
||||
+++ b/asmcomp/i386/emit.mlp
|
||||
@@ -905,12 +905,12 @@ let fundecl fundecl =
|
||||
emit_all true fundecl.fun_body;
|
||||
List.iter emit_call_gc !call_gc_sites;
|
||||
emit_call_bound_errors ();
|
||||
- List.iter emit_float_constant !float_constants;
|
||||
- match Config.system with
|
||||
+ begin match Config.system with
|
||||
"linux_elf" | "bsd_elf" | "gnu" ->
|
||||
` .type {emit_symbol fundecl.fun_name},@function\n`;
|
||||
` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
|
||||
- | _ -> ()
|
||||
+ | _ -> () end;
|
||||
+ List.iter emit_float_constant !float_constants
|
||||
|
||||
|
||||
(* Emission of data *)
|
||||
--
|
11
ocaml.spec
11
ocaml.spec
@ -1,8 +1,8 @@
|
||||
%global _default_patch_fuzz 2
|
||||
|
||||
Name: ocaml
|
||||
Version: 3.12.0
|
||||
Release: 7%{?dist}
|
||||
Version: 3.12.1
|
||||
Release: 1%{?dist}
|
||||
|
||||
Summary: Objective Caml compiler and programming environment
|
||||
|
||||
@ -24,9 +24,6 @@ Source6: ocamlbyteinfo.ml
|
||||
Patch0: ocaml-3.12.0-rpath.patch
|
||||
Patch1: ocaml-user-cflags.patch
|
||||
|
||||
# Fix for RHBZ#691896. This is upstream in 3.12.1.
|
||||
Patch2: 0007-Fix-ocamlopt-w.r.t.-binutils-2.21.patch
|
||||
|
||||
# Patch from Debian for ARM (sent upstream).
|
||||
Patch3: debian_patches_0013-ocamlopt-arm-add-.type-directive-for-code-symbols.patch
|
||||
|
||||
@ -221,7 +218,6 @@ man pages and info files.
|
||||
%setup -q -T -D -a 3 -n %{name}-%{version}
|
||||
%patch0 -p1 -b .rpath
|
||||
%patch1 -p1 -b .cflags
|
||||
%patch2 -p1 -b .rhbz691896
|
||||
%patch3 -p1 -b .arm-type-dir
|
||||
|
||||
cp %{SOURCE2} refman.pdf
|
||||
@ -490,6 +486,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 6 2012 Richard W.M. Jones <rjones@redhat.com> - 3.12.1-1
|
||||
- New upstream version 3.12.1. This is a bugfix update.
|
||||
|
||||
* Thu Dec 8 2011 Richard W.M. Jones <rjones@redhat.com> - 3.12.0-7
|
||||
- Allow this package to be compiled on platforms without native
|
||||
support and/or natdynlink, specifically ppc64. This updates (and
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
3ba7cc65123c3579f14e7c726d3ee782 ocaml-3.12.0.tar.gz
|
||||
93cd91f525441eb7e94cc49b9b64bab0 ocaml-3.12-refman.html.tar.gz
|
||||
8cf24c4f69c6f9c9f9cc1edb9b18f6cb ocaml-3.12-refman.info.tar.gz
|
||||
79fe5b86e0d6462e3e944fd8c47603ac ocaml-3.12-refman.pdf
|
||||
814a047085f0f901ab7d8e3a4b7a9e65 ocaml-3.12.1.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user