3.11.1 release candidate 0.
This commit is contained in:
parent
ee837aa25d
commit
9f89b6c018
@ -1,6 +1,4 @@
|
||||
ocaml-3.11.0+beta1.tar.bz2
|
||||
ocaml-3.11-refman.html.tar.gz
|
||||
ocaml-3.11-refman.info.tar.gz
|
||||
ocaml-3.11-refman.pdf
|
||||
ocaml-3.11.0+rc1.tar.bz2
|
||||
ocaml-3.11.0.tar.bz2
|
||||
ocaml-3.11.1+rc0.tar.gz
|
||||
|
@ -1,47 +0,0 @@
|
||||
--- ocaml/stdlib/string.ml 2008/07/22 11:29:00 1.28
|
||||
+++ ocaml/stdlib/string.ml 2008/11/18 10:29:26 1.29
|
||||
@@ -11,7 +11,7 @@
|
||||
(* *)
|
||||
(***********************************************************************)
|
||||
|
||||
-(* $Id: ocaml-3.11.0-string-index-from.patch,v 1.1 2008/11/20 17:52:37 rjones Exp $ *)
|
||||
+(* $Id: ocaml-3.11.0-string-index-from.patch,v 1.1 2008/11/20 17:52:37 rjones Exp $ *)
|
||||
|
||||
(* String operations *)
|
||||
|
||||
@@ -154,7 +154,7 @@ let index s c = index_rec s (length s) 0
|
||||
|
||||
let index_from s i c =
|
||||
let l = length s in
|
||||
- if i < 0 || i >= l then invalid_arg "String.index_from" else
|
||||
+ if i < 0 || i > l then invalid_arg "String.index_from" else
|
||||
index_rec s l i c;;
|
||||
|
||||
let rec rindex_rec s i c =
|
||||
@@ -164,22 +164,18 @@ let rec rindex_rec s i c =
|
||||
let rindex s c = rindex_rec s (length s - 1) c;;
|
||||
|
||||
let rindex_from s i c =
|
||||
- let l = length s in
|
||||
- if i < 0 || i >= l then invalid_arg "String.rindex_from" else
|
||||
+ if i < -1 || i >= length s then invalid_arg "String.rindex_from" else
|
||||
rindex_rec s i c;;
|
||||
|
||||
let contains_from s i c =
|
||||
let l = length s in
|
||||
- if i < 0 || i >= l then invalid_arg "String.contains_from" else
|
||||
+ if i < 0 || i > l then invalid_arg "String.contains_from" else
|
||||
try ignore (index_rec s l i c); true with Not_found -> false;;
|
||||
|
||||
-let contains s c =
|
||||
- let l = length s in
|
||||
- l <> 0 && contains_from s 0 c;;
|
||||
+let contains s c = contains_from s 0 c;;
|
||||
|
||||
let rcontains_from s i c =
|
||||
- let l = length s in
|
||||
- if i < 0 || i >= l then invalid_arg "String.rcontains_from" else
|
||||
+ if i < 0 || i >= length s then invalid_arg "String.rcontains_from" else
|
||||
try ignore (rindex_rec s i c); true with Not_found -> false;;
|
||||
|
||||
type t = string
|
26
ocaml.spec
26
ocaml.spec
@ -1,8 +1,8 @@
|
||||
%define _default_patch_fuzz 2
|
||||
|
||||
Name: ocaml
|
||||
Version: 3.11.0
|
||||
Release: 2%{?dist}
|
||||
Version: 3.11.1
|
||||
Release: 0.rc0.1%{?dist}
|
||||
|
||||
Summary: Objective Caml compiler and programming environment
|
||||
|
||||
@ -11,7 +11,7 @@ License: QPL and (LGPLv2+ with exceptions)
|
||||
|
||||
URL: http://www.ocaml.org
|
||||
|
||||
Source0: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-%{version}.tar.bz2
|
||||
Source0: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-%{version}+rc0.tar.gz
|
||||
Source1: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-3.11-refman.html.tar.gz
|
||||
Source2: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-3.11-refman.pdf
|
||||
Source3: http://caml.inria.fr/distrib/ocaml-3.11/ocaml-3.11-refman.info.tar.gz
|
||||
@ -21,17 +21,9 @@ Source5: ocaml-find-provides.sh
|
||||
Patch0: ocaml-3.11.0-rpath.patch
|
||||
Patch1: ocaml-user-cflags.patch
|
||||
|
||||
# Not needed, this is upstream since 3.11.0:
|
||||
#Patch2: ocaml-3.10.0-tclver.patch
|
||||
|
||||
# Support for PPC64 platform by David Woodhouse:
|
||||
Patch3: ocaml-3.11.0-ppc64.patch
|
||||
|
||||
# Not needed because the GC allocator was completely rewritten:
|
||||
#Patch4: ocaml-3.10.1-map32bit.patch
|
||||
# A similar fix went upstream in 3.11.0:
|
||||
#Patch5: ocaml-3.11-dev12-no-executable-stack.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: ncurses-devel
|
||||
@ -197,15 +189,12 @@ man pages and info files.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -T -b 0 -n %{name}-%{version}
|
||||
%setup -q -T -D -a 1 -n %{name}-%{version}
|
||||
%setup -q -T -D -a 3 -n %{name}-%{version}
|
||||
%setup -q -T -b 0 -n %{name}-%{version}rc0
|
||||
%setup -q -T -D -a 1 -n %{name}-%{version}rc0
|
||||
%setup -q -T -D -a 3 -n %{name}-%{version}rc0
|
||||
%patch0 -p1 -b .rpath
|
||||
%patch1 -p1 -b .cflags
|
||||
#%patch2 -p1 -b .tclver
|
||||
%patch3 -p1 -b .ppc64
|
||||
#%patch4 -p1 -b .map32bit
|
||||
#%patch5 -p0 -b .noexecstack
|
||||
|
||||
cp %{SOURCE2} refman.pdf
|
||||
|
||||
@ -446,6 +435,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri May 22 2009 Richard W.M. Jones <rjones@redhat.com> - 3.11.1-0.rc0.1
|
||||
- 3.11.1 release candidate 0.
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.11.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
7e20778259f87ab5e7cb60d2a17c657c ocaml-3.11-refman.html.tar.gz
|
||||
3fcfedf63a852f502a10eac547c9042d ocaml-3.11-refman.info.tar.gz
|
||||
076a163e511e575fc384ad96394760a2 ocaml-3.11-refman.pdf
|
||||
6ed1c3ed660a15408362242fa8fa4668 ocaml-3.11.0.tar.bz2
|
||||
45f626b33bec543a40abbf6afa1a6d96 ocaml-3.11.1+rc0.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user