OCaml 4.07.0-beta2 (RHBZ#1536734).
This commit is contained in:
parent
42201e8fdf
commit
9bc0b70a71
@ -1,4 +1,4 @@
|
||||
From 358855aa61775b72a8cba0d107286df960b1380c Mon Sep 17 00:00:00 2001
|
||||
From b53eed0544eaa4ac264e405bd73a43ca3fb574d8 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 24 Jun 2014 10:00:15 +0100
|
||||
Subject: [PATCH 1/6] Don't add rpaths to libraries.
|
||||
@ -8,10 +8,10 @@ Subject: [PATCH 1/6] Don't add rpaths to libraries.
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/Makefile b/tools/Makefile
|
||||
index 92d9e99e7..d0b635b06 100644
|
||||
index 78d2a1068..fbec019ed 100644
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -156,8 +156,8 @@ $(call byte_and_opt,ocamlmklib,ocamlmklibconfig.cmo config.cmo misc.cmo \
|
||||
@@ -157,8 +157,8 @@ $(call byte_and_opt,ocamlmklib,ocamlmklibconfig.cmo config.cmo misc.cmo \
|
||||
ocamlmklibconfig.ml: ../config/Makefile Makefile
|
||||
(echo 'let bindir = "$(BINDIR)"'; \
|
||||
echo 'let supports_shared_libraries = $(SUPPORTS_SHARED_LIBRARIES)';\
|
||||
@ -23,5 +23,5 @@ index 92d9e99e7..d0b635b06 100644
|
||||
sed -n -e 's/^#ml //p' ../config/Makefile) \
|
||||
> ocamlmklibconfig.ml
|
||||
--
|
||||
2.13.2
|
||||
2.15.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 930dbd7512305bb4b80d91e621c4e714531b5513 Mon Sep 17 00:00:00 2001
|
||||
From 010f13a4bc64e3d37aaea3b4fee56295672b91ff Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 29 May 2012 20:40:36 +0100
|
||||
Subject: [PATCH 2/6] ocamlbyteinfo, ocamlplugininfo: Useful utilities from
|
||||
@ -236,5 +236,5 @@ index 000000000..e28800f31
|
||||
+ header.units
|
||||
+ end
|
||||
--
|
||||
2.13.2
|
||||
2.15.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 66e774a2d3f8ebe6b6a4a3775112fc63619add8c Mon Sep 17 00:00:00 2001
|
||||
From 19dbb0c6b73513dddef2702daedcb68bba375af1 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 29 May 2012 20:44:18 +0100
|
||||
Subject: [PATCH 3/6] configure: Allow user defined C compiler flags.
|
||||
@ -8,10 +8,10 @@ Subject: [PATCH 3/6] configure: Allow user defined C compiler flags.
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 203396554..9311589cf 100755
|
||||
index 1316b3c1e..53f45f85b 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -2046,6 +2046,10 @@ if $flat_float_array; then
|
||||
@@ -2050,6 +2050,10 @@ if $flat_float_array; then
|
||||
echo "#define FLAT_FLOAT_ARRAY" >> m.h
|
||||
fi
|
||||
|
||||
@ -23,5 +23,5 @@ index 203396554..9311589cf 100755
|
||||
|
||||
cclibs="$cclibs $mathlib"
|
||||
--
|
||||
2.13.2
|
||||
2.15.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From e70b3f9a27786cbec2346e205933b7104a68c0d9 Mon Sep 17 00:00:00 2001
|
||||
From 08c2bdb60e291ddf55cb82053c39215ff9dac069 Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Ojeda Bar <n.oje.bar@gmail.com>
|
||||
Date: Fri, 27 Oct 2017 17:05:25 +0200
|
||||
Subject: [PATCH 4/6] Add RISC-V backend
|
||||
@ -27,10 +27,10 @@ Subject: [PATCH 4/6] Add RISC-V backend
|
||||
create mode 100644 asmrun/riscv.S
|
||||
|
||||
diff --git a/README.adoc b/README.adoc
|
||||
index 34ca38a06..85b6d0dce 100644
|
||||
index 74d1ec258..ac6c6eac3 100644
|
||||
--- a/README.adoc
|
||||
+++ b/README.adoc
|
||||
@@ -45,6 +45,7 @@ AMD64:: FreeBSD, OpenBSD, NetBSD
|
||||
@@ -47,6 +47,7 @@ AMD64:: FreeBSD, OpenBSD, NetBSD
|
||||
IA32 (Pentium):: NetBSD, OpenBSD, Solaris 9
|
||||
PowerPC:: NetBSD
|
||||
ARM:: NetBSD
|
||||
@ -1734,10 +1734,10 @@ index b79252d6b..8335398b2 100755
|
||||
echo ${UNAME_MACHINE}-ibm-linux-${LIBC}
|
||||
exit ;;
|
||||
diff --git a/configure b/configure
|
||||
index 9311589cf..b0c3b9fc6 100755
|
||||
index 53f45f85b..cf5a4a02a 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -922,6 +922,7 @@ if $with_sharedlibs; then
|
||||
@@ -928,6 +928,7 @@ if $with_sharedlibs; then
|
||||
arm*-*-freebsd*) natdynlink=true;;
|
||||
earm*-*-netbsd*) natdynlink=true;;
|
||||
aarch64-*-linux*) natdynlink=true;;
|
||||
@ -1745,7 +1745,7 @@ index 9311589cf..b0c3b9fc6 100755
|
||||
esac
|
||||
fi
|
||||
|
||||
@@ -996,6 +997,8 @@ case "$target" in
|
||||
@@ -1004,6 +1005,8 @@ case "$target" in
|
||||
x86_64-*-mingw*) arch=amd64; system=mingw;;
|
||||
aarch64-*-linux*) arch=arm64; system=linux;;
|
||||
x86_64-*-cygwin*) arch=amd64; system=cygwin;;
|
||||
@ -1754,7 +1754,7 @@ index 9311589cf..b0c3b9fc6 100755
|
||||
esac
|
||||
|
||||
# Some platforms exist both in 32-bit and 64-bit variants, not distinguished
|
||||
@@ -1054,7 +1057,7 @@ case "$arch,$system" in
|
||||
@@ -1062,7 +1065,7 @@ case "$arch,$system" in
|
||||
aspp="${TOOLPREF}cc -c";;
|
||||
*,freebsd) as="${TOOLPREF}as"
|
||||
aspp="${TOOLPREF}cc -c";;
|
||||
@ -1764,5 +1764,5 @@ index 9311589cf..b0c3b9fc6 100755
|
||||
case "$ccfamily" in
|
||||
clang-*)
|
||||
--
|
||||
2.13.2
|
||||
2.15.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From ebdebcab48818b19ef45e0cc8cdd89ae1cfc522f Mon Sep 17 00:00:00 2001
|
||||
From 58821468995b2dbe18cb1c7259fc5447e2c417ca Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Ojeda Bar <n.oje.bar@gmail.com>
|
||||
Date: Fri, 1 Dec 2017 14:39:46 +0100
|
||||
Subject: [PATCH 5/6] Copyright, untabify
|
||||
@ -713,5 +713,5 @@ index a82048efc..88d7ab924 100644
|
||||
+ .align 3
|
||||
+ .size caml_system__frametable, .-caml_system__frametable
|
||||
--
|
||||
2.13.2
|
||||
2.15.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From c730a434f509fa31b6cb2c89cabb7a740c63b8a2 Mon Sep 17 00:00:00 2001
|
||||
From eba9efdbf5e1cecf39e93e16e6e9d0847e3abb15 Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Ojeda Bar <n.oje.bar@gmail.com>
|
||||
Date: Sat, 2 Dec 2017 10:44:41 +0100
|
||||
Subject: [PATCH 6/6] fix caml_c_call: reload caml_young_limit
|
||||
@ -21,5 +21,5 @@ index 88d7ab924..121f8ba71 100644
|
||||
jr s2
|
||||
.size caml_c_call, .-caml_c_call
|
||||
--
|
||||
2.13.2
|
||||
2.15.1
|
||||
|
||||
|
19
ocaml.spec
19
ocaml.spec
@ -26,8 +26,8 @@
|
||||
#%global no_parallel_build_arches aarch64
|
||||
|
||||
Name: ocaml
|
||||
Version: 4.06.0
|
||||
Release: 5%{?dist}
|
||||
Version: 4.07.0
|
||||
Release: 0.beta2.0%{?dist}
|
||||
|
||||
Summary: OCaml compiler and programming environment
|
||||
|
||||
@ -35,7 +35,7 @@ License: QPL and (LGPLv2+ with exceptions)
|
||||
|
||||
URL: http://www.ocaml.org
|
||||
|
||||
Source0: http://caml.inria.fr/pub/distrib/ocaml-4.06/ocaml-%{version}.tar.xz
|
||||
Source0: http://caml.inria.fr/pub/distrib/ocaml-4.07/ocaml-%{version}+beta2.tar.xz
|
||||
|
||||
# IMPORTANT NOTE:
|
||||
#
|
||||
@ -191,7 +191,7 @@ may not be portable between versions.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -T -b 0 -n %{name}-%{version}
|
||||
%setup -q -T -b 0 -n %{name}-%{version}+beta2
|
||||
%autopatch -p1
|
||||
|
||||
|
||||
@ -282,6 +282,8 @@ find $RPM_BUILD_ROOT \( -name '*.cmt' -o -name '*.cmti' \) -a -delete
|
||||
%{_bindir}/ocamlbyteinfo
|
||||
%{_bindir}/ocamlcmt
|
||||
%{_bindir}/ocamldebug
|
||||
%{_bindir}/ocaml-instr-graph
|
||||
%{_bindir}/ocaml-instr-report
|
||||
#%{_bindir}/ocamlplugininfo
|
||||
%{_bindir}/ocamlyacc
|
||||
|
||||
@ -361,12 +363,16 @@ find $RPM_BUILD_ROOT \( -name '*.cmt' -o -name '*.cmti' \) -a -delete
|
||||
%files runtime
|
||||
%doc README.adoc LICENSE Changes
|
||||
%{_bindir}/ocamlrun
|
||||
%{_bindir}/ocamlrund
|
||||
%{_bindir}/ocamlruni
|
||||
%dir %{_libdir}/ocaml
|
||||
%{_libdir}/ocaml/VERSION
|
||||
%{_libdir}/ocaml/*.cmo
|
||||
%{_libdir}/ocaml/*.cmi
|
||||
%{_libdir}/ocaml/*.cma
|
||||
%{_libdir}/ocaml/stublibs
|
||||
%{_libdir}/ocaml/target_camlheaderd
|
||||
%{_libdir}/ocaml/target_camlheaderi
|
||||
%dir %{_libdir}/ocaml/vmthreads
|
||||
%{_libdir}/ocaml/vmthreads/*.cmi
|
||||
%{_libdir}/ocaml/vmthreads/*.cma
|
||||
@ -392,7 +398,7 @@ find $RPM_BUILD_ROOT \( -name '*.cmt' -o -name '*.cmti' \) -a -delete
|
||||
%doc LICENSE
|
||||
%doc ocamldoc/Changes.txt
|
||||
%{_bindir}/ocamldoc*
|
||||
%{_libdir}/ocaml/ocamldoc
|
||||
%{_libdir}/ocaml/ocamldoc.hva
|
||||
|
||||
|
||||
%files docs
|
||||
@ -424,6 +430,9 @@ find $RPM_BUILD_ROOT \( -name '*.cmt' -o -name '*.cmti' \) -a -delete
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Apr 26 2018 Richard W.M. Jones <rjones@redhat.com> - 4.07.0-0.beta2.0
|
||||
- OCaml 4.07.0-beta2 (RHBZ#1536734).
|
||||
|
||||
* Sun Feb 25 2018 Richard W.M. Jones <rjones@redhat.com> - 4.06.0-5
|
||||
- Add another couple of RISC-V patches from nojb branch.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ocaml-4.06.0.tar.xz) = c1cdba3fa52ef03ca534b7a4932cfe29bbbc79b587d35ed7f6906eb09a5e5af97540def03b1e01c63dd2311dc4e5a6d02378d541d14688191e4f9302aff79c23
|
||||
SHA512 (ocaml-4.07.0+beta2.tar.xz) = 4e867cb2b22c6b90d4034063a4c02200cf0b8d2d0dc94f3d6925fccfd72021f4c658ad45ea89c75ee0cf02f83ae2634dadf470e64aa45c494cc18153a95341c2
|
||||
|
Loading…
Reference in New Issue
Block a user