Auto sync2gitlab import of ocaml-4.07.0-3.el8.src.rpm

This commit is contained in:
James Antill 2022-05-26 12:08:36 -04:00
parent 5bd0f32c66
commit 68ab2ebbfd
12 changed files with 3967 additions and 1 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/ocaml-4.07.0.tar.xz

View File

@ -0,0 +1,27 @@
From 8ddacdf1283fe3d7054f51a4b764bc6b44d7a342 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 24 Jun 2014 10:00:15 +0100
Subject: [PATCH 1/8] Don't add rpaths to libraries.
---
tools/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/Makefile b/tools/Makefile
index 78d2a1068..fbec019ed 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -157,8 +157,8 @@ $(call byte_and_opt,ocamlmklib,ocamlmklibconfig.cmo config.cmo misc.cmo \
ocamlmklibconfig.ml: ../config/Makefile Makefile
(echo 'let bindir = "$(BINDIR)"'; \
echo 'let supports_shared_libraries = $(SUPPORTS_SHARED_LIBRARIES)';\
- echo 'let default_rpath = "$(RPATH)"'; \
- echo 'let mksharedlibrpath = "$(MKSHAREDLIBRPATH)"'; \
+ echo 'let default_rpath = ""'; \
+ echo 'let mksharedlibrpath = ""'; \
echo 'let toolpref = "$(TOOLPREF)"'; \
sed -n -e 's/^#ml //p' ../config/Makefile) \
> ocamlmklibconfig.ml
--
2.17.1

View File

@ -0,0 +1,240 @@
From 118057a71576cb39d71633bf80a37815bf4ff932 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:40:36 +0100
Subject: [PATCH 2/8] ocamlbyteinfo, ocamlplugininfo: Useful utilities from
Debian, sent upstream.
See:
http://git.debian.org/?p=pkg-ocaml-maint/packages/ocaml.git;a=tree;f=debian/ocamlbyteinfo;hb=HEAD
---
ocamlbyteinfo.ml | 101 +++++++++++++++++++++++++++++++++++++++++
ocamlplugininfo.ml | 109 +++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 210 insertions(+)
create mode 100644 ocamlbyteinfo.ml
create mode 100644 ocamlplugininfo.ml
diff --git a/ocamlbyteinfo.ml b/ocamlbyteinfo.ml
new file mode 100644
index 000000000..0a537e4d5
--- /dev/null
+++ b/ocamlbyteinfo.ml
@@ -0,0 +1,101 @@
+(***********************************************************************)
+(* *)
+(* Objective Caml *)
+(* *)
+(* Xavier Leroy, projet Gallium, INRIA Rocquencourt *)
+(* *)
+(* Copyright 2009 Institut National de Recherche en Informatique et *)
+(* en Automatique. All rights reserved. This file is distributed *)
+(* under the terms of the GNU Library General Public License, with *)
+(* the special exception on linking described in file ../../LICENSE. *)
+(* *)
+(***********************************************************************)
+
+(* $Id$ *)
+
+(* Dumps a bytecode binary file *)
+
+open Sys
+open Dynlinkaux
+
+let input_stringlist ic len =
+ let get_string_list sect len =
+ let rec fold s e acc =
+ if e != len then
+ if sect.[e] = '\000' then
+ fold (e+1) (e+1) (String.sub sect s (e-s) :: acc)
+ else fold s (e+1) acc
+ else acc
+ in fold 0 0 []
+ in
+ let sect = Bytes.create len in
+ let _ = really_input ic sect 0 len in
+ get_string_list (Bytes.to_string sect) len
+
+let print = Printf.printf
+let perr s =
+ Printf.eprintf "%s\n" s;
+ exit(1)
+let p_title title = print "%s:\n" title
+
+let p_section title format pdata = function
+ | [] -> ()
+ | l ->
+ p_title title;
+ List.iter
+ (fun (name, data) -> print format (pdata data) name)
+ l
+
+let p_list title format = function
+ | [] -> ()
+ | l ->
+ p_title title;
+ List.iter
+ (fun name -> print format name)
+ l
+
+let _ =
+ try
+ let input_name = Sys.argv.(1) in
+ let ic = open_in_bin input_name in
+ Bytesections.read_toc ic;
+ List.iter
+ (fun section ->
+ try
+ let len = Bytesections.seek_section ic section in
+ if len > 0 then match section with
+ | "CRCS" ->
+ p_section
+ "Imported Units"
+ "\t%s\t%s\n"
+ Digest.to_hex
+ (input_value ic : (string * Digest.t) list)
+ | "DLLS" ->
+ p_list
+ "Used Dlls" "\t%s\n"
+ (input_stringlist ic len)
+ | "DLPT" ->
+ p_list
+ "Additional Dll paths"
+ "\t%s\n"
+ (input_stringlist ic len)
+ | "PRIM" ->
+ let prims = (input_stringlist ic len) in
+ print "Uses unsafe features: ";
+ begin match prims with
+ [] -> print "no\n"
+ | l -> print "YES\n";
+ p_list "Primitives declared in this module"
+ "\t%s\n"
+ l
+ end
+ | _ -> ()
+ with Not_found | Failure _ | Invalid_argument _ -> ()
+ )
+ ["CRCS"; "DLLS"; "DLPT"; "PRIM"];
+ close_in ic
+ with
+ | Sys_error msg ->
+ perr msg
+ | Invalid_argument("index out of bounds") ->
+ perr (Printf.sprintf "Usage: %s filename" Sys.argv.(0))
diff --git a/ocamlplugininfo.ml b/ocamlplugininfo.ml
new file mode 100644
index 000000000..e28800f31
--- /dev/null
+++ b/ocamlplugininfo.ml
@@ -0,0 +1,109 @@
+(***********************************************************************)
+(* *)
+(* Objective Caml *)
+(* *)
+(* Xavier Leroy, projet Gallium, INRIA Rocquencourt *)
+(* *)
+(* Copyright 2009 Institut National de Recherche en Informatique et *)
+(* en Automatique. All rights reserved. This file is distributed *)
+(* under the terms of the GNU Library General Public License, with *)
+(* the special exception on linking described in file ../../LICENSE. *)
+(* *)
+(***********************************************************************)
+
+(* $Id$ *)
+
+(* Dumps a .cmxs file *)
+
+open Natdynlink
+open Format
+
+let file =
+ try
+ Sys.argv.(1)
+ with _ -> begin
+ Printf.eprintf "Usage: %s file.cmxs\n" Sys.argv.(0);
+ exit(1)
+ end
+
+exception Abnormal_exit
+
+let error s e =
+ let eprint = Printf.eprintf in
+ let print_exc s = function
+ | End_of_file ->
+ eprint "%s: %s\n" s file
+ | Abnormal_exit ->
+ eprint "%s\n" s
+ | e -> eprint "%s\n" (Printexc.to_string e)
+ in
+ print_exc s e;
+ exit(1)
+
+let read_in command =
+ let cmd = Printf.sprintf command file in
+ let ic = Unix.open_process_in cmd in
+ try
+ let line = input_line ic in
+ begin match (Unix.close_process_in ic) with
+ | Unix.WEXITED 0 -> Str.split (Str.regexp "[ ]+") line
+ | Unix.WEXITED _ | Unix.WSIGNALED _ | Unix.WSTOPPED _ ->
+ error
+ (Printf.sprintf
+ "Command \"%s\" exited abnormally"
+ cmd
+ )
+ Abnormal_exit
+ end
+ with e -> error "File is empty" e
+
+let get_offset adr_off adr_sec =
+ try
+ let adr = List.nth adr_off 4 in
+ let off = List.nth adr_off 5 in
+ let sec = List.hd adr_sec in
+
+ let (!) x = Int64.of_string ("0x" ^ x) in
+ let (+) = Int64.add in
+ let (-) = Int64.sub in
+
+ Int64.to_int (!off + !sec - !adr)
+
+ with Failure _ | Invalid_argument _ ->
+ error
+ "Command output doesn't have the expected format"
+ Abnormal_exit
+
+let print_infos name crc defines cmi cmx =
+ let print_name_crc (name, crc) =
+ printf "@ %s (%s)" name (Digest.to_hex crc)
+ in
+ let pr_imports ppf imps = List.iter print_name_crc imps in
+ printf "Name: %s@." name;
+ printf "CRC of implementation: %s@." (Digest.to_hex crc);
+ printf "@[<hov 2>Globals defined:";
+ List.iter (fun s -> printf "@ %s" s) defines;
+ printf "@]@.";
+ printf "@[<v 2>Interfaces imported:%a@]@." pr_imports cmi;
+ printf "@[<v 2>Implementations imported:%a@]@." pr_imports cmx
+
+let _ =
+ let adr_off = read_in "objdump -h %s | grep ' .data '" in
+ let adr_sec = read_in "objdump -T %s | grep ' caml_plugin_header$'" in
+
+ let ic = open_in file in
+ let _ = seek_in ic (get_offset adr_off adr_sec) in
+ let header = (input_value ic : Natdynlink.dynheader) in
+ if header.magic <> Natdynlink.dyn_magic_number then
+ raise(Error(Natdynlink.Not_a_bytecode_file file))
+ else begin
+ List.iter
+ (fun ui ->
+ print_infos
+ ui.name
+ ui.crc
+ ui.defines
+ ui.imports_cmi
+ ui.imports_cmx)
+ header.units
+ end
--
2.17.1

View File

@ -0,0 +1,27 @@
From 8ddd2fb4909bf6ed1a3506723126432da8fcf0c4 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:44:18 +0100
Subject: [PATCH 3/8] configure: Allow user defined C compiler flags.
---
configure | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/configure b/configure
index 1316b3c1e..53f45f85b 100755
--- a/configure
+++ b/configure
@@ -2050,6 +2050,10 @@ if $flat_float_array; then
echo "#define FLAT_FLOAT_ARRAY" >> m.h
fi
+# Allow user defined C Compiler flags
+bytecccompopts="$bytecccompopts $CFLAGS"
+nativecccompopts="$nativecccompopts $CFLAGS"
+
# Finish generated files
cclibs="$cclibs $mathlib"
--
2.17.1

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,717 @@
From 2e4038b6b8073f55012613f18cb19a4c99e8219d Mon Sep 17 00:00:00 2001
From: Nicolas Ojeda Bar <n.oje.bar@gmail.com>
Date: Fri, 1 Dec 2017 14:39:46 +0100
Subject: [PATCH 5/8] Copyright, untabify
---
asmrun/riscv.S | 608 ++++++++++++++++++++++++-------------------------
1 file changed, 304 insertions(+), 304 deletions(-)
diff --git a/asmrun/riscv.S b/asmrun/riscv.S
index a82048efc..88d7ab924 100644
--- a/asmrun/riscv.S
+++ b/asmrun/riscv.S
@@ -4,7 +4,7 @@
/* */
/* Nicolas Ojeda Bar <n.oje.bar@gmail.com> */
/* */
-/* Copyright 1996 Institut National de Recherche en Informatique et */
+/* Copyright 2017 Institut National de Recherche en Informatique et */
/* en Automatique. All rights reserved. This file is distributed */
/* under the terms of the GNU Library General Public License, with */
/* the special exception on linking described in file ../LICENSE. */
@@ -37,388 +37,388 @@
.option nopic
#endif
- .section .text
+ .section .text
/* Invoke the garbage collector. */
- .globl caml_system__code_begin
+ .globl caml_system__code_begin
caml_system__code_begin:
- .align 2
- .globl caml_call_gc
- .type caml_call_gc, @function
+ .align 2
+ .globl caml_call_gc
+ .type caml_call_gc, @function
caml_call_gc:
/* Record return address */
- store ra, caml_last_return_address, TMP0
+ store ra, caml_last_return_address, TMP0
/* Record lowest stack address */
- mv TMP1, sp
- store sp, caml_bottom_of_stack, TMP0
+ mv TMP1, sp
+ store sp, caml_bottom_of_stack, TMP0
.Lcaml_call_gc:
- /* Set up stack space, saving return address */
+ /* Set up stack space, saving return address */
/* (1 reg for RA, 1 reg for FP, 21 allocatable int regs, 20 caller-save float regs) * 8 */
/* + 1 for alignment */
- addi sp, sp, -0x160
- mv s0, sp
- store ra, 0x8(sp)
- store s0, 0x0(sp)
+ addi sp, sp, -0x160
+ mv s0, sp
+ store ra, 0x8(sp)
+ store s0, 0x0(sp)
/* Save allocatable integer registers on the stack,
in the order given in proc.ml */
- store a0, 0x10(sp)
- store a1, 0x18(sp)
- store a2, 0x20(sp)
- store a3, 0x28(sp)
- store a4, 0x30(sp)
- store a5, 0x38(sp)
- store a6, 0x40(sp)
- store a7, 0x48(sp)
- store s2, 0x50(sp)
- store s3, 0x58(sp)
- store s4, 0x60(sp)
- store s5, 0x68(sp)
- store s6, 0x70(sp)
- store s7, 0x78(sp)
- store s8, 0x80(sp)
- store s9, 0x88(sp)
- store t2, 0x90(sp)
- store t3, 0x98(sp)
- store t4, 0xa0(sp)
- store t5, 0xa8(sp)
- store t6, 0xb0(sp)
+ store a0, 0x10(sp)
+ store a1, 0x18(sp)
+ store a2, 0x20(sp)
+ store a3, 0x28(sp)
+ store a4, 0x30(sp)
+ store a5, 0x38(sp)
+ store a6, 0x40(sp)
+ store a7, 0x48(sp)
+ store s2, 0x50(sp)
+ store s3, 0x58(sp)
+ store s4, 0x60(sp)
+ store s5, 0x68(sp)
+ store s6, 0x70(sp)
+ store s7, 0x78(sp)
+ store s8, 0x80(sp)
+ store s9, 0x88(sp)
+ store t2, 0x90(sp)
+ store t3, 0x98(sp)
+ store t4, 0xa0(sp)
+ store t5, 0xa8(sp)
+ store t6, 0xb0(sp)
/* Save caller-save floating-point registers on the stack
(callee-saves are preserved by caml_garbage_collection) */
- fsd ft0, 0xb8(sp)
- fsd ft1, 0xc0(sp)
- fsd ft2, 0xc8(sp)
- fsd ft3, 0xd0(sp)
- fsd ft4, 0xd8(sp)
- fsd ft5, 0xe0(sp)
- fsd ft6, 0xe8(sp)
- fsd ft7, 0xf0(sp)
- fsd fa0, 0xf8(sp)
- fsd fa1, 0x100(sp)
- fsd fa2, 0x108(sp)
- fsd fa3, 0x110(sp)
- fsd fa4, 0x118(sp)
- fsd fa5, 0x120(sp)
- fsd fa6, 0x128(sp)
- fsd fa7, 0x130(sp)
- fsd ft8, 0x138(sp)
- fsd ft9, 0x140(sp)
- fsd ft9, 0x148(sp)
- fsd ft10, 0x150(sp)
- fsd ft11, 0x158(sp)
+ fsd ft0, 0xb8(sp)
+ fsd ft1, 0xc0(sp)
+ fsd ft2, 0xc8(sp)
+ fsd ft3, 0xd0(sp)
+ fsd ft4, 0xd8(sp)
+ fsd ft5, 0xe0(sp)
+ fsd ft6, 0xe8(sp)
+ fsd ft7, 0xf0(sp)
+ fsd fa0, 0xf8(sp)
+ fsd fa1, 0x100(sp)
+ fsd fa2, 0x108(sp)
+ fsd fa3, 0x110(sp)
+ fsd fa4, 0x118(sp)
+ fsd fa5, 0x120(sp)
+ fsd fa6, 0x128(sp)
+ fsd fa7, 0x130(sp)
+ fsd ft8, 0x138(sp)
+ fsd ft9, 0x140(sp)
+ fsd ft9, 0x148(sp)
+ fsd ft10, 0x150(sp)
+ fsd ft11, 0x158(sp)
/* Store pointer to saved integer registers in caml_gc_regs */
- addi TMP1, sp, 16
- store TMP1, caml_gc_regs, TMP0
+ addi TMP1, sp, 16
+ store TMP1, caml_gc_regs, TMP0
/* Save current allocation pointer for debugging purposes */
- store ALLOC_PTR, caml_young_ptr, TMP0
+ store ALLOC_PTR, caml_young_ptr, TMP0
/* Save trap pointer in case an exception is raised during GC */
- store TRAP_PTR, caml_exception_pointer, TMP0
+ store TRAP_PTR, caml_exception_pointer, TMP0
/* Call the garbage collector */
- call caml_garbage_collection
+ call caml_garbage_collection
/* Restore registers */
- load a0, 0x10(sp)
- load a1, 0x18(sp)
- load a2, 0x20(sp)
- load a3, 0x28(sp)
- load a4, 0x30(sp)
- load a5, 0x38(sp)
- load a6, 0x40(sp)
- load a7, 0x48(sp)
- load s2, 0x50(sp)
- load s3, 0x58(sp)
- load s4, 0x60(sp)
- load s5, 0x68(sp)
- load s6, 0x70(sp)
- load s7, 0x78(sp)
- load s8, 0x80(sp)
- load s9, 0x88(sp)
- load t2, 0x90(sp)
- load t3, 0x98(sp)
- load t4, 0xa0(sp)
- load t5, 0xa8(sp)
- load t6, 0xb0(sp)
- fld ft0, 0xb8(sp)
- fld ft1, 0xc0(sp)
- fld ft2, 0xc8(sp)
- fld ft3, 0xd0(sp)
- fld ft4, 0xd8(sp)
- fld ft5, 0xe0(sp)
- fld ft6, 0xe8(sp)
- fld ft7, 0xf0(sp)
- fld fa0, 0xf8(sp)
- fld fa1, 0x100(sp)
- fld fa2, 0x108(sp)
- fld fa3, 0x110(sp)
- fld fa4, 0x118(sp)
- fld fa5, 0x120(sp)
- fld fa6, 0x128(sp)
- fld fa7, 0x130(sp)
- fld ft8, 0x138(sp)
- fld ft9, 0x140(sp)
- fld ft9, 0x148(sp)
- fld ft10, 0x150(sp)
- fld ft11, 0x158(sp)
+ load a0, 0x10(sp)
+ load a1, 0x18(sp)
+ load a2, 0x20(sp)
+ load a3, 0x28(sp)
+ load a4, 0x30(sp)
+ load a5, 0x38(sp)
+ load a6, 0x40(sp)
+ load a7, 0x48(sp)
+ load s2, 0x50(sp)
+ load s3, 0x58(sp)
+ load s4, 0x60(sp)
+ load s5, 0x68(sp)
+ load s6, 0x70(sp)
+ load s7, 0x78(sp)
+ load s8, 0x80(sp)
+ load s9, 0x88(sp)
+ load t2, 0x90(sp)
+ load t3, 0x98(sp)
+ load t4, 0xa0(sp)
+ load t5, 0xa8(sp)
+ load t6, 0xb0(sp)
+ fld ft0, 0xb8(sp)
+ fld ft1, 0xc0(sp)
+ fld ft2, 0xc8(sp)
+ fld ft3, 0xd0(sp)
+ fld ft4, 0xd8(sp)
+ fld ft5, 0xe0(sp)
+ fld ft6, 0xe8(sp)
+ fld ft7, 0xf0(sp)
+ fld fa0, 0xf8(sp)
+ fld fa1, 0x100(sp)
+ fld fa2, 0x108(sp)
+ fld fa3, 0x110(sp)
+ fld fa4, 0x118(sp)
+ fld fa5, 0x120(sp)
+ fld fa6, 0x128(sp)
+ fld fa7, 0x130(sp)
+ fld ft8, 0x138(sp)
+ fld ft9, 0x140(sp)
+ fld ft9, 0x148(sp)
+ fld ft10, 0x150(sp)
+ fld ft11, 0x158(sp)
/* Reload new allocation pointer and allocation limit */
- load ALLOC_PTR, caml_young_ptr
- load ALLOC_LIMIT, caml_young_limit
+ load ALLOC_PTR, caml_young_ptr
+ load ALLOC_LIMIT, caml_young_limit
/* Free stack space and return to caller */
- load ra, 0x8(sp)
- load s0, 0x0(sp)
- addi sp, sp, 0x160
+ load ra, 0x8(sp)
+ load s0, 0x0(sp)
+ addi sp, sp, 0x160
ret
- .size caml_call_gc, .-caml_call_gc
+ .size caml_call_gc, .-caml_call_gc
/* Call a C function from OCaml */
/* Function to call is in ARG */
- .align 2
- .globl caml_c_call
- .type caml_c_call, @function
+ .align 2
+ .globl caml_c_call
+ .type caml_c_call, @function
caml_c_call:
/* Preserve return address in callee-save register s2 */
- mv s2, ra
+ mv s2, ra
/* Record lowest stack address and return address */
- store ra, caml_last_return_address, TMP0
- store sp, caml_bottom_of_stack, TMP0
+ store ra, caml_last_return_address, TMP0
+ store sp, caml_bottom_of_stack, TMP0
/* Make the exception handler alloc ptr available to the C code */
- store ALLOC_PTR, caml_young_ptr, TMP0
- store TRAP_PTR, caml_exception_pointer, TMP0
+ store ALLOC_PTR, caml_young_ptr, TMP0
+ store TRAP_PTR, caml_exception_pointer, TMP0
/* Call the function */
- jalr ARG
+ jalr ARG
/* Reload alloc ptr and alloc limit */
- load ALLOC_PTR, caml_young_ptr
- load TRAP_PTR, caml_exception_pointer
+ load ALLOC_PTR, caml_young_ptr
+ load TRAP_PTR, caml_exception_pointer
/* Return */
- jr s2
- .size caml_c_call, .-caml_c_call
+ jr s2
+ .size caml_c_call, .-caml_c_call
/* Raise an exception from OCaml */
- .align 2
- .globl caml_raise_exn
- .type caml_raise_exn, @function
+ .align 2
+ .globl caml_raise_exn
+ .type caml_raise_exn, @function
caml_raise_exn:
/* Test if backtrace is active */
- load TMP1, caml_backtrace_active
- bnez TMP1, 2f
+ load TMP1, caml_backtrace_active
+ bnez TMP1, 2f
1: /* Cut stack at current trap handler */
- mv sp, TRAP_PTR
+ mv sp, TRAP_PTR
/* Pop previous handler and jump to it */
- load TMP1, 8(sp)
- load TRAP_PTR, 0(sp)
- addi sp, sp, 16
- jr TMP1
+ load TMP1, 8(sp)
+ load TRAP_PTR, 0(sp)
+ addi sp, sp, 16
+ jr TMP1
2: /* Preserve exception bucket in callee-save register s2 */
- mv s2, a0
+ mv s2, a0
/* Stash the backtrace */
- mv a1, ra
- mv a2, sp
- mv a3, TRAP_PTR
- call caml_stash_backtrace
+ mv a1, ra
+ mv a2, sp
+ mv a3, TRAP_PTR
+ call caml_stash_backtrace
/* Restore exception bucket and raise */
- mv a0, s2
- j 1b
- .size caml_raise_exn, .-caml_raise_exn
+ mv a0, s2
+ j 1b
+ .size caml_raise_exn, .-caml_raise_exn
- .globl caml_reraise_exn
- .type caml_reraise_exn, @function
+ .globl caml_reraise_exn
+ .type caml_reraise_exn, @function
/* Raise an exception from C */
- .align 2
- .globl caml_raise_exception
- .type caml_raise_exception, @function
+ .align 2
+ .globl caml_raise_exception
+ .type caml_raise_exception, @function
caml_raise_exception:
- load TRAP_PTR, caml_exception_pointer
- load ALLOC_PTR, caml_young_ptr
- load ALLOC_LIMIT, caml_young_limit
- load TMP1, caml_backtrace_active
- bnez TMP1, 2f
+ load TRAP_PTR, caml_exception_pointer
+ load ALLOC_PTR, caml_young_ptr
+ load ALLOC_LIMIT, caml_young_limit
+ load TMP1, caml_backtrace_active
+ bnez TMP1, 2f
1: /* Cut stack at current trap handler */
- mv sp, TRAP_PTR
- load TMP1, 8(sp)
- load TRAP_PTR, 0(sp)
- addi sp, sp, 16
- jr TMP1
+ mv sp, TRAP_PTR
+ load TMP1, 8(sp)
+ load TRAP_PTR, 0(sp)
+ addi sp, sp, 16
+ jr TMP1
2: /* Preserve exception bucket in callee-save register s2 */
- mv s2, a0
- load a1, caml_last_return_address
- load a2, caml_bottom_of_stack
- mv a3, TRAP_PTR
- call caml_stash_backtrace
- mv a0, s2
- j 1b
- .size caml_raise_exception, .-caml_raise_exception
+ mv s2, a0
+ load a1, caml_last_return_address
+ load a2, caml_bottom_of_stack
+ mv a3, TRAP_PTR
+ call caml_stash_backtrace
+ mv a0, s2
+ j 1b
+ .size caml_raise_exception, .-caml_raise_exception
/* Start the OCaml program */
- .align 2
- .globl caml_start_program
- .type caml_start_program, @function
+ .align 2
+ .globl caml_start_program
+ .type caml_start_program, @function
caml_start_program:
- la ARG, caml_program
+ la ARG, caml_program
/* Code shared with caml_callback* */
/* Address of OCaml code to call is in ARG */
/* Arguments to the OCaml code are in a0 ... a7 */
.Ljump_to_caml:
- /* Set up stack frame and save callee-save registers */
- addi sp, sp, -0xd0
- store ra, 0xc0(sp)
- store s0, 0x0(sp)
- store s1, 0x8(sp)
- store s2, 0x10(sp)
- store s3, 0x18(sp)
- store s4, 0x20(sp)
- store s5, 0x28(sp)
- store s6, 0x30(sp)
- store s7, 0x38(sp)
- store s8, 0x40(sp)
- store s9, 0x48(sp)
- store s10, 0x50(sp)
- store s11, 0x58(sp)
- fsd fs0, 0x60(sp)
- fsd fs1, 0x68(sp)
- fsd fs2, 0x70(sp)
- fsd fs3, 0x78(sp)
- fsd fs4, 0x80(sp)
- fsd fs5, 0x88(sp)
- fsd fs6, 0x90(sp)
- fsd fs7, 0x98(sp)
- fsd fs8, 0xa0(sp)
- fsd fs9, 0xa8(sp)
- fsd fs10, 0xb0(sp)
- fsd fs11, 0xb8(sp)
- addi sp, sp, -32
+ /* Set up stack frame and save callee-save registers */
+ addi sp, sp, -0xd0
+ store ra, 0xc0(sp)
+ store s0, 0x0(sp)
+ store s1, 0x8(sp)
+ store s2, 0x10(sp)
+ store s3, 0x18(sp)
+ store s4, 0x20(sp)
+ store s5, 0x28(sp)
+ store s6, 0x30(sp)
+ store s7, 0x38(sp)
+ store s8, 0x40(sp)
+ store s9, 0x48(sp)
+ store s10, 0x50(sp)
+ store s11, 0x58(sp)
+ fsd fs0, 0x60(sp)
+ fsd fs1, 0x68(sp)
+ fsd fs2, 0x70(sp)
+ fsd fs3, 0x78(sp)
+ fsd fs4, 0x80(sp)
+ fsd fs5, 0x88(sp)
+ fsd fs6, 0x90(sp)
+ fsd fs7, 0x98(sp)
+ fsd fs8, 0xa0(sp)
+ fsd fs9, 0xa8(sp)
+ fsd fs10, 0xb0(sp)
+ fsd fs11, 0xb8(sp)
+ addi sp, sp, -32
/* Setup a callback link on the stack */
- load TMP1, caml_bottom_of_stack
- store TMP1, 0(sp)
- load TMP1, caml_last_return_address
- store TMP1, 8(sp)
- load TMP1, caml_gc_regs
- store TMP1, 16(sp)
- /* set up a trap frame */
- addi sp, sp, -16
- load TMP1, caml_exception_pointer
- store TMP1, 0(sp)
- lla TMP0, .Ltrap_handler
- store TMP0, 8(sp)
- mv TRAP_PTR, sp
- load ALLOC_PTR, caml_young_ptr
- load ALLOC_LIMIT, caml_young_limit
- store x0, caml_last_return_address, TMP0
- jalr ARG
-.Lcaml_retaddr: /* pop trap frame, restoring caml_exception_pointer */
- load TMP1, 0(sp)
- store TMP1, caml_exception_pointer, TMP0
- addi sp, sp, 16
-.Lreturn_result: /* pop callback link, restoring global variables */
- load TMP1, 0(sp)
- store TMP1, caml_bottom_of_stack, TMP0
- load TMP1, 8(sp)
- store TMP1, caml_last_return_address, TMP0
- load TMP1, 16(sp)
- store TMP1, caml_gc_regs, TMP0
- addi sp, sp, 32
- /* Update allocation pointer */
- store ALLOC_PTR, caml_young_ptr, TMP0
- /* reload callee-save registers and return */
- load ra, 0xc0(sp)
- load s0, 0x0(sp)
- load s1, 0x8(sp)
- load s2, 0x10(sp)
- load s3, 0x18(sp)
- load s4, 0x20(sp)
- load s5, 0x28(sp)
- load s6, 0x30(sp)
- load s7, 0x38(sp)
- load s8, 0x40(sp)
- load s9, 0x48(sp)
- load s10, 0x50(sp)
- load s11, 0x58(sp)
- fld fs0, 0x60(sp)
- fld fs1, 0x68(sp)
- fld fs2, 0x70(sp)
- fld fs3, 0x78(sp)
- fld fs4, 0x80(sp)
- fld fs5, 0x88(sp)
- fld fs6, 0x90(sp)
- fld fs7, 0x98(sp)
- fld fs8, 0xa0(sp)
- fld fs9, 0xa8(sp)
- fld fs10, 0xb0(sp)
- fld fs11, 0xb8(sp)
- addi sp, sp, 0xd0
- ret
+ load TMP1, caml_bottom_of_stack
+ store TMP1, 0(sp)
+ load TMP1, caml_last_return_address
+ store TMP1, 8(sp)
+ load TMP1, caml_gc_regs
+ store TMP1, 16(sp)
+ /* set up a trap frame */
+ addi sp, sp, -16
+ load TMP1, caml_exception_pointer
+ store TMP1, 0(sp)
+ lla TMP0, .Ltrap_handler
+ store TMP0, 8(sp)
+ mv TRAP_PTR, sp
+ load ALLOC_PTR, caml_young_ptr
+ load ALLOC_LIMIT, caml_young_limit
+ store x0, caml_last_return_address, TMP0
+ jalr ARG
+.Lcaml_retaddr: /* pop trap frame, restoring caml_exception_pointer */
+ load TMP1, 0(sp)
+ store TMP1, caml_exception_pointer, TMP0
+ addi sp, sp, 16
+.Lreturn_result: /* pop callback link, restoring global variables */
+ load TMP1, 0(sp)
+ store TMP1, caml_bottom_of_stack, TMP0
+ load TMP1, 8(sp)
+ store TMP1, caml_last_return_address, TMP0
+ load TMP1, 16(sp)
+ store TMP1, caml_gc_regs, TMP0
+ addi sp, sp, 32
+ /* Update allocation pointer */
+ store ALLOC_PTR, caml_young_ptr, TMP0
+ /* reload callee-save registers and return */
+ load ra, 0xc0(sp)
+ load s0, 0x0(sp)
+ load s1, 0x8(sp)
+ load s2, 0x10(sp)
+ load s3, 0x18(sp)
+ load s4, 0x20(sp)
+ load s5, 0x28(sp)
+ load s6, 0x30(sp)
+ load s7, 0x38(sp)
+ load s8, 0x40(sp)
+ load s9, 0x48(sp)
+ load s10, 0x50(sp)
+ load s11, 0x58(sp)
+ fld fs0, 0x60(sp)
+ fld fs1, 0x68(sp)
+ fld fs2, 0x70(sp)
+ fld fs3, 0x78(sp)
+ fld fs4, 0x80(sp)
+ fld fs5, 0x88(sp)
+ fld fs6, 0x90(sp)
+ fld fs7, 0x98(sp)
+ fld fs8, 0xa0(sp)
+ fld fs9, 0xa8(sp)
+ fld fs10, 0xb0(sp)
+ fld fs11, 0xb8(sp)
+ addi sp, sp, 0xd0
+ ret
.Ltrap_handler:
- store TRAP_PTR, caml_exception_pointer, TMP0
- ori a0, a0, 2
- j .Lreturn_result
- .size caml_start_program, .-caml_start_program
+ store TRAP_PTR, caml_exception_pointer, TMP0
+ ori a0, a0, 2
+ j .Lreturn_result
+ .size caml_start_program, .-caml_start_program
/* Callback from C to OCaml */
- .align 2
- .globl caml_callback_exn
- .type caml_callback_exn, @function
+ .align 2
+ .globl caml_callback_exn
+ .type caml_callback_exn, @function
caml_callback_exn:
/* Initial shuffling of arguments (a0 = closure, a1 = first arg) */
- mv TMP1, a0
- mv a0, a1 /* a0 = first arg */
- mv a1, TMP1 /* a1 = closure environment */
- load ARG, 0(TMP1) /* code pointer */
- j .Ljump_to_caml
- .size caml_callback_exn, .-caml_callback_exn
+ mv TMP1, a0
+ mv a0, a1 /* a0 = first arg */
+ mv a1, TMP1 /* a1 = closure environment */
+ load ARG, 0(TMP1) /* code pointer */
+ j .Ljump_to_caml
+ .size caml_callback_exn, .-caml_callback_exn
- .align 2
- .globl caml_callback2_exn
- .type caml_callback2_exn, @function
+ .align 2
+ .globl caml_callback2_exn
+ .type caml_callback2_exn, @function
caml_callback2_exn:
/* Initial shuffling of arguments (a0 = closure, a1 = arg1, a2 = arg2) */
- mv TMP1, a0
- mv a0, a1
- mv a1, a2
- mv a2, TMP1
- la ARG, caml_apply2
- j .Ljump_to_caml
- .size caml_callback2_exn, .-caml_callback2_exn
+ mv TMP1, a0
+ mv a0, a1
+ mv a1, a2
+ mv a2, TMP1
+ la ARG, caml_apply2
+ j .Ljump_to_caml
+ .size caml_callback2_exn, .-caml_callback2_exn
- .align 2
- .globl caml_callback3_exn
- .type caml_callback3_exn, @function
+ .align 2
+ .globl caml_callback3_exn
+ .type caml_callback3_exn, @function
caml_callback3_exn:
/* Initial shuffling of argumnets */
/* (a0 = closure, a1 = arg1, a2 = arg2, a3 = arg3) */
- mv TMP1, a0
- mv a0, a1
- mv a1, a2
- mv a2, a3
- mv a3, TMP1
- la ARG, caml_apply3
- j .Ljump_to_caml
- .size caml_callback3_exn, .-caml_callback3_exn
+ mv TMP1, a0
+ mv a0, a1
+ mv a1, a2
+ mv a2, a3
+ mv a3, TMP1
+ la ARG, caml_apply3
+ j .Ljump_to_caml
+ .size caml_callback3_exn, .-caml_callback3_exn
- .align 2
- .globl caml_ml_array_bound_error
- .type caml_ml_array_bound_error, @function
+ .align 2
+ .globl caml_ml_array_bound_error
+ .type caml_ml_array_bound_error, @function
caml_ml_array_bound_error:
/* Load address of [caml_array_bound_error] in ARG */
- la ARG, caml_array_bound_error
+ la ARG, caml_array_bound_error
/* Call that function */
- j caml_c_call
+ j caml_c_call
- .globl caml_system__code_end
+ .globl caml_system__code_end
caml_system__code_end:
/* GC roots for callback */
- .section .data
- .align 3
- .globl caml_system__frametable
- .type caml_system__frametable, @object
+ .section .data
+ .align 3
+ .globl caml_system__frametable
+ .type caml_system__frametable, @object
caml_system__frametable:
- .quad 1 /* one descriptor */
- .quad .Lcaml_retaddr /* return address into callback */
- .short -1 /* negative frame size => use callback link */
- .short 0 /* no roots */
- .align 3
- .size caml_system__frametable, .-caml_system__frametable
+ .quad 1 /* one descriptor */
+ .quad .Lcaml_retaddr /* return address into callback */
+ .short -1 /* negative frame size => use callback link */
+ .short 0 /* no roots */
+ .align 3
+ .size caml_system__frametable, .-caml_system__frametable
--
2.17.1

View File

@ -0,0 +1,25 @@
From 207fbbc2616ee44e048dd5bb133e52f252cd1caf Mon Sep 17 00:00:00 2001
From: Nicolas Ojeda Bar <n.oje.bar@gmail.com>
Date: Sat, 2 Dec 2017 10:44:41 +0100
Subject: [PATCH 6/8] fix caml_c_call: reload caml_young_limit
---
asmrun/riscv.S | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/asmrun/riscv.S b/asmrun/riscv.S
index 88d7ab924..121f8ba71 100644
--- a/asmrun/riscv.S
+++ b/asmrun/riscv.S
@@ -187,7 +187,7 @@ caml_c_call:
jalr ARG
/* Reload alloc ptr and alloc limit */
load ALLOC_PTR, caml_young_ptr
- load TRAP_PTR, caml_exception_pointer
+ load ALLOC_LIMIT, caml_young_limit
/* Return */
jr s2
.size caml_c_call, .-caml_c_call
--
2.17.1

67
0007-Adapt-to-4.07.patch Normal file
View File

@ -0,0 +1,67 @@
From a89427d52a20633be40056fe008b7eeec5ded7dd Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nicol=C3=A1s=20Ojeda=20B=C3=A4r?= <n.oje.bar@gmail.com>
Date: Tue, 15 May 2018 07:17:06 +0000
Subject: [PATCH 7/8] Adapt to 4.07
---
asmcomp/riscv/emit.mlp | 28 +++++++++++++++++-----------
asmcomp/riscv/selection.ml | 2 +-
2 files changed, 18 insertions(+), 12 deletions(-)
diff --git a/asmcomp/riscv/emit.mlp b/asmcomp/riscv/emit.mlp
index 51165d0f1..718dca080 100644
--- a/asmcomp/riscv/emit.mlp
+++ b/asmcomp/riscv/emit.mlp
@@ -461,19 +461,25 @@ let emit_instr i =
` {emit_string name} {emit_reg i.arg.(0)}, {emit_reg i.arg.(1)}, {emit_label lbl}\n`
| Iinttest_imm _ ->
fatal_error "Emit.emit_instr (Iinttest_imm _)"
- | Ifloattest(cmp, neg) ->
- let neg = match cmp with
- | Ceq -> ` feq.d {emit_reg reg_tmp1}, {emit_reg i.arg.(0)}, {emit_reg i.arg.(1)}\n`; neg
- | Cne -> ` feq.d {emit_reg reg_tmp1}, {emit_reg i.arg.(0)}, {emit_reg i.arg.(1)}\n`; not neg
- | Clt -> ` flt.d {emit_reg reg_tmp1}, {emit_reg i.arg.(0)}, {emit_reg i.arg.(1)}\n`; neg
- | Cgt -> ` flt.d {emit_reg reg_tmp1}, {emit_reg i.arg.(1)}, {emit_reg i.arg.(0)}\n`; neg
- | Cle -> ` fle.d {emit_reg reg_tmp1}, {emit_reg i.arg.(0)}, {emit_reg i.arg.(1)}\n`; neg
- | Cge -> ` fle.d {emit_reg reg_tmp1}, {emit_reg i.arg.(1)}, {emit_reg i.arg.(0)}\n`; neg
- in
- if neg then
+ | Ifloattest cmp ->
+ begin match cmp with
+ | CFeq | CFneq ->
+ ` feq.d {emit_reg reg_tmp1}, {emit_reg i.arg.(0)}, {emit_reg i.arg.(1)}\n`
+ | CFlt | CFnlt ->
+ ` flt.d {emit_reg reg_tmp1}, {emit_reg i.arg.(0)}, {emit_reg i.arg.(1)}\n`
+ | CFgt | CFngt ->
+ ` flt.d {emit_reg reg_tmp1}, {emit_reg i.arg.(1)}, {emit_reg i.arg.(0)}\n`
+ | CFle | CFnle ->
+ ` fle.d {emit_reg reg_tmp1}, {emit_reg i.arg.(0)}, {emit_reg i.arg.(1)}\n`
+ | CFge | CFnge ->
+ ` fle.d {emit_reg reg_tmp1}, {emit_reg i.arg.(1)}, {emit_reg i.arg.(0)}\n`
+ end;
+ begin match cmp with
+ | CFneq | CFnlt | CFngt | CFnle | CFnge ->
` beqz {emit_reg reg_tmp1}, {emit_label lbl}\n`
- else
+ | CFeq | CFlt | CFgt | CFle | CFge ->
` bnez {emit_reg reg_tmp1}, {emit_label lbl}\n`
+ end
| Ioddtest ->
` andi {emit_reg reg_tmp1}, {emit_reg i.arg.(0)}, 1\n`;
` bnez {emit_reg reg_tmp1}, {emit_label lbl}\n`
diff --git a/asmcomp/riscv/selection.ml b/asmcomp/riscv/selection.ml
index 092ca88aa..1f0af6abc 100644
--- a/asmcomp/riscv/selection.ml
+++ b/asmcomp/riscv/selection.ml
@@ -61,7 +61,7 @@ method! select_condition = function
| Cop(Ccmpa cmp, args, _) ->
(Iinttest(Iunsigned cmp), Ctuple args)
| Cop(Ccmpf cmp, args, _) ->
- (Ifloattest(cmp, false), Ctuple args)
+ (Ifloattest cmp, Ctuple args)
| Cop(Cand, [arg; Cconst_int 1], _) ->
(Ioddtest, arg)
| arg ->
--
2.17.1

View File

@ -0,0 +1,40 @@
From af276d83f41cb9eb9f1e50a75a9be205c9b2fee6 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 5 Jun 2018 19:48:08 +0000
Subject: [PATCH 8/8] riscv: Emit debug info.
---
asmcomp/riscv/emit.mlp | 3 +++
1 file changed, 3 insertions(+)
diff --git a/asmcomp/riscv/emit.mlp b/asmcomp/riscv/emit.mlp
index 718dca080..e42ee9770 100644
--- a/asmcomp/riscv/emit.mlp
+++ b/asmcomp/riscv/emit.mlp
@@ -261,6 +261,7 @@ let tailrec_entry_point = ref 0
(* Output the assembly code for an instruction *)
let emit_instr i =
+ emit_debug_info i.dbg;
match i.desc with
Lend -> ()
| Lop(Imove | Ispill | Ireload) ->
@@ -560,6 +561,7 @@ let fundecl fundecl =
emit_stack_adjustment (-n);
if !contains_calls then store_ra n;
`{emit_label !tailrec_entry_point}:\n`;
+ emit_debug_info fundecl.fun_dbg;
emit_all fundecl.fun_body;
List.iter emit_call_gc !call_gc_sites;
List.iter emit_call_bound_error !bound_error_sites;
@@ -619,6 +621,7 @@ let data l =
let begin_assembly() =
` .file \"\"\n`; (* PR#7073 *)
+ reset_debug_info ();
(* Emit the beginning of the segments *)
let lbl_begin = Compilenv.make_symbol (Some "data_begin") in
` {emit_string data_space}\n`;
--
2.17.1

1
EMPTY
View File

@ -1 +0,0 @@

1054
ocaml.spec Normal file

File diff suppressed because it is too large Load Diff

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (ocaml-4.07.0.tar.xz) = 1c27c2c81919af6b51824fb69f203ebca009ab093af0dffb0dbe66d08ba980525ee14e9426edf142c527315144602ac9ef6e36d2266714b5f7ccc7c063e75ac8