s390x: Fix address of caml_raise_exn in native dynlink modules.
Upstream bug report: https://caml.inria.fr/mantis/view.php?id=7405
This commit is contained in:
parent
3faf9753d1
commit
02890f76ff
@ -1,7 +1,7 @@
|
||||
From fc5ac0d955afce294fe58a20cab8e9dda572de78 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 24 Jun 2014 10:00:15 +0100
|
||||
Subject: [PATCH 1/5] Don't add rpaths to libraries.
|
||||
Subject: [PATCH 1/6] Don't add rpaths to libraries.
|
||||
|
||||
---
|
||||
tools/Makefile.shared | 6 +++---
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 61bdb02cedd1be6ecdc37bc4a80ffe3f19aa5521 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 29 May 2012 20:40:36 +0100
|
||||
Subject: [PATCH 2/5] ocamlbyteinfo, ocamlplugininfo: Useful utilities from
|
||||
Subject: [PATCH 2/6] ocamlbyteinfo, ocamlplugininfo: Useful utilities from
|
||||
Debian, sent upstream.
|
||||
|
||||
See:
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 2f93494aea56c9216bb561800a6861b653f409ce Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 29 May 2012 20:44:18 +0100
|
||||
Subject: [PATCH 3/5] configure: Allow user defined C compiler flags.
|
||||
Subject: [PATCH 3/6] configure: Allow user defined C compiler flags.
|
||||
|
||||
---
|
||||
configure | 4 ++++
|
||||
|
@ -1,7 +1,7 @@
|
||||
From cdd42ba82210bfaa97cfa010eaac3d805b80cb49 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 3 Nov 2016 19:50:20 +0000
|
||||
Subject: [PATCH 4/5] Don't rewrite -Werror.
|
||||
Subject: [PATCH 4/6] Don't rewrite -Werror.
|
||||
|
||||
In Fedora our CFLAGS contains -Wall -Werror=format-security.
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 4d586c823b021c3091aab7bb3f88f1678c194558 Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Ojeda Bar <n.oje.bar@gmail.com>
|
||||
Date: Fri, 4 Nov 2016 20:39:09 +0100
|
||||
Subject: [PATCH 5/5] RISC-V support 2016-11-08
|
||||
Subject: [PATCH 5/6] RISC-V support 2016-11-08
|
||||
|
||||
This commit contains the squashed commits from:
|
||||
|
||||
|
@ -0,0 +1,28 @@
|
||||
From 6d3d16d5d0490b222ff27261c209f121d60db3a4 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 9 Nov 2016 11:01:15 -0500
|
||||
Subject: [PATCH 6/6] s390x: Fix address of caml_raise_exn in native dynlink
|
||||
modules.
|
||||
|
||||
Upstream bug report:
|
||||
https://caml.inria.fr/mantis/view.php?id=7405
|
||||
---
|
||||
asmcomp/s390x/emit.mlp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/asmcomp/s390x/emit.mlp b/asmcomp/s390x/emit.mlp
|
||||
index 5d233a3..a099bdb 100644
|
||||
--- a/asmcomp/s390x/emit.mlp
|
||||
+++ b/asmcomp/s390x/emit.mlp
|
||||
@@ -611,7 +611,7 @@ let emit_instr i =
|
||||
| Lraise k ->
|
||||
begin match k with
|
||||
| Cmm.Raise_withtrace ->
|
||||
- ` brasl %r14, {emit_symbol "caml_raise_exn"}\n`;
|
||||
+ ` brasl %r14, {emit_symbol "caml_raise_exn"}@PLT\n`;
|
||||
let lbl = record_frame Reg.Set.empty true i.dbg in
|
||||
`{emit_label lbl}:\n`
|
||||
| Cmm.Raise_notrace ->
|
||||
--
|
||||
2.9.3
|
||||
|
@ -27,7 +27,7 @@
|
||||
|
||||
Name: ocaml
|
||||
Version: 4.04.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
|
||||
Summary: OCaml compiler and programming environment
|
||||
|
||||
@ -63,6 +63,7 @@ Patch0004: 0004-Don-t-rewrite-Werror.patch
|
||||
# Out of tree patch from
|
||||
# https://github.com/nojb/riscv-ocaml
|
||||
Patch0005: 0005-RISC-V-support-2016-11-08.patch
|
||||
Patch0006: 0006-s390x-Fix-address-of-caml_raise_exn-in-native-dynlin.patch
|
||||
|
||||
BuildRequires: binutils-devel
|
||||
BuildRequires: ncurses-devel
|
||||
@ -439,6 +440,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Nov 09 2016 Richard W.M. Jones <rjones@redhat.com> - 4.04.0-3
|
||||
- s390x: Fix address of caml_raise_exn in native dynlink modules.
|
||||
(https://caml.inria.fr/mantis/view.php?id=7405)
|
||||
|
||||
* Tue Nov 08 2016 Richard W.M. Jones <rjones@redhat.com> - 4.04.0-2
|
||||
- Add support for RISC-V using out of tree support from:
|
||||
https://github.com/nojb/riscv-ocaml
|
||||
|
Loading…
Reference in New Issue
Block a user