import ocaml-libvirt-0.6.1.5-19.el9
This commit is contained in:
commit
bbad13854d
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/ocaml-libvirt-0.6.1.5.tar.gz
|
1
.ocaml-libvirt.metadata
Normal file
1
.ocaml-libvirt.metadata
Normal file
@ -0,0 +1 @@
|
||||
ca9d1c487f7c7deadfa0d2f09e399e76bc7e9af2 SOURCES/ocaml-libvirt-0.6.1.5.tar.gz
|
@ -0,0 +1,38 @@
|
||||
From 75b13978f85b32c7a121aa289d8ebf41ba14ee5a Mon Sep 17 00:00:00 2001
|
||||
From: Pino Toscano <ptoscano@redhat.com>
|
||||
Date: Thu, 5 Sep 2019 09:57:09 +0200
|
||||
Subject: [PATCH] Make const the return value of caml_named_value()
|
||||
|
||||
With OCaml >= 4.09 caml_named_value() returns a const value *, so keep
|
||||
the constness to build also in this case.
|
||||
|
||||
Signed-off-by: Pino Toscano <ptoscano@redhat.com>
|
||||
---
|
||||
libvirt/libvirt_c_oneoffs.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/libvirt/libvirt_c_oneoffs.c b/libvirt/libvirt_c_oneoffs.c
|
||||
index 6f56f10..e23c0db 100644
|
||||
--- a/libvirt/libvirt_c_oneoffs.c
|
||||
+++ b/libvirt/libvirt_c_oneoffs.c
|
||||
@@ -1207,7 +1207,7 @@ ocaml_libvirt_event_run_default_impl (value unitv)
|
||||
#define DOMAIN_CALLBACK_BEGIN(NAME) \
|
||||
value connv, domv, callback_id, result; \
|
||||
connv = domv = callback_id = result = Val_int(0); \
|
||||
- static value *callback = NULL; \
|
||||
+ static const value *callback = NULL; \
|
||||
caml_leave_blocking_section(); \
|
||||
if (callback == NULL) \
|
||||
callback = caml_named_value(NAME); \
|
||||
@@ -1433,7 +1433,7 @@ timeout_callback(int timer, void *opaque)
|
||||
{
|
||||
value callback_id, result;
|
||||
callback_id = result = Val_int(0);
|
||||
- static value *callback = NULL;
|
||||
+ static const value *callback = NULL;
|
||||
caml_leave_blocking_section();
|
||||
if (callback == NULL)
|
||||
callback = caml_named_value("Libvirt.timeout_callback");
|
||||
--
|
||||
2.23.0
|
||||
|
@ -0,0 +1,74 @@
|
||||
From 29709872404fad20a9822c43a831f30b7b09f34a Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 19 Jan 2020 12:58:17 +0000
|
||||
Subject: [PATCH 1/3] block_peek, memory_peek: Use bytes for return buffer.
|
||||
|
||||
Strings are immutable in modern OCaml.
|
||||
---
|
||||
libvirt/libvirt.ml | 4 ++--
|
||||
libvirt/libvirt.mli | 4 ++--
|
||||
libvirt/libvirt_c_oneoffs.c | 4 ++--
|
||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/libvirt/libvirt.ml b/libvirt/libvirt.ml
|
||||
index 7f9d0e4..bdb9460 100644
|
||||
--- a/libvirt/libvirt.ml
|
||||
+++ b/libvirt/libvirt.ml
|
||||
@@ -731,8 +731,8 @@ struct
|
||||
external migrate : [>`W] t -> [>`W] Connect.t -> migrate_flag list -> ?dname:string -> ?uri:string -> ?bandwidth:int -> unit -> rw t = "ocaml_libvirt_domain_migrate_bytecode" "ocaml_libvirt_domain_migrate_native"
|
||||
external block_stats : [>`R] t -> string -> block_stats = "ocaml_libvirt_domain_block_stats"
|
||||
external interface_stats : [>`R] t -> string -> interface_stats = "ocaml_libvirt_domain_interface_stats"
|
||||
- external block_peek : [>`W] t -> string -> int64 -> int -> string -> int -> unit = "ocaml_libvirt_domain_block_peek_bytecode" "ocaml_libvirt_domain_block_peek_native"
|
||||
- external memory_peek : [>`W] t -> memory_flag list -> int64 -> int -> string -> int -> unit = "ocaml_libvirt_domain_memory_peek_bytecode" "ocaml_libvirt_domain_memory_peek_native"
|
||||
+ external block_peek : [>`W] t -> string -> int64 -> int -> bytes -> int -> unit = "ocaml_libvirt_domain_block_peek_bytecode" "ocaml_libvirt_domain_block_peek_native"
|
||||
+ external memory_peek : [>`W] t -> memory_flag list -> int64 -> int -> bytes -> int -> unit = "ocaml_libvirt_domain_memory_peek_bytecode" "ocaml_libvirt_domain_memory_peek_native"
|
||||
|
||||
external get_all_domain_stats : [>`R] Connect.t -> stats_type list -> get_all_domain_stats_flag list -> domain_stats_record array = "ocaml_libvirt_domain_get_all_domain_stats"
|
||||
|
||||
diff --git a/libvirt/libvirt.mli b/libvirt/libvirt.mli
|
||||
index 0d74199..7900392 100644
|
||||
--- a/libvirt/libvirt.mli
|
||||
+++ b/libvirt/libvirt.mli
|
||||
@@ -708,7 +708,7 @@ sig
|
||||
val interface_stats : [>`R] t -> string -> interface_stats
|
||||
(** Returns network interface stats. *)
|
||||
|
||||
- val block_peek : [>`W] t -> string -> int64 -> int -> string -> int -> unit
|
||||
+ val block_peek : [>`W] t -> string -> int64 -> int -> bytes -> int -> unit
|
||||
(** [block_peek dom path offset size buf boff] reads [size] bytes at
|
||||
[offset] in the domain's [path] block device.
|
||||
|
||||
@@ -717,7 +717,7 @@ sig
|
||||
|
||||
See also {!max_peek}. *)
|
||||
val memory_peek : [>`W] t -> memory_flag list -> int64 -> int ->
|
||||
- string -> int -> unit
|
||||
+ bytes -> int -> unit
|
||||
(** [memory_peek dom Virtual offset size] reads [size] bytes
|
||||
at [offset] in the domain's virtual memory.
|
||||
|
||||
diff --git a/libvirt/libvirt_c_oneoffs.c b/libvirt/libvirt_c_oneoffs.c
|
||||
index 40384e8..8468c73 100644
|
||||
--- a/libvirt/libvirt_c_oneoffs.c
|
||||
+++ b/libvirt/libvirt_c_oneoffs.c
|
||||
@@ -1057,7 +1057,7 @@ ocaml_libvirt_domain_block_peek_native (value domv, value pathv, value offsetv,
|
||||
const char *path = String_val (pathv);
|
||||
unsigned long long offset = Int64_val (offsetv);
|
||||
size_t size = Int_val (sizev);
|
||||
- char *buffer = String_val (bufferv);
|
||||
+ unsigned char *buffer = Bytes_val (bufferv);
|
||||
int boff = Int_val (boffv);
|
||||
int r;
|
||||
|
||||
@@ -1089,7 +1089,7 @@ ocaml_libvirt_domain_memory_peek_native (value domv, value flagsv, value offsetv
|
||||
int flags = 0;
|
||||
unsigned long long offset = Int64_val (offsetv);
|
||||
size_t size = Int_val (sizev);
|
||||
- char *buffer = String_val (bufferv);
|
||||
+ unsigned char *buffer = Bytes_val (bufferv);
|
||||
int boff = Int_val (boffv);
|
||||
int r;
|
||||
|
||||
--
|
||||
2.24.1
|
||||
|
113
SOURCES/0002-String_val-returns-const-char-in-OCaml-4.10.patch
Normal file
113
SOURCES/0002-String_val-returns-const-char-in-OCaml-4.10.patch
Normal file
@ -0,0 +1,113 @@
|
||||
From 3705b9bdcd04dc86474c62e1c8dd8759669842bc Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 19 Jan 2020 12:59:09 +0000
|
||||
Subject: [PATCH 2/3] String_val returns const char * in OCaml 4.10.
|
||||
|
||||
This should be compatible with earlier versions of OCaml
|
||||
too since we are just assigning a char * to a const char *.
|
||||
---
|
||||
libvirt/generator.pl | 14 +++++++-------
|
||||
libvirt/libvirt_c_oneoffs.c | 6 +++---
|
||||
2 files changed, 10 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/libvirt/generator.pl b/libvirt/generator.pl
|
||||
index ac3dd65..aff371b 100755
|
||||
--- a/libvirt/generator.pl
|
||||
+++ b/libvirt/generator.pl
|
||||
@@ -593,7 +593,7 @@ sub gen_c_code
|
||||
} elsif ($sig =~ /^(\w+), string : unit$/) {
|
||||
"\
|
||||
" . gen_unpack_args ($1) . "
|
||||
- char *str = String_val (strv);
|
||||
+ const char *str = String_val (strv);
|
||||
int r;
|
||||
|
||||
NONBLOCKING (r = $c_name ($1, str));
|
||||
@@ -605,7 +605,7 @@ sub gen_c_code
|
||||
"\
|
||||
CAMLlocal1 (rv);
|
||||
" . gen_unpack_args ($1) . "
|
||||
- char *str = String_val (strv);
|
||||
+ const char *str = String_val (strv);
|
||||
int r;
|
||||
|
||||
NONBLOCKING (r = $c_name ($1, str, 0));
|
||||
@@ -618,7 +618,7 @@ sub gen_c_code
|
||||
"\
|
||||
CAMLlocal1 (rv);
|
||||
" . gen_unpack_args ($1) . "
|
||||
- char *str = String_val (strv);
|
||||
+ const char *str = String_val (strv);
|
||||
$c_ret_type r;
|
||||
|
||||
NONBLOCKING (r = $c_name ($1, str));
|
||||
@@ -633,7 +633,7 @@ sub gen_c_code
|
||||
"\
|
||||
CAMLlocal1 (rv);
|
||||
" . gen_unpack_args ($1) . "
|
||||
- char *str = String_val (strv);
|
||||
+ const char *str = String_val (strv);
|
||||
$c_ret_type r;
|
||||
|
||||
NONBLOCKING (r = $c_name ($1, str, 0));
|
||||
@@ -648,7 +648,7 @@ sub gen_c_code
|
||||
"\
|
||||
CAMLlocal1 (rv);
|
||||
" . gen_unpack_args ($1) . "
|
||||
- char *str = String_val (strv);
|
||||
+ const char *str = String_val (strv);
|
||||
unsigned int u = Int_val (uv);
|
||||
$c_ret_type r;
|
||||
|
||||
@@ -735,7 +735,7 @@ sub gen_c_code
|
||||
"\
|
||||
CAMLlocal2 (rv, connv);
|
||||
" . gen_unpack_args ($1) . "
|
||||
- char *str = String_val (strv);
|
||||
+ const char *str = String_val (strv);
|
||||
$c_ret_type r;
|
||||
|
||||
NONBLOCKING (r = $c_name ($1, str));
|
||||
@@ -751,7 +751,7 @@ sub gen_c_code
|
||||
"\
|
||||
CAMLlocal2 (rv, connv);
|
||||
" . gen_unpack_args ($1) . "
|
||||
- char *str = String_val (strv);
|
||||
+ const char *str = String_val (strv);
|
||||
$c_ret_type r;
|
||||
|
||||
NONBLOCKING (r = $c_name ($1, str, 0));
|
||||
diff --git a/libvirt/libvirt_c_oneoffs.c b/libvirt/libvirt_c_oneoffs.c
|
||||
index 8468c73..fc2ac13 100644
|
||||
--- a/libvirt/libvirt_c_oneoffs.c
|
||||
+++ b/libvirt/libvirt_c_oneoffs.c
|
||||
@@ -601,7 +601,7 @@ ocaml_libvirt_domain_set_scheduler_parameters (value domv, value paramsv)
|
||||
int nparams = Wosize_val (paramsv);
|
||||
virSchedParameterPtr params;
|
||||
int r, i;
|
||||
- char *name;
|
||||
+ const char *name;
|
||||
|
||||
params = malloc (sizeof (*params) * nparams);
|
||||
if (params == NULL)
|
||||
@@ -1005,7 +1005,7 @@ ocaml_libvirt_domain_block_stats (value domv, value pathv)
|
||||
CAMLparam2 (domv, pathv);
|
||||
CAMLlocal2 (rv,v);
|
||||
virDomainPtr dom = Domain_val (domv);
|
||||
- char *path = String_val (pathv);
|
||||
+ const char *path = String_val (pathv);
|
||||
struct _virDomainBlockStats stats;
|
||||
int r;
|
||||
|
||||
@@ -1028,7 +1028,7 @@ ocaml_libvirt_domain_interface_stats (value domv, value pathv)
|
||||
CAMLparam2 (domv, pathv);
|
||||
CAMLlocal2 (rv,v);
|
||||
virDomainPtr dom = Domain_val (domv);
|
||||
- char *path = String_val (pathv);
|
||||
+ const char *path = String_val (pathv);
|
||||
struct _virDomainInterfaceStats stats;
|
||||
int r;
|
||||
|
||||
--
|
||||
2.24.1
|
||||
|
68
SOURCES/0003-Don-t-try-to-memcpy-into-a-String_val.patch
Normal file
68
SOURCES/0003-Don-t-try-to-memcpy-into-a-String_val.patch
Normal file
@ -0,0 +1,68 @@
|
||||
From 3d3d6af425d369200a7a62a127adf640d94a38a3 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 19 Jan 2020 13:02:16 +0000
|
||||
Subject: [PATCH 3/3] Don't try to memcpy into a String_val.
|
||||
|
||||
In OCaml 4.10 String_val returns const char *, so we cannot use it as
|
||||
the destination for memcpy. Use Bytes_val instead.
|
||||
---
|
||||
libvirt/generator.pl | 2 +-
|
||||
libvirt/libvirt_c_oneoffs.c | 8 ++++----
|
||||
2 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/libvirt/generator.pl b/libvirt/generator.pl
|
||||
index aff371b..463a19b 100755
|
||||
--- a/libvirt/generator.pl
|
||||
+++ b/libvirt/generator.pl
|
||||
@@ -440,7 +440,7 @@ sub gen_c_code
|
||||
|
||||
/* UUIDs are byte arrays with a fixed length. */
|
||||
rv = caml_alloc_string (VIR_UUID_BUFLEN);
|
||||
- memcpy (String_val (rv), uuid, VIR_UUID_BUFLEN);
|
||||
+ memcpy (Bytes_val (rv), uuid, VIR_UUID_BUFLEN);
|
||||
CAMLreturn (rv);
|
||||
"
|
||||
} elsif ($sig =~ /^(\w+) : uuid string$/) {
|
||||
diff --git a/libvirt/libvirt_c_oneoffs.c b/libvirt/libvirt_c_oneoffs.c
|
||||
index fc2ac13..e8472b7 100644
|
||||
--- a/libvirt/libvirt_c_oneoffs.c
|
||||
+++ b/libvirt/libvirt_c_oneoffs.c
|
||||
@@ -394,7 +394,7 @@ ocaml_libvirt_connect_call_auth_default_callback (value listv)
|
||||
elemv = caml_alloc (2, 0);
|
||||
if (cred->result != NULL && cred->resultlen > 0) {
|
||||
v = caml_alloc_string (cred->resultlen);
|
||||
- memcpy (String_val (v), cred->result, cred->resultlen);
|
||||
+ memcpy (Bytes_val (v), cred->result, cred->resultlen);
|
||||
optv = caml_alloc (1, 0);
|
||||
Store_field (optv, 0, v);
|
||||
} else
|
||||
@@ -715,7 +715,7 @@ ocaml_libvirt_domain_get_vcpus (value domv, value maxinfov, value maplenv)
|
||||
|
||||
/* Copy the bitmap. */
|
||||
strv = caml_alloc_string (maxinfo * maplen);
|
||||
- memcpy (String_val (strv), cpumaps, maxinfo * maplen);
|
||||
+ memcpy (Bytes_val (strv), cpumaps, maxinfo * maplen);
|
||||
|
||||
/* Allocate the tuple and return it. */
|
||||
rv = caml_alloc_tuple (3);
|
||||
@@ -900,7 +900,7 @@ ocaml_libvirt_domain_get_all_domain_stats (value connv,
|
||||
*/
|
||||
v = caml_alloc_string (VIR_UUID_BUFLEN);
|
||||
virDomainGetUUID (rstats[i]->dom, uuid);
|
||||
- memcpy (String_val (v), uuid, VIR_UUID_BUFLEN);
|
||||
+ memcpy (Bytes_val (v), uuid, VIR_UUID_BUFLEN);
|
||||
Store_field (dsv, 0, v);
|
||||
|
||||
tpv = caml_alloc (rstats[i]->nparams, 0); /* typed_param array */
|
||||
@@ -1646,7 +1646,7 @@ ocaml_libvirt_secret_get_value (value secv)
|
||||
CHECK_ERROR (secval == NULL, "virSecretGetValue");
|
||||
|
||||
rv = caml_alloc_string (size);
|
||||
- memcpy (String_val (rv), secval, size);
|
||||
+ memcpy (Bytes_val (rv), secval, size);
|
||||
free (secval);
|
||||
|
||||
CAMLreturn (rv);
|
||||
--
|
||||
2.24.1
|
||||
|
445
SPECS/ocaml-libvirt.spec
Normal file
445
SPECS/ocaml-libvirt.spec
Normal file
@ -0,0 +1,445 @@
|
||||
Name: ocaml-libvirt
|
||||
Version: 0.6.1.5
|
||||
Release: 19%{?dist}
|
||||
Summary: OCaml binding for libvirt
|
||||
License: LGPLv2+
|
||||
|
||||
URL: http://libvirt.org/ocaml/
|
||||
Source0: http://libvirt.org/sources/ocaml/%{name}-%{version}.tar.gz
|
||||
|
||||
# Fixes build with OCaml >= 4.09.
|
||||
# Upstream commit 75b13978f85b32c7a121aa289d8ebf41ba14ee5a.
|
||||
Patch1: 0001-Make-const-the-return-value-of-caml_named_value.patch
|
||||
|
||||
# Fixes for OCaml 4.10, sent upstream 2020-01-19.
|
||||
Patch2: 0001-block_peek-memory_peek-Use-bytes-for-return-buffer.patch
|
||||
Patch3: 0002-String_val-returns-const-char-in-OCaml-4.10.patch
|
||||
Patch4: 0003-Don-t-try-to-memcpy-into-a-String_val.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: ocaml >= 3.10.0
|
||||
BuildRequires: ocaml-ocamldoc
|
||||
BuildRequires: ocaml-findlib-devel
|
||||
|
||||
BuildRequires: libvirt-devel >= 0.2.1
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: gawk
|
||||
|
||||
|
||||
%description
|
||||
OCaml binding for libvirt.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and signature files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%autopatch -p1
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
make all doc
|
||||
%ifarch %{ocaml_native_compiler}
|
||||
make opt
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
# These rules work if the library uses 'ocamlfind install' to install itself.
|
||||
export DESTDIR=$RPM_BUILD_ROOT
|
||||
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
|
||||
mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
|
||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||
%ifarch %{ocaml_native_compiler}
|
||||
make install-opt
|
||||
%else
|
||||
make install-byte
|
||||
%endif
|
||||
|
||||
|
||||
%files
|
||||
%doc COPYING.LIB README ChangeLog
|
||||
%{_libdir}/ocaml/libvirt
|
||||
%ifarch %{ocaml_native_compiler}
|
||||
%exclude %{_libdir}/ocaml/libvirt/*.a
|
||||
%exclude %{_libdir}/ocaml/libvirt/*.cmxa
|
||||
%exclude %{_libdir}/ocaml/libvirt/*.cmx
|
||||
%endif
|
||||
%exclude %{_libdir}/ocaml/libvirt/*.mli
|
||||
%{_libdir}/ocaml/stublibs/*.so
|
||||
%{_libdir}/ocaml/stublibs/*.so.owner
|
||||
|
||||
|
||||
%files devel
|
||||
%doc COPYING.LIB README TODO.libvirt ChangeLog html/*
|
||||
%ifarch %{ocaml_native_compiler}
|
||||
%{_libdir}/ocaml/libvirt/*.a
|
||||
%{_libdir}/ocaml/libvirt/*.cmxa
|
||||
%{_libdir}/ocaml/libvirt/*.cmx
|
||||
%endif
|
||||
%{_libdir}/ocaml/libvirt/*.mli
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 11 2022 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-19
|
||||
- Rebuild for EPEL
|
||||
resolves: rhbz#2060850
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.6.1.5-18
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Wed Jun 23 2021 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-17
|
||||
- Bump and rebuild
|
||||
resolves: rhbz#1975311
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.6.1.5-16
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.5-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Sep 01 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-14
|
||||
- OCaml 4.11.1 rebuild
|
||||
|
||||
* Fri Aug 21 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-13
|
||||
- OCaml 4.11.0 rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.5-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon May 04 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-11
|
||||
- OCaml 4.11.0+dev2-2020-04-22 rebuild
|
||||
|
||||
* Tue Apr 21 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-10
|
||||
- OCaml 4.11.0 pre-release attempt 2
|
||||
|
||||
* Fri Apr 17 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-9
|
||||
- OCaml 4.11.0 pre-release
|
||||
|
||||
* Thu Apr 02 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-8
|
||||
- Update all OCaml dependencies for RPM 4.16.
|
||||
|
||||
* Wed Feb 26 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-7
|
||||
- OCaml 4.10.0 final.
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.5-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sun Jan 19 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-5
|
||||
- OCaml 4.10.0+beta1 rebuild.
|
||||
|
||||
* Thu Jan 09 2020 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-4
|
||||
- OCaml 4.09.0 for riscv64
|
||||
|
||||
* Fri Dec 06 2019 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-3
|
||||
- Include upstream patch to fix build for OCaml 4.09.
|
||||
|
||||
* Fri Dec 06 2019 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-2
|
||||
- OCaml 4.09.0 (final) rebuild.
|
||||
|
||||
* Wed Aug 21 2019 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.5-1
|
||||
- New upstream version 0.6.1.5.
|
||||
- Remove all patches as they are upstream.
|
||||
|
||||
* Fri Aug 16 2019 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-35
|
||||
- OCaml 4.08.1 (final) rebuild.
|
||||
|
||||
* Wed Jul 31 2019 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-34
|
||||
- OCaml 4.08.1 (rc2) rebuild.
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.4-33
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jun 27 2019 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-32
|
||||
- OCaml 4.08.0 (final) rebuild.
|
||||
|
||||
* Mon Apr 29 2019 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-31
|
||||
- OCaml 4.08.0 (beta 3) rebuild.
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.4-30
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.4-29
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Jul 11 2018 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-28
|
||||
- OCaml 4.07.0 (final) rebuild.
|
||||
|
||||
* Tue Jun 19 2018 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-27
|
||||
- OCaml 4.07.0-rc1 rebuild.
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.4-26
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Nov 08 2017 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-25
|
||||
- Fix -safe-string.
|
||||
|
||||
* Tue Nov 07 2017 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-22
|
||||
- OCaml 4.06.0 rebuild.
|
||||
|
||||
* Mon Aug 07 2017 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-21
|
||||
- OCaml 4.05.0 rebuild.
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.4-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.4-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jun 26 2017 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-18
|
||||
- OCaml 4.04.2 rebuild.
|
||||
|
||||
* Fri May 12 2017 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-17
|
||||
- Bump release and rebuild.
|
||||
|
||||
* Thu May 11 2017 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-16
|
||||
- OCaml 4.04.1 rebuild.
|
||||
|
||||
* Tue Mar 28 2017 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-15
|
||||
- Further upstream patches, adding binding for virConnectGetAllDomainStats.
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.4-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Nov 04 2016 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-13
|
||||
- Rebuild for OCaml 4.04.0.
|
||||
|
||||
* Fri Feb 05 2016 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-12
|
||||
- Add upstream patch to remove unused function.
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1.4-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2015 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-10
|
||||
- OCaml 4.02.3 rebuild.
|
||||
|
||||
* Mon Jul 27 2015 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-9
|
||||
- Remove ExcludeArch since bytecode build should now work.
|
||||
|
||||
* Wed Jun 24 2015 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-8
|
||||
- Bump release and rebuild.
|
||||
- Fix bogus date in changelog.
|
||||
|
||||
* Wed Jun 17 2015 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-7
|
||||
- ocaml-4.02.2 rebuild.
|
||||
|
||||
* Tue Mar 17 2015 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-6
|
||||
- Add upstream patches to fix error handling.
|
||||
|
||||
* Fri Mar 6 2015 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-5
|
||||
- Add binding for virDomainCreateXML.
|
||||
|
||||
* Mon Feb 16 2015 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-4
|
||||
- ocaml-4.02.1 rebuild.
|
||||
|
||||
* Sat Aug 30 2014 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-3
|
||||
- ocaml-4.02.0 final rebuild.
|
||||
- Fix int types.
|
||||
|
||||
* Mon Aug 25 2014 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.4-1
|
||||
- New upstream version 0.6.1.4.
|
||||
- Patch removed, now upstream.
|
||||
|
||||
* Sat Aug 23 2014 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.2-14
|
||||
- ocaml-4.02.0+rc1 rebuild.
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1.2-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Aug 02 2014 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.2-12
|
||||
- ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
|
||||
|
||||
* Mon Jul 21 2014 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.2-11
|
||||
- OCaml 4.02.0 beta rebuild.
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1.2-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Wed Sep 18 2013 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.2-9
|
||||
- OCaml 4.01.0 rebuild.
|
||||
- Enable debuginfo.
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1.2-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Mon Oct 29 2012 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.2-6
|
||||
- Rebuild for OCaml 4.00.1.
|
||||
|
||||
* Fri Oct 12 2012 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.2-5
|
||||
- Modernise the spec file.
|
||||
- Add upstream patch to remove unnecessary get_cpu_stats second parameter
|
||||
(thanks Hu Tao).
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jun 09 2012 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.2-2
|
||||
- Rebuild for OCaml 4.00.0.
|
||||
|
||||
* Fri Mar 23 2012 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.2-1
|
||||
- New upstream version 0.6.1.2.
|
||||
|
||||
* Tue Mar 6 2012 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.1-1
|
||||
- New upstream version 0.6.1.1.
|
||||
- Remove mlvirsh subpackage, no longer upstream.
|
||||
- Replace custom configure with RPM macro configure.
|
||||
- Use RPM global instead of define.
|
||||
- Use built-in RPM OCaml dependency generator.
|
||||
|
||||
* Fri Jan 06 2012 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.0-10
|
||||
- Rebuild for OCaml 3.12.1.
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Jan 05 2011 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.0-8
|
||||
- Rebuild for OCaml 3.12 (http://fedoraproject.org/wiki/Features/OCaml3.12).
|
||||
|
||||
* Wed Dec 30 2009 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.0-7
|
||||
- Rebuild for OCaml 3.11.2.
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Jul 15 2009 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.0-5
|
||||
- Force rebuild to test FTBFS issue.
|
||||
|
||||
* Fri Jun 12 2009 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.0-3
|
||||
- Force rebuild to test FTBFS issue.
|
||||
|
||||
* Sat May 23 2009 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.0-2
|
||||
- Rebuild for OCaml 3.11.1
|
||||
|
||||
* Thu Apr 16 2009 S390x secondary arch maintainer <fedora-s390x@lists.fedoraproject.org>
|
||||
- ExcludeArch sparc64, s390, s390x as we don't have OCaml on those archs
|
||||
(added sparc64 per request from the sparc maintainer)
|
||||
|
||||
* Tue Mar 10 2009 Richard W.M. Jones <rjones@redhat.com> - 0.6.1.0-1
|
||||
- New upstream release 0.6.1.0.
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.4.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Nov 26 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.4.2-3
|
||||
- Rebuild for OCaml 3.11.0+rc1.
|
||||
|
||||
* Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.4.2-2
|
||||
- Rebuild for OCaml 3.11.0
|
||||
|
||||
* Wed Jul 9 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.4.2-1
|
||||
- New upstream version.
|
||||
- In upstream, 'make install' became 'make install-byte' or 'make install-opt'
|
||||
|
||||
* Tue Jun 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.2.4-1
|
||||
- New upstream version.
|
||||
|
||||
* Thu Jun 5 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.2.3-1
|
||||
- New upstream version.
|
||||
|
||||
* Thu Jun 5 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.2.2-1
|
||||
- New upstream version.
|
||||
- Removed virt-ctrl, virt-df, virt-top subpackages, since these are
|
||||
now separate Fedora packages.
|
||||
|
||||
* Tue May 20 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.1-4
|
||||
- Disable virt-top (bz 442871).
|
||||
- Disable virt-ctrl (bz 442875).
|
||||
|
||||
* Mon May 19 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.1-3
|
||||
- Disable virt-df (bz 442873).
|
||||
|
||||
* Wed Apr 23 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.1-2
|
||||
- Rebuild for OCaml 3.10.2
|
||||
|
||||
* Thu Mar 20 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.1-1
|
||||
- New upstream release 0.4.1.1.
|
||||
- Move configure to build section.
|
||||
- Pass RPM_OPT_FLAGS.
|
||||
|
||||
* Tue Mar 4 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.0-2
|
||||
- Fix source URL.
|
||||
- Install virt-df manpage.
|
||||
|
||||
* Tue Mar 4 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.0-1
|
||||
- New upstream release 0.4.1.0.
|
||||
- Upstream now requires ocaml-dbus >= 0.06, ocaml-lablgtk >= 2.10.0,
|
||||
ocaml-dbus-devel.
|
||||
- Enable virt-df.
|
||||
|
||||
* Sat Mar 1 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.0.3-3
|
||||
- Rebuild for ppc64.
|
||||
|
||||
* Wed Feb 13 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.0.3-2
|
||||
- Add BR gtk2-devel
|
||||
|
||||
* Tue Feb 12 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.0.3-1
|
||||
- New upstream version 0.4.0.3.
|
||||
- Rebuild for OCaml 3.10.1.
|
||||
|
||||
* Tue Nov 20 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.3.4-1
|
||||
- New upstream release 0.3.3.4.
|
||||
- Upstream website is now http://libvirt.org/ocaml/
|
||||
|
||||
* Fri Oct 19 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.3.0-2
|
||||
- Mistake: BR is ocaml-calendar-devel.
|
||||
|
||||
* Fri Oct 19 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.3.0-1
|
||||
- New upstream release 0.3.3.0.
|
||||
- Added support for virt-df, but disabled it by default.
|
||||
- +BR ocaml-calendar.
|
||||
|
||||
* Mon Sep 24 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.8-1
|
||||
- New upstream release 0.3.2.8.
|
||||
|
||||
* Thu Sep 20 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.7-1
|
||||
- New upstream release 0.3.2.7.
|
||||
- Ship the upstream ChangeLog file.
|
||||
|
||||
* Thu Sep 6 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.6-2
|
||||
- Force dependency on ocaml >= 3.10.0-7 which has fixed requires/provides
|
||||
scripts.
|
||||
|
||||
* Thu Sep 6 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.6-1
|
||||
- New upstream version 0.3.2.6.
|
||||
|
||||
* Wed Aug 29 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.5-1
|
||||
- New upstream version 0.3.2.5.
|
||||
- Keep TODO out of the main package, but add (renamed) TODO.libvirt and
|
||||
TODO.virt-top to the devel and virt-top packages respectively.
|
||||
- Add BR gawk.
|
||||
|
||||
* Thu Aug 23 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.4-1
|
||||
- New upstream version 0.3.2.4.
|
||||
|
||||
* Thu Aug 23 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.3-2
|
||||
- build_* macros so we can choose what subpackages to build.
|
||||
|
||||
* Thu Aug 23 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.3-1
|
||||
- Upstream version 0.3.2.3.
|
||||
- Add missing BR libvirt-devel.
|
||||
|
||||
* Wed Aug 22 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.2-1
|
||||
- Upstream version 0.3.2.2.
|
||||
|
||||
* Wed Aug 22 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.1-2
|
||||
- Fix unclosed if-statement in spec file.
|
||||
|
||||
* Wed Aug 22 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.1-1
|
||||
- Upstream version 0.3.2.1.
|
||||
- Put HTML documentation in -devel package.
|
||||
|
||||
* Mon Aug 6 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.1.2-1
|
||||
- Initial RPM release.
|
Loading…
Reference in New Issue
Block a user