Fix Source line.
Combine patches into single patch and update to latest sources.
This commit is contained in:
parent
2fd0a63b26
commit
6bf7a73629
@ -1,28 +0,0 @@
|
|||||||
--- labltk-8.06.0.old/support/Makefile.common 2014-09-18 05:08:33.000000000 +0100
|
|
||||||
+++ labltk-8.06.0/support/Makefile.common 2015-02-16 15:11:30.157186457 +0000
|
|
||||||
@@ -21,17 +21,17 @@
|
|
||||||
## Tools from the OCaml distribution
|
|
||||||
|
|
||||||
CAMLRUN=$(BINDIR)/ocamlrun
|
|
||||||
-CAMLC=$(BINDIR)/ocamlc$(OPT)
|
|
||||||
-CAMLOPT=$(BINDIR)/ocamlopt$(OPT)
|
|
||||||
-CAMLCB=$(BINDIR)/ocamlc
|
|
||||||
-CAMLOPTB=$(BINDIR)/ocamlopt
|
|
||||||
-CAMLCOMP=$(CAMLC) -c -warn-error A-3
|
|
||||||
+CAMLC=$(BINDIR)/ocamlc$(OPT) -g
|
|
||||||
+CAMLOPT=$(BINDIR)/ocamlopt$(OPT) -g
|
|
||||||
+CAMLCB=$(BINDIR)/ocamlc -g
|
|
||||||
+CAMLOPTB=$(BINDIR)/ocamlopt -g
|
|
||||||
+CAMLCOMP=$(CAMLC) -c -warn-error A-3 -g
|
|
||||||
CAMLYACC=$(BINDIR)/ocamlyacc -v
|
|
||||||
CAMLLEX=$(BINDIR)/ocamllex
|
|
||||||
-CAMLLIBR=$(CAMLC) -a
|
|
||||||
+CAMLLIBR=$(CAMLC) -a -g
|
|
||||||
CAMLDEP=$(BINDIR)/ocamldep
|
|
||||||
COMPFLAGS=-g
|
|
||||||
LINKFLAGS=
|
|
||||||
-CAMLOPTLIBR=$(CAMLOPT) -a
|
|
||||||
-MKLIB=$(BINDIR)/ocamlmklib
|
|
||||||
+CAMLOPTLIBR=$(CAMLOPT) -a -g
|
|
||||||
+MKLIB=$(BINDIR)/ocamlmklib -g
|
|
||||||
CAMLRUNGEN=$(BINDIR)/ocamlrun
|
|
41
labltk-8.06.11-enable-debugging.patch
Normal file
41
labltk-8.06.11-enable-debugging.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
diff -ur labltk-8.06.11.old/support/Makefile labltk-8.06.11/support/Makefile
|
||||||
|
--- labltk-8.06.11.old/support/Makefile 2021-10-04 19:10:57.000196523 +0100
|
||||||
|
+++ labltk-8.06.11/support/Makefile 2021-10-04 19:18:06.263137991 +0100
|
||||||
|
@@ -28,7 +28,7 @@
|
||||||
|
cltkFile.$(O) cltkMain.$(O) cltkMisc.$(O) cltkTimer.$(O) \
|
||||||
|
cltkVar.$(O) cltkWait.$(O) cltkImg.$(O)
|
||||||
|
|
||||||
|
-CCFLAGS=-I$(LIBDIR)/caml $(TK_DEFS) $(SHAREDCCCOMPOPTS)
|
||||||
|
+CCFLAGS=-I$(LIBDIR)/caml $(TK_DEFS) $(SHAREDCCCOMPOPTS) -g
|
||||||
|
|
||||||
|
COMPFLAGS=
|
||||||
|
THFLAGS=-I +threads -I vmthreads
|
||||||
|
diff -ur labltk-8.06.11.old/support/Makefile.common labltk-8.06.11/support/Makefile.common
|
||||||
|
--- labltk-8.06.11.old/support/Makefile.common 2021-10-04 19:10:56.990196618 +0100
|
||||||
|
+++ labltk-8.06.11/support/Makefile.common 2021-10-04 19:18:06.264137981 +0100
|
||||||
|
@@ -21,17 +21,17 @@
|
||||||
|
## Tools from the OCaml distribution
|
||||||
|
|
||||||
|
CAMLRUN=$(BINDIR)/ocamlrun
|
||||||
|
-CAMLC=$(BINDIR)/ocamlc$(OPT)
|
||||||
|
-CAMLOPT=$(BINDIR)/ocamlopt$(OPT) $(WARNERR)
|
||||||
|
-CAMLCB=$(BINDIR)/ocamlc
|
||||||
|
-CAMLOPTB=$(BINDIR)/ocamlopt
|
||||||
|
-CAMLCOMP=$(CAMLC) -c $(WARNERR)
|
||||||
|
+CAMLC=$(BINDIR)/ocamlc$(OPT) -g
|
||||||
|
+CAMLOPT=$(BINDIR)/ocamlopt$(OPT) $(WARNERR) -g
|
||||||
|
+CAMLCB=$(BINDIR)/ocamlc -g
|
||||||
|
+CAMLOPTB=$(BINDIR)/ocamlopt -g
|
||||||
|
+CAMLCOMP=$(CAMLC) -c $(WARNERR) -g
|
||||||
|
CAMLYACC=$(BINDIR)/ocamlyacc -v
|
||||||
|
CAMLLEX=$(BINDIR)/ocamllex
|
||||||
|
-CAMLLIBR=$(CAMLC) -a
|
||||||
|
+CAMLLIBR=$(CAMLC) -a -g
|
||||||
|
CAMLDEP=$(BINDIR)/ocamldep
|
||||||
|
COMPFLAGS=-g
|
||||||
|
LINKFLAGS=
|
||||||
|
-CAMLOPTLIBR=$(CAMLOPT) -a
|
||||||
|
-MKLIB=$(BINDIR)/ocamlmklib
|
||||||
|
+CAMLOPTLIBR=$(CAMLOPT) -a -g
|
||||||
|
+MKLIB=$(BINDIR)/ocamlmklib -g
|
||||||
|
CAMLRUNGEN=$(BINDIR)/ocamlrun
|
@ -1,11 +0,0 @@
|
|||||||
--- labltk-8.06.4.old/support/Makefile 2017-10-30 09:19:07.000000000 +0000
|
|
||||||
+++ labltk-8.06.4/support/Makefile 2017-11-07 21:24:58.244605912 +0000
|
|
||||||
@@ -28,7 +28,7 @@
|
|
||||||
cltkFile.$(O) cltkMain.$(O) cltkMisc.$(O) cltkTimer.$(O) \
|
|
||||||
cltkVar.$(O) cltkWait.$(O) cltkImg.$(O)
|
|
||||||
|
|
||||||
-CCFLAGS=-I$(LIBDIR)/caml $(TK_DEFS) $(SHAREDCCCOMPOPTS)
|
|
||||||
+CCFLAGS=-I$(LIBDIR)/caml $(TK_DEFS) $(SHAREDCCCOMPOPTS) -g
|
|
||||||
|
|
||||||
COMPFLAGS=
|
|
||||||
THFLAGS=-I +threads -I vmthreads
|
|
@ -13,11 +13,10 @@ Summary: Tcl/Tk interface for OCaml
|
|||||||
License: LGPLv2+ with exceptions
|
License: LGPLv2+ with exceptions
|
||||||
|
|
||||||
URL: https://github.com/garrigue/labltk
|
URL: https://github.com/garrigue/labltk
|
||||||
Source0: https://github.com/garrigue/labltk/archive/%{version}.tar.gz
|
Source0: https://github.com/garrigue/labltk/archive/%{version}/labltk-%{version}.tar.gz
|
||||||
|
|
||||||
# This adds debugging (-g) everywhere.
|
# This adds debugging (-g) everywhere.
|
||||||
Patch1: labltk-8.06.0-enable-debugging.patch
|
Patch1: labltk-8.06.11-enable-debugging.patch
|
||||||
Patch2: labltk-8.06.4-enable-more-debugging.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: ocaml
|
BuildRequires: ocaml
|
||||||
@ -46,7 +45,6 @@ This package contains the development files.
|
|||||||
%setup -q -n labltk-%{version}
|
%setup -q -n labltk-%{version}
|
||||||
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
# Remove version control files which might get copied into documentation.
|
# Remove version control files which might get copied into documentation.
|
||||||
find -name .gitignore -delete
|
find -name .gitignore -delete
|
||||||
|
Loading…
Reference in New Issue
Block a user