import ocaml-fileutils-0.5.2-29.el9
This commit is contained in:
commit
922eb2fdc9
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/ocaml-fileutils-0.5.2.tar.gz
|
1
.ocaml-fileutils.metadata
Normal file
1
.ocaml-fileutils.metadata
Normal file
@ -0,0 +1 @@
|
||||
ee236a4e6ec69b1007d19f7b0d7f56f094a21d8b SOURCES/ocaml-fileutils-0.5.2.tar.gz
|
20
SOURCES/fileutils-0.5.2-fix-bytes.patch
Normal file
20
SOURCES/fileutils-0.5.2-fix-bytes.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- ocaml-fileutils-0.5.2.old/src/FileUtilCP.ml 2017-05-23 21:12:19.000000000 +0100
|
||||
+++ ocaml-fileutils-0.5.2/src/FileUtilCP.ml 2017-11-08 17:36:42.271524209 +0000
|
||||
@@ -138,7 +138,7 @@
|
||||
end
|
||||
in
|
||||
|
||||
- let buffer = String.make 1024 ' ' in
|
||||
+ let buffer = Bytes.make 1024 ' ' in
|
||||
|
||||
let cp_file st_src dst_exists fn_src fn_dst =
|
||||
let mode = int_of_permission st_src.permission in
|
||||
@@ -176,7 +176,7 @@
|
||||
try
|
||||
while (read :=
|
||||
handle_exception
|
||||
- (Unix.read fd_src buffer 0) (String.length buffer)
|
||||
+ (Unix.read fd_src buffer 0) (Bytes.length buffer)
|
||||
(fun e -> `ErrorRead(fn_src, e));
|
||||
!read <> 0) do
|
||||
let written =
|
30
SOURCES/ocaml-fileutils-0.5.2-ounit2.patch
Normal file
30
SOURCES/ocaml-fileutils-0.5.2-ounit2.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff -ur ocaml-fileutils-0.5.2.old/setup.ml ocaml-fileutils-0.5.2.new/setup.ml
|
||||
--- ocaml-fileutils-0.5.2.old/setup.ml 2017-05-23 21:12:33.000000000 +0100
|
||||
+++ ocaml-fileutils-0.5.2.new/setup.ml 2020-02-27 08:52:42.964618292 +0000
|
||||
@@ -7621,7 +7621,7 @@
|
||||
InternalLibrary "fileutils";
|
||||
InternalLibrary "fileutils-str";
|
||||
FindlibPackage
|
||||
- ("oUnit",
|
||||
+ ("ounit2",
|
||||
Some (OASISVersion.VGreaterEqual "2.0.0"))
|
||||
];
|
||||
bs_build_tools = [ExternalTool "ocamlbuild"];
|
||||
diff -ur ocaml-fileutils-0.5.2.old/_tags ocaml-fileutils-0.5.2.new/_tags
|
||||
--- ocaml-fileutils-0.5.2.old/_tags 2017-05-23 21:12:33.000000000 +0100
|
||||
+++ ocaml-fileutils-0.5.2.new/_tags 2020-02-27 08:52:38.020680545 +0000
|
||||
@@ -25,12 +25,12 @@
|
||||
<test/BenchFind.{native,byte}>: pkg_unix
|
||||
<test/BenchFind.{native,byte}>: use_fileutils
|
||||
# Executable test
|
||||
-"test/test.byte": pkg_oUnit
|
||||
+"test/test.byte": pkg_ounit2
|
||||
"test/test.byte": pkg_str
|
||||
"test/test.byte": pkg_unix
|
||||
"test/test.byte": use_fileutils
|
||||
"test/test.byte": use_fileutils-str
|
||||
-<test/*.ml{,i,y}>: pkg_oUnit
|
||||
+<test/*.ml{,i,y}>: pkg_ounit2
|
||||
<test/*.ml{,i,y}>: pkg_str
|
||||
<test/*.ml{,i,y}>: pkg_unix
|
||||
<test/*.ml{,i,y}>: use_fileutils
|
351
SPECS/ocaml-fileutils.spec
Normal file
351
SPECS/ocaml-fileutils.spec
Normal file
@ -0,0 +1,351 @@
|
||||
Name: ocaml-fileutils
|
||||
Version: 0.5.2
|
||||
Release: 29%{?dist}
|
||||
Summary: OCaml library for common file and filename operations
|
||||
|
||||
License: LGPLv2 with exceptions
|
||||
URL: https://forge.ocamlcore.org/projects/ocaml-fileutils/
|
||||
Source0: http://forge.ocamlcore.org/frs/download.php/1695/ocaml-fileutils-0.5.2.tar.gz
|
||||
|
||||
Patch1: fileutils-0.5.2-fix-bytes.patch
|
||||
# Use ounit2.
|
||||
Patch2: ocaml-fileutils-0.5.2-ounit2.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: ocaml >= 4.00.1
|
||||
BuildRequires: ocaml-findlib-devel >= 1.3.3-3
|
||||
BuildRequires: ocaml-ocamldoc
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 6
|
||||
BuildRequires: ocaml-ounit-devel
|
||||
%endif
|
||||
BuildRequires: ocaml-ocamlbuild
|
||||
|
||||
|
||||
%description
|
||||
This library is intended to provide a basic interface to the most
|
||||
common file and filename operations. It provides several different
|
||||
filename functions: reduce, make_absolute, make_relative... It also
|
||||
enables you to manipulate real files: cp, mv, rm, touch...
|
||||
|
||||
It is separated into two modules: SysUtil and SysPath. The first one
|
||||
manipulates real files, the second one is made for manipulating
|
||||
abstract filenames.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and signature files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%autopatch -p1
|
||||
|
||||
|
||||
%build
|
||||
# Disable the tests (RHEL 7 only) since they require ocaml-ounit.
|
||||
ocaml setup.ml -configure --prefix %{_prefix} --destdir $RPM_BUILD_ROOT \
|
||||
%if 0%{?rhel} >= 7
|
||||
--disable-tests
|
||||
%else
|
||||
--enable-tests
|
||||
%endif
|
||||
make
|
||||
|
||||
|
||||
%install
|
||||
export DESTDIR=$RPM_BUILD_ROOT
|
||||
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
|
||||
mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
|
||||
|
||||
# Set htmldir to current directory, then copy the docs (in api/)
|
||||
# as a %doc rule.
|
||||
make htmldir=. install
|
||||
|
||||
|
||||
%check
|
||||
%if ! 0%{?rhel} >= 7
|
||||
make test
|
||||
%endif
|
||||
|
||||
|
||||
%files
|
||||
%doc COPYING.txt
|
||||
%{_libdir}/ocaml/fileutils
|
||||
%ifarch %{ocaml_native_compiler}
|
||||
%exclude %{_libdir}/ocaml/fileutils/*.a
|
||||
%exclude %{_libdir}/ocaml/fileutils/*.cmx
|
||||
%exclude %{_libdir}/ocaml/fileutils/*.cmxa
|
||||
%endif
|
||||
%exclude %{_libdir}/ocaml/fileutils/*.ml
|
||||
%exclude %{_libdir}/ocaml/fileutils/*.mli
|
||||
|
||||
|
||||
%files devel
|
||||
%doc COPYING.txt AUTHORS.txt CHANGELOG.txt README.txt TODO.txt
|
||||
%ifarch %{ocaml_native_compiler}
|
||||
%{_libdir}/ocaml/fileutils/*.a
|
||||
%{_libdir}/ocaml/fileutils/*.cmx
|
||||
%{_libdir}/ocaml/fileutils/*.cmxa
|
||||
%endif
|
||||
%{_libdir}/ocaml/fileutils/*.ml
|
||||
%{_libdir}/ocaml/fileutils/*.mli
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 11 2022 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-29
|
||||
- Rebuild for EPEL
|
||||
resolves: rhbz#2060850
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.5.2-28
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Wed Jun 23 2021 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-27
|
||||
- Bump and rebuild
|
||||
resolves: rhbz#1975307
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.5.2-26
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-25
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Sep 01 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-24
|
||||
- OCaml 4.11.1 rebuild
|
||||
|
||||
* Fri Aug 21 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-23
|
||||
- OCaml 4.11.0 rebuild
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-22
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue May 05 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-20
|
||||
- Bump and rebuild for s390x.
|
||||
|
||||
* Tue May 05 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-19
|
||||
- OCaml 4.11.0+dev2-2020-04-22 rebuild
|
||||
|
||||
* Tue Apr 21 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-18
|
||||
- OCaml 4.11.0 pre-release attempt 2
|
||||
|
||||
* Sat Apr 04 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-17
|
||||
- Update all OCaml dependencies for RPM 4.16.
|
||||
|
||||
* Wed Feb 26 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-16
|
||||
- OCaml 4.10.0 final.
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sun Jan 19 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-14
|
||||
- OCaml 4.10.0+beta1 rebuild.
|
||||
|
||||
* Thu Jan 09 2020 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-13
|
||||
- OCaml 4.09.0 for riscv64
|
||||
|
||||
* Fri Dec 06 2019 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-12
|
||||
- OCaml 4.09.0 (final) rebuild.
|
||||
|
||||
* Fri Aug 16 2019 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-11
|
||||
- OCaml 4.08.1 (final) rebuild.
|
||||
|
||||
* Wed Jul 31 2019 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-10
|
||||
- OCaml 4.08.1 (rc2) rebuild.
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jun 27 2019 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-8
|
||||
- OCaml 4.08.0 (final) rebuild.
|
||||
|
||||
* Mon Apr 29 2019 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-7
|
||||
- OCaml 4.08.0 (beta 3) rebuild.
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Jul 11 2018 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-4
|
||||
- OCaml 4.07.0 (final) rebuild.
|
||||
|
||||
* Wed Jun 20 2018 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-3
|
||||
- OCaml 4.07.0-rc1 rebuild.
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Nov 08 2017 Richard W.M. Jones <rjones@redhat.com> - 0.5.2-1
|
||||
- New upstream version 0.5.2.
|
||||
- OCaml 4.06.0 rebuild.
|
||||
|
||||
* Mon Aug 07 2017 Richard W.M. Jones <rjones@redhat.com> - 0.5.1-8
|
||||
- OCaml 4.05.0 rebuild.
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jun 26 2017 Richard W.M. Jones <rjones@redhat.com> - 0.5.1-5
|
||||
- OCaml 4.04.2 rebuild.
|
||||
|
||||
* Fri May 12 2017 Richard W.M. Jones <rjones@redhat.com> - 0.5.1-4
|
||||
- OCaml 4.04.1 rebuild.
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Nov 09 2016 Dan Horák <dan@danny.cz> - 0.5.1-2
|
||||
- rebuild for s390x codegen bug
|
||||
|
||||
* Fri Nov 04 2016 Richard W.M. Jones <rjones@redhat.com> - 0.5.1-1
|
||||
- New upstream version 0.5.1.
|
||||
- Add explicit dependency on ocamlbuild.
|
||||
|
||||
* Mon Sep 12 2016 Dan Horák <dan[at]danny.cz> - 0.4.5-17
|
||||
- disable debuginfo subpackage on interpreted builds
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.5-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2015 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-15
|
||||
- OCaml 4.02.3 rebuild.
|
||||
|
||||
* Mon Jul 27 2015 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-14
|
||||
- Remove ExcludeArch since bytecode build should now work.
|
||||
|
||||
* Tue Jun 23 2015 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-13
|
||||
- Bump release and rebuild.
|
||||
|
||||
* Wed Jun 17 2015 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-12
|
||||
- ocaml-4.02.2 rebuild.
|
||||
|
||||
* Mon Feb 16 2015 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-11
|
||||
- ocaml-4.02.1 rebuild.
|
||||
|
||||
* Sat Aug 30 2014 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-10
|
||||
- ocaml-4.02.0 final rebuild.
|
||||
|
||||
* Sat Aug 23 2014 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-9
|
||||
- ocaml-4.02.0+rc1 rebuild.
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.5-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Aug 02 2014 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-7
|
||||
- ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
|
||||
|
||||
* Mon Jul 21 2014 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-6
|
||||
- OCaml 4.02.0 beta rebuild.
|
||||
|
||||
* Mon Jul 14 2014 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-5
|
||||
- Rebuild for OCaml 4.02.0.
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Sep 14 2013 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-1
|
||||
- New upstream version 0.4.5.
|
||||
- Enable debuginfo.
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.4-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Tue Nov 27 2012 Richard W.M. Jones <rjones@redhat.com> - 0.4.4-4
|
||||
- BR >= OCaml 4.00.1 so we can't be built against the wrong OCaml.
|
||||
|
||||
* Tue Nov 27 2012 Richard W.M. Jones <rjones@redhat.com> - 0.4.4-3
|
||||
- Disable the tests on RHEL 7, since they require ocaml-ounit.
|
||||
|
||||
* Fri Oct 19 2012 Richard W.M. Jones <rjones@redhat.com> - 0.4.4-2
|
||||
- New upstream version 0.4.4.
|
||||
- Clean up the spec file.
|
||||
- Fix homepage and download URLs.
|
||||
- Don't use configure macro. Upstream are using some sort of non-autoconf
|
||||
brokenness.
|
||||
- Rename text files as *.txt. There is no 'api' directory any more.
|
||||
|
||||
* Sat Jul 28 2012 Richard W.M. Jones <rjones@redhat.com> - 0.4.0-10
|
||||
- Bump and rebuild against new OCaml 4.00.0 official release.
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jun 09 2012 Richard W.M. Jones <rjones@redhat.com> - 0.4.0-8
|
||||
- Rebuild for OCaml 4.00.0.
|
||||
|
||||
* Mon May 14 2012 Richard W.M. Jones <rjones@redhat.com> - 0.4.0-7
|
||||
- Bump release and rebuild for new OCaml on ARM.
|
||||
|
||||
* Fri Jan 06 2012 Richard W.M. Jones <rjones@redhat.com> - 0.4.0-6
|
||||
- Rebuild for OCaml 3.12.1.
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Jan 05 2011 Richard W.M. Jones <rjones@redhat.com> - 0.4.0-4
|
||||
- Rebuild for OCaml 3.12 (http://fedoraproject.org/wiki/Features/OCaml3.12).
|
||||
|
||||
* Wed Dec 30 2009 Richard W.M. Jones <rjones@redhat.com> - 0.4.0-3
|
||||
- Rebuild for OCaml 3.11.2.
|
||||
|
||||
* Thu Oct 8 2009 Richard W.M. Jones <rjones@redhat.com> - 0.4.0-2
|
||||
- New upstream version 0.4.0.
|
||||
- Upstream build system has been rationalized, so remove all the
|
||||
hacks we were using.
|
||||
- Upstream now contains tests, run them.
|
||||
- Needs ounit in order to carry out the tests.
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Sat May 23 2009 Richard W.M. Jones <rjones@redhat.com> - 0.3.0-10
|
||||
- Rebuild for OCaml 3.11.1
|
||||
|
||||
* Thu Apr 16 2009 S390x secondary arch maintainer <fedora-s390x@lists.fedoraproject.org>
|
||||
- ExcludeArch sparc64, s390, s390x as we don't have OCaml on those archs
|
||||
(added sparc64 per request from the sparc maintainer)
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Nov 26 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.0-8
|
||||
- Rebuild for OCaml 3.11.0+rc1.
|
||||
|
||||
* Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.0-7
|
||||
- Rebuild for OCaml 3.11.0
|
||||
|
||||
* Wed Apr 23 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.0-5
|
||||
- Rebuild for OCaml 3.10.2
|
||||
|
||||
* Sat Mar 1 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.0-4
|
||||
- Rebuild for ppc64.
|
||||
|
||||
* Thu Feb 21 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.0-3
|
||||
- Fixed grammar in the description section.
|
||||
- License is LGPLv2 with exceptions
|
||||
- Include license file with both RPMs.
|
||||
- Include other documentation only in the -devel RPM.
|
||||
|
||||
* Tue Feb 12 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.0-2
|
||||
- Added BR ocaml-camlp4-devel.
|
||||
- Build into tmp directory under the build root.
|
||||
|
||||
* Wed Aug 8 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.0-1
|
||||
- Initial RPM release.
|
Loading…
Reference in New Issue
Block a user