ee4adc67d7
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/ocaml-dune#6f162e464e2afd8775b983ce9185d434f105d8e5
43 lines
1.3 KiB
Diff
43 lines
1.3 KiB
Diff
From 8a3d7f2f2015b71384caa07226d1a89dba9d6c25 Mon Sep 17 00:00:00 2001
|
|
From: Mario Rodas <marsam@users.noreply.github.com>
|
|
Date: Wed, 2 Sep 2020 20:00:00 -0500
|
|
Subject: [PATCH] src/dune/setup.ml is now src/dune_rules/setup.ml
|
|
|
|
src/dune/setup.ml was renamed in bebb7a9432b149fce95ac820757216372afb8f0f
|
|
|
|
Signed-off-by: Mario Rodas <marsam@users.noreply.github.com>
|
|
---
|
|
Makefile | 2 +-
|
|
configure.ml | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 4ae969a9..52d5d20a 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -103,7 +103,7 @@ clean: $(BIN)
|
|
rm -rf _boot dune.exe
|
|
|
|
distclean: clean
|
|
- rm -f src/dune/setup.ml
|
|
+ rm -f src/dune_rules/setup.ml
|
|
|
|
doc:
|
|
cd doc && sphinx-build . _build
|
|
diff --git a/configure.ml b/configure.ml
|
|
index f5366f17..c1fe8d30 100644
|
|
--- a/configure.ml
|
|
+++ b/configure.ml
|
|
@@ -44,7 +44,7 @@ let () =
|
|
let anon s = bad "Don't know what to do with %s" s in
|
|
Arg.parse (Arg.align args) anon
|
|
"Usage: ocaml configure.ml [OPTRIONS]]\nOptions are:";
|
|
- let oc = open_out "src/dune/setup.ml" in
|
|
+ let oc = open_out "src/dune_rules/setup.ml" in
|
|
let pr fmt = fprintf oc (fmt ^^ "\n") in
|
|
pr "let library_path = %s" (option (list string) !library_path);
|
|
pr "let library_destdir = %s" (option string !library_destdir);
|
|
--
|
|
2.26.2
|
|
|