diff --git a/ocaml-dune-debuginfo.patch b/ocaml-dune-debuginfo.patch
index 8cb3cb3..8917c71 100644
--- a/ocaml-dune-debuginfo.patch
+++ b/ocaml-dune-debuginfo.patch
@@ -1,9 +1,9 @@
---- dune-3.8.1/src/dune_rules/dune_project.ml.orig	2023-06-05 10:33:12.000000000 -0600
-+++ dune-3.8.1/src/dune_rules/dune_project.ml	2023-06-09 15:43:53.671558827 -0600
-@@ -465,7 +465,7 @@ let implicit_transitive_deps_default ~la
- let wrapped_executables_default ~(lang : Lang.Instance.t) =
-   lang.version >= (2, 0)
- 
+--- dune-3.11.0/src/dune_rules/dune_project.ml.orig	2023-09-23 19:52:10.552217543 -0600
++++ dune-3.11.0/src/dune_rules/dune_project.ml	2023-09-23 22:03:32.641347776 -0600
+@@ -455,7 +455,7 @@ let filename = "dune-project"
+ let opam_file_location_default ~lang:_ = `Relative_to_project
+ let implicit_transitive_deps_default ~lang:_ = true
+ let wrapped_executables_default ~(lang : Lang.Instance.t) = lang.version >= (2, 0)
 -let map_workspace_root_default ~(lang : Lang.Instance.t) = lang.version >= (3, 0)
 +let map_workspace_root_default ~(lang : Lang.Instance.t) = false
  
diff --git a/ocaml-dune.spec b/ocaml-dune.spec
index 2e4db3c..a251de0 100644
--- a/ocaml-dune.spec
+++ b/ocaml-dune.spec
@@ -8,7 +8,7 @@
 %bcond_with lwt
 
 Name:           ocaml-dune
-Version:        3.10.0
+Version:        3.11.0
 Release:        1%{?dist}
 Summary:        Composable build system for OCaml and Reason
 
@@ -31,6 +31,8 @@ Summary:        Composable build system for OCaml and Reason
 # - vendor/0install-solver
 # MIT:
 # - vendor/build_path_prefix_map
+# - vendor/fiber
+# - vendor/lwd
 # - vendor/spawn
 License:        MIT AND ISC AND LGPL-2.0-only AND LGPL-2.0-only WITH OCaml-LGPL-linking-exception AND LGPL-2.1-or-later
 URL:            https://dune.build
@@ -47,8 +49,10 @@ ExcludeArch: %{ix86}
 BuildRequires:  emacs-nox
 BuildRequires:  make
 BuildRequires:  ocaml >= 4.08
+BuildRequires:  ocaml-compiler-libs
 BuildRequires:  ocaml-csexp-devel >= 1.5.0
 BuildRequires:  ocaml-pp-devel >= 1.1.0
+BuildRequires:  ocaml-rpm-macros
 BuildRequires:  %{py3_dist sphinx}
 BuildRequires:  %{py3_dist sphinx-copybutton}
 BuildRequires:  %{py3_dist sphinx-rtd-theme}
@@ -63,11 +67,13 @@ BuildRequires:  ocaml-lwt-devel
 Provides:       bundled(ocaml-0install-solver) = 2.18
 Provides:       bundled(ocaml-build-path-prefix-map) = 0.3
 Provides:       bundled(ocaml-cmdliner) = 1.1.1
+Provides:       bundled(ocaml-fiber) = 3.7.0
 Provides:       bundled(ocaml-fmt) = 0.8.10
 Provides:       bundled(ocaml-incremental-cycles) = 1e2030a5d5183d84561cde142eecca40e03db2a3
 Provides:       bundled(ocaml-inotify) = 2.3
+Provides:       bundled(ocaml-lwd) = 0.3
 Provides:       bundled(ocaml-notty) = 0.2.3
-Provides:       bundled(ocaml-opam) = 2.1.4
+Provides:       bundled(ocaml-opam) = 2.1.5
 Provides:       bundled(ocaml-opam-0install) = 0.4.3
 Provides:       bundled(ocaml-opam-file-format) = 2.1.6
 Provides:       bundled(ocaml-re) = 1.9.0
@@ -78,7 +84,10 @@ Provides:       bundled(ocaml-uutf) = 1.0.3
 Provides:       dune = %{version}-%{release}
 
 # This is needed for the dune-related RPM macros
-Requires:       python3
+Requires:       ocaml-rpm-macros
+
+# The dune rules module requires Toploop
+Requires:       ocaml-compiler-libs%{?_isa}
 
 # Both packages install a binary named dune and an associated man page
 Conflicts:      wdune
@@ -92,9 +101,6 @@ Provides:       ocaml-fiber-devel = %{version}-%{release}
 # Install documentation in the main package doc directory
 %global _docdir_fmt %{name}
 
-# Do not require ocaml-compiler-libs at runtime
-%global __ocaml_requires_opts -i Asttypes -i Build_path_prefix_map -i Cmi_format -i Env -i Ident -i Identifiable -i Load_path -i Location -i Longident -i Misc -i Outcometree -i Parsetree -i Path -i Primitive -i Shape -i Subst -i Topdirs -i Toploop -i Type_immediacy -i Types -i Warnings
-
 %description
 Dune is a build system designed for OCaml/Reason projects only. It focuses
 on providing the user with a consistent experience and takes care of most of
@@ -567,6 +573,9 @@ cd -
 %files -n ocaml-xdg-devel -f .ofiles-xdg-devel
 
 %changelog
+* Wed Oct  4 2023 Jerry James <loganjerry@gmail.com> - 3.11.0-1
+- Version 3.11.0
+
 * Tue Aug  1 2023 Jerry James <loganjerry@gmail.com> - 3.10.0-1
 - Version 3.10.0
 
diff --git a/sources b/sources
index 245e956..cb70797 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (dune-3.10.0.tar.gz) = 2884a4eaaa44164ce911286ca6670b548a4a564e2b5040f05405d1d2729af84083fbfdde7c92db4f6f7a54d15a43fc9dddcec19d8d79d5a66221b2be861473de
+SHA512 (dune-3.11.0.tar.gz) = e8bb95d53acb7f5fbd0a144fb2a9350e9280dc0306cdf309b4ad0093821a665b9a231417783210315edcf8e0097b4a0d3b7b10ce3fc04d3183337f463233d755