Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/ocaml-dune.git#6e96dffe9beda6f029adf80e5753fb4ffa08aaa8
This commit is contained in:
parent
4a23d5bd6b
commit
67c32a9352
@ -1,42 +0,0 @@
|
||||
From 8a3d7f2f2015b71384caa07226d1a89dba9d6c25 Mon Sep 17 00:00:00 2001
|
||||
From: Mario Rodas <marsam@users.noreply.github.com>
|
||||
Date: Wed, 2 Sep 2020 20:00:00 -0500
|
||||
Subject: [PATCH] src/dune/setup.ml is now src/dune_rules/setup.ml
|
||||
|
||||
src/dune/setup.ml was renamed in bebb7a9432b149fce95ac820757216372afb8f0f
|
||||
|
||||
Signed-off-by: Mario Rodas <marsam@users.noreply.github.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
configure.ml | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 4ae969a9..52d5d20a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -103,7 +103,7 @@ clean: $(BIN)
|
||||
rm -rf _boot dune.exe
|
||||
|
||||
distclean: clean
|
||||
- rm -f src/dune/setup.ml
|
||||
+ rm -f src/dune_rules/setup.ml
|
||||
|
||||
doc:
|
||||
cd doc && sphinx-build . _build
|
||||
diff --git a/configure.ml b/configure.ml
|
||||
index f5366f17..c1fe8d30 100644
|
||||
--- a/configure.ml
|
||||
+++ b/configure.ml
|
||||
@@ -44,7 +44,7 @@ let () =
|
||||
let anon s = bad "Don't know what to do with %s" s in
|
||||
Arg.parse (Arg.align args) anon
|
||||
"Usage: ocaml configure.ml [OPTRIONS]]\nOptions are:";
|
||||
- let oc = open_out "src/dune/setup.ml" in
|
||||
+ let oc = open_out "src/dune_rules/setup.ml" in
|
||||
let pr fmt = fprintf oc (fmt ^^ "\n") in
|
||||
pr "let library_path = %s" (option (list string) !library_path);
|
||||
pr "let library_destdir = %s" (option string !library_destdir);
|
||||
--
|
||||
2.26.2
|
||||
|
@ -5,8 +5,8 @@
|
||||
%bcond_without menhir
|
||||
|
||||
Name: ocaml-%{libname}
|
||||
Version: 2.7.1
|
||||
Release: 2%{?dist}
|
||||
Version: 2.8.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A composable build system for OCaml
|
||||
|
||||
# Dune itself is MIT. Some bundled libraries have a different license:
|
||||
@ -22,14 +22,10 @@ License: MIT and LGPLv2 and LGPLv2 with exceptions and ISC
|
||||
URL: https://dune.build
|
||||
Source0: https://github.com/ocaml/%{libname}/archive/%{version}/%{libname}-%{version}.tar.gz
|
||||
|
||||
# Fix path to the configuration file
|
||||
# https://github.com/ocaml/dune/pull/3757
|
||||
Patch0: 9749697c9f6cd5848d2083faa84836b7dd8fbd4b.patch
|
||||
|
||||
BuildRequires: emacs
|
||||
BuildRequires: make
|
||||
BuildRequires: ocaml >= 4.08
|
||||
BuildRequires: ocaml-csexp-devel
|
||||
BuildRequires: ocaml-csexp-devel >= 1.3.0
|
||||
BuildRequires: ocaml-findlib
|
||||
BuildRequires: %{py3_dist sphinx}
|
||||
BuildRequires: %{py3_dist sphinx-rtd-theme}
|
||||
@ -46,8 +42,8 @@ BuildRequires: ocaml-menhir
|
||||
# https://github.com/ocaml/dune/issues/220
|
||||
Provides: bundled(ocaml-build-path-prefix-map) = 0.2
|
||||
Provides: bundled(ocaml-opam-file-format) = 2.0.0
|
||||
Provides: bundled(ocaml-cmdliner) = 1.0.3
|
||||
Provides: bundled(ocaml-re) = 1.7.1
|
||||
Provides: bundled(ocaml-cmdliner) = 1.0.4
|
||||
Provides: bundled(ocaml-re) = 1.9.0
|
||||
|
||||
Provides: dune = %{version}-%{release}
|
||||
|
||||
@ -107,9 +103,13 @@ system, a mode to edit dune files, and flymake support for dune files.
|
||||
./dune.exe build @install
|
||||
%make_build doc
|
||||
|
||||
# Relink the stublib. See https://github.com/ocaml/dune/issues/2977.
|
||||
# Relink the stublibs. See https://github.com/ocaml/dune/issues/2977.
|
||||
cd _build/default/src/stdune
|
||||
ocamlmklib -g -ldopt "$RPM_LD_FLAGS" -o stdune_stubs fcntl_stubs.o
|
||||
ocamlmklib -g -ldopt "%{build_ldflags}" -o stdune_stubs fcntl_stubs.o
|
||||
cd -
|
||||
cd _build/default/src/dune_filesystem_stubs
|
||||
ocamlmklib -g -ldopt "%{build_ldflags}" -o dune_filesystem_stubs_stubs \
|
||||
$(ar t libdune_filesystem_stubs_stubs.a)
|
||||
cd -
|
||||
|
||||
%install
|
||||
@ -156,16 +156,22 @@ cp -ar README.md CHANGES.md MIGRATION.md doc/_build/* %{buildroot}%{_pkgdocdir}/
|
||||
%dir %{_libdir}/ocaml/dune-private-libs/dune_re/
|
||||
%dir %{_libdir}/ocaml/dune-private-libs/ocaml-config/
|
||||
%dir %{_libdir}/ocaml/dune-private-libs/stdune/
|
||||
%dir %{_libdir}/ocaml/dune-site/
|
||||
%dir %{_libdir}/ocaml/dune-site/plugins/
|
||||
%{_libdir}/ocaml/dune*/META
|
||||
%{_libdir}/ocaml/dune*/*.cma
|
||||
%{_libdir}/ocaml/dune*/*.cmi
|
||||
%{_libdir}/ocaml/dune-configurator/.private/
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.cma
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.cmi
|
||||
%{_libdir}/ocaml/dune-site/*/*.cma
|
||||
%{_libdir}/ocaml/dune-site/*/*.cmi
|
||||
%ifarch %{ocaml_native_compiler}
|
||||
%{_libdir}/ocaml/dune*/*.cmxs
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.cmxs
|
||||
%{_libdir}/ocaml/dune-site/*/*.cmxs
|
||||
%{_libdir}/ocaml/stublibs/dllstdune_stubs.so
|
||||
%{_libdir}/ocaml/stublibs/dlldune_filesystem_stubs_stubs.so
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
@ -179,6 +185,10 @@ cp -ar README.md CHANGES.md MIGRATION.md doc/_build/* %{buildroot}%{_pkgdocdir}/
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.cmti
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.ml
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.mli
|
||||
%{_libdir}/ocaml/dune-site/*/*.cmt
|
||||
%{_libdir}/ocaml/dune-site/*/*.cmti
|
||||
%{_libdir}/ocaml/dune-site/*/*.ml
|
||||
%{_libdir}/ocaml/dune-site/*/*.mli
|
||||
%ifarch %{ocaml_native_compiler}
|
||||
%{_libdir}/ocaml/dune*/*.a
|
||||
%{_libdir}/ocaml/dune*/*.cmx
|
||||
@ -186,6 +196,9 @@ cp -ar README.md CHANGES.md MIGRATION.md doc/_build/* %{buildroot}%{_pkgdocdir}/
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.a
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.cmx
|
||||
%{_libdir}/ocaml/dune-private-libs/*/*.cmxa
|
||||
%{_libdir}/ocaml/dune-site/*/*.a
|
||||
%{_libdir}/ocaml/dune-site/*/*.cmx
|
||||
%{_libdir}/ocaml/dune-site/*/*.cmxa
|
||||
%endif
|
||||
|
||||
%files doc
|
||||
@ -197,6 +210,10 @@ cp -ar README.md CHANGES.md MIGRATION.md doc/_build/* %{buildroot}%{_pkgdocdir}/
|
||||
%{_emacs_sitelispdir}/dune*
|
||||
|
||||
%changelog
|
||||
* Wed Jan 13 2021 Jerry James <loganjerry@gmail.com> - 2.8.0-1
|
||||
- Version 2.8.0
|
||||
- Drop upstreamed patch from pull request 3757
|
||||
|
||||
* Fri Sep 18 2020 Jerry James <loganjerry@gmail.com> - 2.7.1-2
|
||||
- Add ocaml-csexp-devel R to the -devel subpackage
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dune-2.7.1.tar.gz) = b77d0e207263107365e5a6e94423e8ab4ddbab1f920872d915e4014b7cc69915274b53fe946bb4b29dfe3de2bf5573ab3b2bffb4db8eb50b472e7dfb6cab88b7
|
||||
SHA512 (dune-2.8.0.tar.gz) = e594afed20a4ef7205122f60fbd839cf704602412738ee408dc24cfbdca0036b651a4b5c03ef5e0edad7a6c7fd9049624fffc7dc10774fdc73b77dee720e28a3
|
||||
|
Loading…
Reference in New Issue
Block a user