Revert back to pre-release of 0.8.6.
The 0.8.6 version throws a Not_found error which breaks ocaml-gettext. Revert back to the previous working version. Revert "Avoid a stack overflow in the OCaml 4.05 compiler on POWER only." This reverts commit9c0d3bbc74
. Revert "New upstream version 0.8.6." This reverts commit194663eaf7
.
This commit is contained in:
parent
9c0d3bbc74
commit
5373cd587b
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,4 +3,3 @@ camomile-0.7.2.tar.bz2
|
|||||||
/camomile-0.8.3.tar.bz2
|
/camomile-0.8.3.tar.bz2
|
||||||
/camomile-0.8.5.tar.bz2
|
/camomile-0.8.5.tar.bz2
|
||||||
/camomile-3f4d657d.tar.gz
|
/camomile-3f4d657d.tar.gz
|
||||||
/camomile-0.8.6.tar.gz
|
|
||||||
|
11
camomile-0.8.3-enable-debug.patch
Normal file
11
camomile-0.8.3-enable-debug.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- camomile-0.8.3/Makefile.in.old 2013-09-14 07:39:54.498539889 +0100
|
||||||
|
+++ camomile-0.8.3/Makefile.in 2013-09-14 07:40:02.920552224 +0100
|
||||||
|
@@ -65,7 +65,7 @@
|
||||||
|
SUBDIR = -I internal -I public -I toolslib -I .
|
||||||
|
INCLUDES = $(SUBDIR)
|
||||||
|
BFLAGS = $(BOPTIONS) $(INCLUDES)
|
||||||
|
-OFLAGS = $(OOPTIONS) $(INCLUDES)
|
||||||
|
+OFLAGS = $(OOPTIONS) $(INCLUDES) -g
|
||||||
|
|
||||||
|
# Generic targets
|
||||||
|
#################
|
@ -1,6 +1,11 @@
|
|||||||
|
# Currently building git releases from
|
||||||
|
# https://github.com/yoriyuki/Camomile
|
||||||
|
%global commit 3f4d657d50c17213f3338ca75efb30d728704df3
|
||||||
|
%global shortcommit 3f4d657d
|
||||||
|
|
||||||
Name: ocaml-camomile
|
Name: ocaml-camomile
|
||||||
Version: 0.8.6
|
Version: 0.8.6
|
||||||
Release: 1%{?dist}
|
Release: 0.1.git%{shortcommit}%{?dist}
|
||||||
Summary: Unicode library for OCaml
|
Summary: Unicode library for OCaml
|
||||||
|
|
||||||
# Several files are MIT and UCD licensed, but the overall work is LGPLv2+
|
# Several files are MIT and UCD licensed, but the overall work is LGPLv2+
|
||||||
@ -8,14 +13,19 @@ Summary: Unicode library for OCaml
|
|||||||
# https://www.redhat.com/archives/fedora-legal-list/2008-March/msg00005.html
|
# https://www.redhat.com/archives/fedora-legal-list/2008-March/msg00005.html
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/yoriyuki/Camomile
|
URL: https://github.com/yoriyuki/Camomile
|
||||||
Source0: https://github.com/yoriyuki/Camomile/archive/rel-%{version}/camomile-%{version}.tar.gz
|
Source0: https://github.com/yoriyuki/Camomile/archive/%{commit}/camomile-%{shortcommit}.tar.gz
|
||||||
|
|
||||||
|
# Use ocamlopt -g option to enable debuginfo.
|
||||||
|
Patch1: camomile-0.8.3-enable-debug.patch
|
||||||
|
|
||||||
BuildRequires: ocaml >= 3.12.1-12
|
BuildRequires: ocaml >= 3.12.1-12
|
||||||
BuildRequires: ocaml-findlib-devel
|
BuildRequires: ocaml-findlib-devel
|
||||||
BuildRequires: ocaml-ocamldoc
|
BuildRequires: ocaml-ocamldoc
|
||||||
BuildRequires: ocaml-camlp4-devel
|
BuildRequires: ocaml-camlp4-devel
|
||||||
BuildRequires: ocaml-cppo
|
BuildRequires: ocaml-cppo
|
||||||
BuildRequires: jbuilder
|
|
||||||
|
# While we are building from git pre-releases we must run autoconf.
|
||||||
|
BuildRequires: autoconf
|
||||||
|
|
||||||
# The base package requires the data files. Note that it is possible
|
# The base package requires the data files. Note that it is possible
|
||||||
# to install the data files on their own to support other packages
|
# to install the data files on their own to support other packages
|
||||||
@ -51,39 +61,39 @@ applications that use %{name}.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n Camomile-rel-%{version}
|
%setup -q -n Camomile-%{commit}
|
||||||
|
cd Camomile
|
||||||
|
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
autoconf
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# This avoids a stack overflow in the OCaml 4.05 compiler on POWER only.
|
cd Camomile
|
||||||
%ifarch %{power64}
|
# Parallel builds don't work.
|
||||||
ulimit -Hs 65536
|
unset MAKEFLAGS
|
||||||
ulimit -Ss 65536
|
./configure --prefix=%{_prefix} --datadir=%{_datadir} --libdir=%{_libdir}
|
||||||
%endif
|
make
|
||||||
jbuilder build --verbose
|
make dochtml
|
||||||
|
make man
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
# We have to do this by hand because jbuilder doesn't work.
|
cd Camomile
|
||||||
export DESTDIR=$RPM_BUILD_ROOT
|
export DESTDIR=$RPM_BUILD_ROOT
|
||||||
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
|
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
|
||||||
mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
|
mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}
|
make install
|
||||||
ocamlfind install camomile _build/install/default/lib/camomile/*
|
|
||||||
cp -r _build/install/default/share/camomile $RPM_BUILD_ROOT%{_datadir}
|
|
||||||
%ifarch %{ocaml_native_compiler}
|
%ifarch %{ocaml_native_compiler}
|
||||||
cp _build/default/Camomile/tools/camomilecharmap.exe $RPM_BUILD_ROOT%{_bindir}/camomilecharmap
|
cp tools/camomilecharmap.opt $RPM_BUILD_ROOT%{_bindir}/camomilecharmap
|
||||||
cp _build/default/Camomile/tools/camomilelocaledef.exe $RPM_BUILD_ROOT%{_bindir}/camomilelocaledef
|
cp tools/camomilelocaledef.opt $RPM_BUILD_ROOT%{_bindir}/camomilelocaledef
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%check
|
|
||||||
jbuilder runtest
|
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc README
|
%doc Camomile/README
|
||||||
%{_libdir}/ocaml/camomile
|
%{_libdir}/ocaml/camomile
|
||||||
%ifarch %{ocaml_native_compiler}
|
%ifarch %{ocaml_native_compiler}
|
||||||
%exclude %{_libdir}/ocaml/camomile/*.a
|
%exclude %{_libdir}/ocaml/camomile/*.a
|
||||||
@ -98,7 +108,7 @@ jbuilder runtest
|
|||||||
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%doc README web/dochtml/*
|
%doc Camomile/README Camomile/dochtml/*
|
||||||
%ifarch %{ocaml_native_compiler}
|
%ifarch %{ocaml_native_compiler}
|
||||||
%{_libdir}/ocaml/camomile/*.a
|
%{_libdir}/ocaml/camomile/*.a
|
||||||
%{_libdir}/ocaml/camomile/*.cmxa
|
%{_libdir}/ocaml/camomile/*.cmxa
|
||||||
@ -108,19 +118,11 @@ jbuilder runtest
|
|||||||
|
|
||||||
|
|
||||||
%files data
|
%files data
|
||||||
%doc README
|
%doc Camomile/README
|
||||||
%{_datadir}/camomile/
|
%{_datadir}/camomile/
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Oct 17 2017 Richard W.M. Jones <rjones@redhat.com> - 0.8.6-1
|
|
||||||
- New upstream version 0.8.6.
|
|
||||||
- Switch back to versioned releases.
|
|
||||||
- Use new build system.
|
|
||||||
- Enable parallel builds.
|
|
||||||
- Drop -g patch since that seems to work by default now.
|
|
||||||
- Run tests.
|
|
||||||
|
|
||||||
* Mon Aug 07 2017 Richard W.M. Jones <rjones@redhat.com> - 0.8.6-0.1
|
* Mon Aug 07 2017 Richard W.M. Jones <rjones@redhat.com> - 0.8.6-0.1
|
||||||
- Build from git releases.
|
- Build from git releases.
|
||||||
- OCaml 4.05.0 rebuild.
|
- OCaml 4.05.0 rebuild.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (camomile-0.8.6.tar.gz) = d31d7015640ced3da47055ae3d4d8f868018b63e825e5a208420641aa6515b8753eacaf03f1d26239086d186ee4a293de17e97b634a335bb62eb399708f95353
|
SHA512 (camomile-3f4d657d.tar.gz) = 32141ce1b1ab4d199092838a8fc57341a0c2fab395f4d6530d9e4e28a8dab6fcc85841149ec0f9e614606c78a305f5a1aa862124e447fd67597389b2370b5907
|
||||||
|
Loading…
Reference in New Issue
Block a user