New upstream version 0.8.6.

This commit is contained in:
Richard W.M. Jones 2017-10-17 15:07:42 +01:00
parent 06fddcf8d8
commit 194663eaf7
4 changed files with 28 additions and 45 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@ camomile-0.7.2.tar.bz2
/camomile-0.8.3.tar.bz2 /camomile-0.8.3.tar.bz2
/camomile-0.8.5.tar.bz2 /camomile-0.8.5.tar.bz2
/camomile-3f4d657d.tar.gz /camomile-3f4d657d.tar.gz
/camomile-0.8.6.tar.gz

View File

@ -1,11 +0,0 @@
--- camomile-0.8.3/Makefile.in.old 2013-09-14 07:39:54.498539889 +0100
+++ camomile-0.8.3/Makefile.in 2013-09-14 07:40:02.920552224 +0100
@@ -65,7 +65,7 @@
SUBDIR = -I internal -I public -I toolslib -I .
INCLUDES = $(SUBDIR)
BFLAGS = $(BOPTIONS) $(INCLUDES)
-OFLAGS = $(OOPTIONS) $(INCLUDES)
+OFLAGS = $(OOPTIONS) $(INCLUDES) -g
# Generic targets
#################

View File

@ -1,11 +1,6 @@
# Currently building git releases from
# https://github.com/yoriyuki/Camomile
%global commit 3f4d657d50c17213f3338ca75efb30d728704df3
%global shortcommit 3f4d657d
Name: ocaml-camomile Name: ocaml-camomile
Version: 0.8.6 Version: 0.8.6
Release: 0.1.git%{shortcommit}%{?dist} Release: 1%{?dist}
Summary: Unicode library for OCaml Summary: Unicode library for OCaml
# Several files are MIT and UCD licensed, but the overall work is LGPLv2+ # Several files are MIT and UCD licensed, but the overall work is LGPLv2+
@ -13,19 +8,14 @@ Summary: Unicode library for OCaml
# https://www.redhat.com/archives/fedora-legal-list/2008-March/msg00005.html # https://www.redhat.com/archives/fedora-legal-list/2008-March/msg00005.html
License: LGPLv2+ License: LGPLv2+
URL: https://github.com/yoriyuki/Camomile URL: https://github.com/yoriyuki/Camomile
Source0: https://github.com/yoriyuki/Camomile/archive/%{commit}/camomile-%{shortcommit}.tar.gz Source0: https://github.com/yoriyuki/Camomile/archive/rel-%{version}/camomile-%{version}.tar.gz
# Use ocamlopt -g option to enable debuginfo.
Patch1: camomile-0.8.3-enable-debug.patch
BuildRequires: ocaml >= 3.12.1-12 BuildRequires: ocaml >= 3.12.1-12
BuildRequires: ocaml-findlib-devel BuildRequires: ocaml-findlib-devel
BuildRequires: ocaml-ocamldoc BuildRequires: ocaml-ocamldoc
BuildRequires: ocaml-camlp4-devel BuildRequires: ocaml-camlp4-devel
BuildRequires: ocaml-cppo BuildRequires: ocaml-cppo
BuildRequires: jbuilder
# While we are building from git pre-releases we must run autoconf.
BuildRequires: autoconf
# The base package requires the data files. Note that it is possible # The base package requires the data files. Note that it is possible
# to install the data files on their own to support other packages # to install the data files on their own to support other packages
@ -61,39 +51,34 @@ applications that use %{name}.
%prep %prep
%setup -q -n Camomile-%{commit} %setup -q -n Camomile-rel-%{version}
cd Camomile
%patch1 -p1
autoconf
%build %build
cd Camomile jbuilder build --verbose
# Parallel builds don't work.
unset MAKEFLAGS
./configure --prefix=%{_prefix} --datadir=%{_datadir} --libdir=%{_libdir}
make
make dochtml
make man
%install %install
cd Camomile # We have to do this by hand because jbuilder doesn't work.
export DESTDIR=$RPM_BUILD_ROOT export DESTDIR=$RPM_BUILD_ROOT
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
mkdir -p $RPM_BUILD_ROOT%{_bindir} mkdir -p $RPM_BUILD_ROOT%{_bindir}
make install mkdir -p $RPM_BUILD_ROOT%{_datadir}
ocamlfind install camomile _build/install/default/lib/camomile/*
cp -r _build/install/default/share/camomile $RPM_BUILD_ROOT%{_datadir}
%ifarch %{ocaml_native_compiler} %ifarch %{ocaml_native_compiler}
cp tools/camomilecharmap.opt $RPM_BUILD_ROOT%{_bindir}/camomilecharmap cp _build/default/Camomile/tools/camomilecharmap.exe $RPM_BUILD_ROOT%{_bindir}/camomilecharmap
cp tools/camomilelocaledef.opt $RPM_BUILD_ROOT%{_bindir}/camomilelocaledef cp _build/default/Camomile/tools/camomilelocaledef.exe $RPM_BUILD_ROOT%{_bindir}/camomilelocaledef
%endif %endif
%check
jbuilder runtest
%files %files
%doc Camomile/README %doc README
%{_libdir}/ocaml/camomile %{_libdir}/ocaml/camomile
%ifarch %{ocaml_native_compiler} %ifarch %{ocaml_native_compiler}
%exclude %{_libdir}/ocaml/camomile/*.a %exclude %{_libdir}/ocaml/camomile/*.a
@ -108,7 +93,7 @@ cp tools/camomilelocaledef.opt $RPM_BUILD_ROOT%{_bindir}/camomilelocaledef
%files devel %files devel
%doc Camomile/README Camomile/dochtml/* %doc README web/dochtml/*
%ifarch %{ocaml_native_compiler} %ifarch %{ocaml_native_compiler}
%{_libdir}/ocaml/camomile/*.a %{_libdir}/ocaml/camomile/*.a
%{_libdir}/ocaml/camomile/*.cmxa %{_libdir}/ocaml/camomile/*.cmxa
@ -118,11 +103,19 @@ cp tools/camomilelocaledef.opt $RPM_BUILD_ROOT%{_bindir}/camomilelocaledef
%files data %files data
%doc Camomile/README %doc README
%{_datadir}/camomile/ %{_datadir}/camomile/
%changelog %changelog
* Tue Oct 17 2017 Richard W.M. Jones <rjones@redhat.com> - 0.8.6-1
- New upstream version 0.8.6.
- Switch back to versioned releases.
- Use new build system.
- Enable parallel builds.
- Drop -g patch since that seems to work by default now.
- Run tests.
* Mon Aug 07 2017 Richard W.M. Jones <rjones@redhat.com> - 0.8.6-0.1 * Mon Aug 07 2017 Richard W.M. Jones <rjones@redhat.com> - 0.8.6-0.1
- Build from git releases. - Build from git releases.
- OCaml 4.05.0 rebuild. - OCaml 4.05.0 rebuild.

View File

@ -1 +1 @@
SHA512 (camomile-3f4d657d.tar.gz) = 32141ce1b1ab4d199092838a8fc57341a0c2fab395f4d6530d9e4e28a8dab6fcc85841149ec0f9e614606c78a305f5a1aa862124e447fd67597389b2370b5907 SHA512 (camomile-0.8.6.tar.gz) = d31d7015640ced3da47055ae3d4d8f868018b63e825e5a208420641aa6515b8753eacaf03f1d26239086d186ee4a293de17e97b634a335bb62eb399708f95353