92adf4cf1d
ocaml-calendar 3.0.0 (in Fedora 39+ and briefly in RHEL 10) requires ocaml-re, which we removed from RHEL 10, so now that package cannot build. We don't need ocaml-calendar 3, version 2.04 will do fine. Revert back to it. Unfortunately to do this I had to introduce an epoch to get this to override previous versions from RHEL 10. I also had to remove debuginfo because that fails for unclear reasons. I also had to do some porting for OCaml 5.
12 lines
364 B
Diff
12 lines
364 B
Diff
--- calendar-2.03.2/Makefile.in.old 2013-09-14 16:15:43.760253519 +0100
|
|
+++ calendar-2.03.2/Makefile.in 2013-09-14 16:16:03.233279962 +0100
|
|
@@ -86,7 +86,7 @@
|
|
|
|
CAMLIBS = $(addprefix -I , $(DIRS))
|
|
|
|
-CAMLFLAGS= $(CAMLIBS)
|
|
+CAMLFLAGS= -g $(CAMLIBS)
|
|
BYTEFLAGS= $(CAMLFLAGS)
|
|
LINK_OPTFLAGS = $(CAMLFLAGS) -noassert
|
|
OPTFLAGS = $(LINK_OPTFLAGS) -for-pack CalendarLib
|