New upstream version 2.03.2.

- Rebuild for OCaml 4.00.1.
- Remove upstream patch.
This commit is contained in:
Richard W.M. Jones 2012-10-29 14:24:22 +00:00
parent 9d926b9aae
commit 9c2f99d887
4 changed files with 10 additions and 65 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
calendar-2.01.1.tar.gz
/calendar-2.03.tar.gz
/calendar-2.03.1.tar.gz
/calendar-2.03.2.tar.gz

View File

@ -1,45 +0,0 @@
--- calendar-2.03.1/configure.in 2011-03-24 16:28:22.000000000 +0000
+++ calendar-2.03.1.ocaml4/configure.in 2012-06-09 23:46:15.564638844 +0100
@@ -55,6 +55,7 @@
3.09*) echo "${ECHO_T}Warning: unsupported version. Compile at your own risks";;
3.0*) echo "${ECHO_T}Unsupported version!"; exit 2;;
3.*) echo "${ECHO_T}Good!";;
+ 4.*) echo "${ECHO_T}Good!";;
*) echo "${ECHO_T}Unsupported version!"; exit 2;;
esac
--- calendar-2.03.1.old/utils/example.ml 2011-03-24 16:28:22.000000000 +0000
+++ calendar-2.03.1/utils/example.ml 2012-06-09 23:51:24.188610783 +0100
@@ -23,15 +23,18 @@
(* $Id: example.ml 242 2011-03-24 16:26:50Z signoles $ *)
(** Add a tag @example *)
-class example = object (self)
- inherit Odoc_html.html as super
- method html_of_example txt =
+module Generator (G : Odoc_html.Html_generator) =
+struct
+class html = object (self)
+ inherit G.html as super
+
+ method private html_of_example txt =
let buf = Buffer.create 97 in
self#html_of_text buf txt;
Format.sprintf "%s<br>\n" (Buffer.contents buf);
- method html_of_examples = function
+ method private html_of_examples = function
| [] -> ""
| [ txt ] -> Format.sprintf "<b>Example:</b> %s" (self#html_of_example txt)
| examples ->
@@ -64,6 +67,8 @@
initializer
tag_functions <- ("example", self#html_of_example) :: tag_functions
end
+end
let () =
- Odoc_args.set_doc_generator (Some ((new example) :> Odoc_args.doc_generator))
+ Odoc_args.extend_html_generator
+ (module Generator : Odoc_gen.Html_functor)

View File

@ -2,14 +2,13 @@
%global debug_package %{nil}
Name: ocaml-calendar
Version: 2.03.1
Release: 5%{?dist}
Version: 2.03.2
Release: 1%{?dist}
Summary: Objective Caml library for managing dates and times
Group: Development/Libraries
License: LGPLv2
URL: http://calendar.forge.ocamlcore.org/
Source0: http://forge.ocamlcore.org/frs/download.php/605/calendar-%{version}.tar.gz
Source0: http://forge.ocamlcore.org/frs/download.php/915/calendar-2.03.2.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
ExcludeArch: sparc64 s390 s390x
@ -17,10 +16,6 @@ BuildRequires: ocaml >= 3.12.1-3
BuildRequires: ocaml-findlib-devel, ocaml-ocamldoc
BuildRequires: gawk
# Patch for OCaml 4 + BR autoconf because we update configure.in.
Patch0: calendar-2.03.1-ocaml-4.patch
BuildRequires: autoconf
# Ignore all generated modules *except* CalendarLib, since everything
# now appears in that namespace.
%global __ocaml_requires_opts -i Calendar_builder -i Calendar_sig -i Date -i Date_sig -i Fcalendar -i Ftime -i Period -i Printer -i Time -i Time_sig -i Time_Zone -i Utils -i Version
@ -33,7 +28,6 @@ Objective Caml library for managing dates and times.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
@ -45,9 +39,6 @@ developing applications that use %{name}.
%prep
%setup -q -n calendar-%{version}
%patch0 -p1
autoconf
%build
./configure --libdir=%{_libdir}
@ -59,19 +50,13 @@ iconv -f iso-8859-1 -t utf-8 < TODO.old > TODO
%install
rm -rf $RPM_BUILD_ROOT
export DESTDIR=$RPM_BUILD_ROOT
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
make install
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc CHANGES README TODO LGPL COPYING
%{_libdir}/ocaml/calendar
%if %opt
@ -81,7 +66,6 @@ rm -rf $RPM_BUILD_ROOT
%files devel
%defattr(-,root,root,-)
%doc CHANGES README TODO LGPL COPYING calendarFAQ-2.6.txt doc/*
%if %opt
%{_libdir}/ocaml/calendar/*.cmx
@ -90,6 +74,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Mon Oct 29 2012 Richard W.M. Jones <rjones@redhat.com> - 2.03.2-1
- New upstream version 2.03.2.
- Rebuild for OCaml 4.00.1.
- Remove upstream patch.
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.03.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

View File

@ -1 +1 @@
8f14a2c7d84e4caf03099b049716d728 calendar-2.03.1.tar.gz
4f50e3c9ad0eec3d06c0457a2ba0f0b4 calendar-2.03.2.tar.gz