diff --git a/.gitignore b/.gitignore
index ee9f857..667054d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,6 +3,12 @@
/.build-*.log
/*.src.rpm
/noarch
-/asm-*
/archive.tar.gz
-/parent.pom
+/asm-6.2.pom
+/asm-analysis-6.2.pom
+/asm-commons-6.2.pom
+/asm-test-6.2.pom
+/asm-tree-6.2.pom
+/asm-util-6.2.pom
+/asm-xml-6.2.pom
+/objectweb-asm-6.2.tar.gz
diff --git a/asm-all.pom b/asm-all.pom
new file mode 100644
index 0000000..81aba6d
--- /dev/null
+++ b/asm-all.pom
@@ -0,0 +1,62 @@
+
+
+ 4.0.0
+
+ org.ow2
+ ow2
+ 1.5
+
+ org.ow2.asm
+ asm-all
+ @VERSION@
+
+
+ org.ow2.asm
+ asm
+ @VERSION@
+
+
+ org.ow2.asm
+ asm-analysis
+ @VERSION@
+
+
+ org.ow2.asm
+ asm-commons
+ @VERSION@
+
+
+ org.ow2.asm
+ asm-tree
+ @VERSION@
+
+
+ org.ow2.asm
+ asm-tree
+ @VERSION@
+
+
+ org.ow2.asm
+ asm-xml
+ @VERSION@
+
+
+
+
+
+ org.apache.maven.plugins
+ maven-shade-plugin
+ 3.1.1
+
+
+ package
+
+ shade
+
+
+
+
+
+
+
diff --git a/objectweb-asm.spec b/objectweb-asm.spec
index 1497f40..12475f6 100644
--- a/objectweb-asm.spec
+++ b/objectweb-asm.spec
@@ -1,16 +1,16 @@
-%global gittag ASM_6_1_1
+%global gittag ASM_6_2
%bcond_without junit5
Name: objectweb-asm
-Version: 6.1.1
-Release: 4%{?dist}
+Version: 6.2
+Release: 1%{?dist}
Summary: Java bytecode manipulation and analysis framework
License: BSD
URL: http://asm.ow2.org/
BuildArch: noarch
-Source0: https://gitlab.ow2.org/asm/asm/repository/%{gittag}/archive.tar.gz
+Source0: https://gitlab.ow2.org/asm/asm/repository/%{gittag}/archive.tar.gz#/%{name}-%{version}.tar.gz
Source1: parent.pom
Source2: http://repo1.maven.org/maven2/org/ow2/asm/asm/%{version}/asm-%{version}.pom
Source3: http://repo1.maven.org/maven2/org/ow2/asm/asm-analysis/%{version}/asm-analysis-%{version}.pom
@@ -21,7 +21,7 @@ Source7: http://repo1.maven.org/maven2/org/ow2/asm/asm-util/%{version}/as
Source8: http://repo1.maven.org/maven2/org/ow2/asm/asm-xml/%{version}/asm-xml-%{version}.pom
# We still want to create an "all" uberjar, so this is a custom pom to generate it
# TODO: Fix other packages to no longer depend on "asm-all" so we can drop this
-Source9: asm-all-%{version}.pom
+Source9: asm-all.pom
BuildRequires: maven-local
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
@@ -54,7 +54,7 @@ Summary: API documentation for %{name}
This package provides %{summary}.
%prep
-%setup -q -n asm-%{gittag}-11b3cabce9b90706cf91a47dd15215c667f8055b
+%setup -q -n asm-%{gittag}-c72a86bd5f48a308537695213d3a23ac35a57d55
find -name *.jar -delete
rm -rf gradle/
@@ -101,7 +101,7 @@ done
# Insert asm-all pom
mkdir -p asm-all
-cp -p %{SOURCE9} asm-all/pom.xml
+sed 's/@VERSION@/%{version}/g' %{SOURCE9} > asm-all/pom.xml
# Remove invalid self-dependency
%pom_remove_dep org.ow2.asm:asm-test asm-test
@@ -140,6 +140,9 @@ popd
%license LICENSE.txt
%changelog
+* Mon Jul 02 2018 Michael Simacek - 6.2-1
+- Update to upstream version 6.2
+
* Sat Jun 30 2018 Mikolaj Izdebski - 6.1.1-4
- Relax versioned self-build-requirement a bit
diff --git a/parent.pom b/parent.pom
new file mode 100644
index 0000000..6aad2c2
--- /dev/null
+++ b/parent.pom
@@ -0,0 +1,22 @@
+
+
+ 4.0.0
+
+ org.ow2.asm
+ asm-aggregator
+ 1
+
+ pom
+
+
+ asm
+ asm-analysis
+ asm-commons
+ asm-test
+ asm-tree
+ asm-util
+ asm-xml
+ asm-all
+
+
diff --git a/sources b/sources
index bc5fe57..8302099 100644
--- a/sources
+++ b/sources
@@ -1,10 +1,8 @@
-SHA512 (archive.tar.gz) = 9719f97dc953d20473bc161557e2e254e9455654229858af13af5fe6582a39a96c77dd52ee342bc79157e8e8e87ef48188185a0ebe28f4bb6ecb7f0cb3923f7b
-SHA512 (asm-6.1.1.pom) = 4485086ec55d29fdcd96f0c1d6cf517ef3237a87552c68d6bdf59f5ae50cd93ba9706eeb5f43bafcc1289e32e152cd845aee44a2316fd060d0501cf3141840b7
-SHA512 (asm-all-6.1.1.pom) = 90df1a63b5e2a2b2b40f17cbc0303072e96d168c6cccd1bcb986f9b900b370fa191d857c694e20449d42d4b9d575f5c5153fceb09405f472257bc6733388e917
-SHA512 (asm-analysis-6.1.1.pom) = 213bfae989c64f807bb00856a262c7ad507eb9188653e688319f3c862f1362aa5ffffd18cb1ed712c7cb3bd3095b924fbfba06ed54c2e67920d6251b307c86d0
-SHA512 (asm-commons-6.1.1.pom) = 742b17e77b93c04bae33987fd4ab0a3bf889277ae46331b0b8fc3e67c360e0a11406e02e8ca6d3350542557a7c0f6b78057f15866fd3250b7dffe81999a29ae2
-SHA512 (asm-test-6.1.1.pom) = 2ff4b770eb6e14eddd13b7fa41c3b8d684c5f22f4d08c215e42a7f3a51c846b66e90603040376a56c6b9dbd09f7bf49beca826062145d0613319087b860614c7
-SHA512 (asm-tree-6.1.1.pom) = c02053d0279b7f43f7838a9540806bd597391ee5af7babb2a77d7764e0e255dad3eb6da83203480c1cabc06a2014fb196e97f2f34e90442f9516c19874fd1153
-SHA512 (asm-util-6.1.1.pom) = 2ceac588f3aa34e2531dcc3dac8614ce0c9131e7ba226f2f9b5766f80c4f7ad5dfd9806c9379789d7ac38d4e91543c4936f61f1dacd3f0815cc8abed9d6edf8e
-SHA512 (asm-xml-6.1.1.pom) = a0796711334d3f29ba8a3743e87c13f3c0c5e2491f6718ee08cfb45bd7f873699e79daf6845437f8c58abf8b6d273fde56328ae5e53797df3c22309629d36c41
-SHA512 (parent.pom) = 0e0ed1e893e604ebfa863b046b1189a424ebb68032026b7402894e66f36376c8a748f2e4c08e96be6fee21eab3dc79203b805b61b422d3ab9158a4a1a78d2bb6
+SHA512 (objectweb-asm-6.2.tar.gz) = 4eabeebf98ca642cc3901b6eb178840cc677150d79c7c981e1759d6e9a798df1837f15eb3dba6d0fe3c0dd156f21f6348bd908b49da78aa5c5e03d374d797943
+SHA512 (asm-6.2.pom) = a6cebb211772ac4e13df2c519593da5ce0742bb88d928fc0c2cf9094141f88c4e88dbff29ca6f7b7b3749d0ada02ddc07c27c25493c6562be8dbcecf8a1fcad5
+SHA512 (asm-analysis-6.2.pom) = 853742bb74ffae42314c162f624c8bb2a6149a3fc7763a9ac2ec2528f2381c5b84d7bfd41c61f89e59bd1650a06faf64d4124f6e0fa2cfd23554257949d6006b
+SHA512 (asm-commons-6.2.pom) = c8033bde09af20576aee78237e555620f22de6fccfa9ab8840d7e09657f6d92cf2b467080c18207cf978c4a21af86eba120bd9a19430b264822b55fbfefa5e4f
+SHA512 (asm-test-6.2.pom) = 3ef16fee0924ffd6da3bc3e715574cc6324250707980586beadd1bbee50bf9e709f251593e21c6637d56f5c90db9b7c599b5617f22e4da5bc87932fb610914da
+SHA512 (asm-tree-6.2.pom) = cb8eec7d54024595cd2c13a7fb2e8fec9d04f83ccd0c50b71745fd51a6fb6f4e5e56521b86932f9da3e775dd2a0d3a1fe90c8bf2da3c2ee39453b1019e0efd43
+SHA512 (asm-util-6.2.pom) = 0fcf4c8c0dc98b71cd53f1e2253a5f8293bfed4a673b2d231993365645326a27f8ded6a2879e3f9a341ffeb2cdbb5b8d659c789ee1bd3ed109676f505b61bc18
+SHA512 (asm-xml-6.2.pom) = 078aa27a82b3513080e238830e6ac7cd09e5dd374587544ec55c56a9ddf53d050b660b2f61ed51ff7421fd6134ee0fdf686c4e6c55cbb9fc8f48123eb750c96c