initial import (#1425898)

Signed-off-by: Andy Grover <agrover@redhat.com>
This commit is contained in:
Andy Grover 2017-02-23 14:32:59 -08:00
parent 276779a181
commit 6a03962c7d
4 changed files with 75 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/nvmetcli-0.3.tar.gz

10
fix-setup.patch Normal file
View File

@ -0,0 +1,10 @@
iff --git a/setup.py b/setup.py
index 078020f..f62ce5b 100755
--- a/setup.py
+++ b/setup.py
@@ -27,4 +27,5 @@ setup(
maintainer_email = 'hch@lst.de',
test_suite='nose2.collector.collector',
packages = ['nvmet'],
+ scripts = ['nvmetcli'],
)

63
nvmetcli.spec Normal file
View File

@ -0,0 +1,63 @@
Name: nvmetcli
License: ASL 2.0
Group: Applications/System
Summary: An adminstration shell for NVMe storage targets
Version: 0.3
Release: 1%{?dist}
URL: ftp://ftp.infradead.org/pub/nvmetcli/
Source: ftp://ftp.infradead.org/pub/nvmetcli/%{name}-%{version}.tar.gz
Patch0: fix-setup.patch
BuildArch: noarch
BuildRequires: python3-devel python3-setuptools systemd-units asciidoc xmlto
Requires: python3-configshell python3-kmod
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
%description
This package contains the command line interface to the NVMe over Fabrics
nvmet in the Linux kernel. It allows configuring the nvmet interactively
as well as saving / restoring the configuration to / from a json file.
%prep
%setup -q
%patch0 -p1
%build
%{__python3} setup.py build
cd Documentation
make
gzip --stdout nvmetcli.8 > nvmetcli.8.gz
%install
%{__python3} setup.py install --skip-build --root %{buildroot}
mkdir -p %{buildroot}%{_unitdir}
mkdir -p %{buildroot}%{_sysconfdir}/nvmet
install -m 644 nvmet.service %{buildroot}%{_unitdir}/nvmet.service
mkdir -p %{buildroot}%{_mandir}/man8/
install -m 644 Documentation/nvmetcli.8.gz %{buildroot}%{_mandir}/man8/
%post
%systemd_post nvmet.service
%preun
%systemd_preun nvmet.service
%postun
%systemd_postun_with_restart nvmet.service
%files
%{python3_sitelib}/*
%dir %{_sysconfdir}/nvmet
%{_bindir}/nvmetcli
%{_unitdir}/nvmet.service
%doc README
%license COPYING
%{_mandir}/man8/nvmetcli.8.gz
%changelog
* Tue Feb 21 2017 Andy Grover <agrover@redhat.com> - 0.3-1
- Update for new upstream release
* Wed Oct 12 2016 Andy Grover <agrover@redhat.com> - 0.2-1
- Initial packaging

View File

@ -0,0 +1 @@
SHA512 (nvmetcli-0.3.tar.gz) = 73361ed1c854ad7faa4885e2330d44cae18092c58bf553a86486b0c2b7e1c21d82f79d097c54ba2ece8452012c23d6dbed68a084e911fd133b072d0396883603