import nvme-cli-1.16-3.el9
This commit is contained in:
commit
dd4e63cf53
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/v1.16.tar.gz
|
1
.nvme-cli.metadata
Normal file
1
.nvme-cli.metadata
Normal file
@ -0,0 +1 @@
|
||||
2706485a7adb8134943102ff3f1a087e003f2b1f SOURCES/v1.16.tar.gz
|
@ -0,0 +1,32 @@
|
||||
From f74ac1b841b0aae73969debaed0444f0ecb03dba Mon Sep 17 00:00:00 2001
|
||||
From: Martin George <marting@netapp.com>
|
||||
Date: Mon, 15 Nov 2021 16:00:47 +0530
|
||||
Subject: [PATCH 1/3] fabrics: fix 'nvme connect' segfault if transport type is
|
||||
omitted
|
||||
|
||||
Check if the transport type is available before dereferencing
|
||||
it in discovery_trsvcid().
|
||||
|
||||
Fixes: 362c90f ("fabrics: add default port number for NVMe/TCP I/O
|
||||
controllers")
|
||||
Signed-off-by: Martin George <marting@netapp.com>
|
||||
---
|
||||
fabrics.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/fabrics.c b/fabrics.c
|
||||
index d691191..adca89b 100644
|
||||
--- a/fabrics.c
|
||||
+++ b/fabrics.c
|
||||
@@ -1070,6 +1070,8 @@ static void set_discovery_kato(struct fabrics_config *cfg)
|
||||
|
||||
static void discovery_trsvcid(struct fabrics_config *fabrics_cfg, bool discover)
|
||||
{
|
||||
+ if (!fabrics_cfg->transport)
|
||||
+ return;
|
||||
if (!strcmp(fabrics_cfg->transport, "tcp")) {
|
||||
if (discover) {
|
||||
/* Default port for NVMe/TCP discovery controllers */
|
||||
--
|
||||
2.27.0
|
||||
|
29
SOURCES/0002-fabrics-fix-a-buffer-overrun.patch
Normal file
29
SOURCES/0002-fabrics-fix-a-buffer-overrun.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From ff8f9b6f59b574fda24a071fb0af4381c0cc6d9f Mon Sep 17 00:00:00 2001
|
||||
From: Maurizio Lombardi <mlombard@redhat.com>
|
||||
Date: Thu, 9 Dec 2021 12:21:51 +0100
|
||||
Subject: [PATCH 2/3] fabrics: fix a buffer overrun
|
||||
|
||||
the uuid buffer size must be at least 37 bytes to avoid
|
||||
corrupting the memory
|
||||
|
||||
Signed-off-by: Maurizio Lombardi <mlombard@redhat.com>
|
||||
---
|
||||
fabrics.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/fabrics.c b/fabrics.c
|
||||
index adca89b..0766729 100644
|
||||
--- a/fabrics.c
|
||||
+++ b/fabrics.c
|
||||
@@ -883,7 +883,7 @@ static char *hostnqn_generate_systemd(void)
|
||||
|
||||
static char *hostnqn_read_dmi(void)
|
||||
{
|
||||
- char uuid[16];
|
||||
+ char uuid[37];
|
||||
char *ret = NULL;
|
||||
|
||||
if (uuid_from_dmi(uuid) < 0)
|
||||
--
|
||||
2.27.0
|
||||
|
36
SOURCES/0003-bash-Fix-nvme-completion.patch
Normal file
36
SOURCES/0003-bash-Fix-nvme-completion.patch
Normal file
@ -0,0 +1,36 @@
|
||||
From 821935cccfcad6b18da78d42f9ddf49f4cbe0b8e Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Wagner <dwagner@suse.de>
|
||||
Date: Thu, 9 Dec 2021 15:40:26 +0100
|
||||
Subject: [PATCH 3/3] bash: Fix nvme completion
|
||||
|
||||
Signed-off-by: Daniel Wagner <dwagner@suse.de>
|
||||
---
|
||||
completions/bash-nvme-completion.sh | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/completions/bash-nvme-completion.sh b/completions/bash-nvme-completion.sh
|
||||
index 41938d7..902da01 100644
|
||||
--- a/completions/bash-nvme-completion.sh
|
||||
+++ b/completions/bash-nvme-completion.sh
|
||||
@@ -101,8 +101,7 @@ _cmds="list list-subsys id-ctrl id-ns \
|
||||
connect disconnect disconnect-all gen-hostnqn \
|
||||
show-hostnqn dir-receive dir-send virt-mgmt \
|
||||
rpmb boot-part-log fid-support-effects-log \
|
||||
- supported-log-pages lockdown"
|
||||
- supported-log-pages list-endgrp"
|
||||
+ supported-log-pages lockdown list-endgrp"
|
||||
|
||||
# Add plugins:
|
||||
for plugin in "${!_plugin_subcmds[@]}"; do
|
||||
@@ -1368,7 +1367,7 @@ plugin_ymtc_opts () {
|
||||
opts+=" --namespace-id= -n --raw-binary -b"
|
||||
;;
|
||||
"help")
|
||||
- opts+=NO_OPTS
|
||||
+ opts+=$NO_OPTS
|
||||
;;
|
||||
esac
|
||||
|
||||
--
|
||||
2.27.0
|
||||
|
39
SOURCES/0004-nvme-do-not-leak-an-open-file-handle.patch
Normal file
39
SOURCES/0004-nvme-do-not-leak-an-open-file-handle.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 45223fd3c5a13da9209c4f44d7593cb42cab94fb Mon Sep 17 00:00:00 2001
|
||||
From: Maurizio Lombardi <mlombard@redhat.com>
|
||||
Date: Tue, 14 Dec 2021 10:09:42 +0100
|
||||
Subject: [PATCH 1/4] nvme: do not leak an open file handle
|
||||
|
||||
We performed a "sec_fd=open(cfg.file)" earlier, so we should not
|
||||
overwrite the handle.
|
||||
|
||||
Signed-off-by: Maurizio Lombardi <mlombard@redhat.com>
|
||||
---
|
||||
nvme.c | 9 +--------
|
||||
1 file changed, 1 insertion(+), 8 deletions(-)
|
||||
|
||||
diff --git a/nvme.c b/nvme.c
|
||||
index 862f9b6..5beeac7 100644
|
||||
--- a/nvme.c
|
||||
+++ b/nvme.c
|
||||
@@ -4379,17 +4379,10 @@ static int sec_send(int argc, char **argv, struct command *cmd, struct plugin *p
|
||||
fprintf(stderr, "WARNING: --tl not dword aligned; unaligned bytes may be truncated\n");
|
||||
|
||||
if (strlen(cfg.file) == 0) {
|
||||
+ close(sec_fd);
|
||||
sec_fd = STDIN_FILENO;
|
||||
sec_size = cfg.tl;
|
||||
} else {
|
||||
- sec_fd = open(cfg.file, O_RDONLY);
|
||||
- if (sec_fd < 0) {
|
||||
- fprintf(stderr, "Failed to open %s: %s\n",
|
||||
- cfg.file, strerror(errno));
|
||||
- err = -EINVAL;
|
||||
- goto close_fd;
|
||||
- }
|
||||
-
|
||||
err = fstat(sec_fd, &sb);
|
||||
if (err < 0) {
|
||||
perror("fstat");
|
||||
--
|
||||
2.27.0
|
||||
|
@ -0,0 +1,35 @@
|
||||
From b580886dbc322b2a71d6c0c1b71f9fca7b750b02 Mon Sep 17 00:00:00 2001
|
||||
From: Maurizio Lombardi <mlombard@redhat.com>
|
||||
Date: Tue, 14 Dec 2021 09:58:09 +0100
|
||||
Subject: [PATCH 2/4] nvme-topology: fix memory leaks in
|
||||
nvme_logical_block_size_from_ns_char()
|
||||
|
||||
Free the allocated strings before returning from the function
|
||||
|
||||
Signed-off-by: Maurizio Lombardi <mlombard@redhat.com>
|
||||
---
|
||||
nvme-topology.c | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/nvme-topology.c b/nvme-topology.c
|
||||
index 0a22f6b..6be2b09 100644
|
||||
--- a/nvme-topology.c
|
||||
+++ b/nvme-topology.c
|
||||
@@ -686,10 +686,13 @@ int nvme_logical_block_size_from_ns_char(const char *dev)
|
||||
return -EINVAL;
|
||||
|
||||
s = nvme_get_ctrl_attr(path, "logical_block_size");
|
||||
+ free(path);
|
||||
if (!s)
|
||||
return -EINVAL;
|
||||
|
||||
- return atoi(s);
|
||||
+ ret = atoi(s);
|
||||
+ free(s);
|
||||
+ return ret;
|
||||
}
|
||||
|
||||
void *mmap_registers(const char *dev)
|
||||
--
|
||||
2.27.0
|
||||
|
@ -0,0 +1,37 @@
|
||||
From 58c23ceb12d16756b2222a55d1d9dc5f34bb4fa4 Mon Sep 17 00:00:00 2001
|
||||
From: James Smart <jsmart2021@gmail.com>
|
||||
Date: Fri, 17 Dec 2021 11:32:32 -0800
|
||||
Subject: [PATCH 3/4] nvme-cli: nvmf-connect@.service: Remove matching from
|
||||
default syntax
|
||||
|
||||
commit 53aab69a0add added the "--matching" argument to the systemd
|
||||
connect script that issues connect-all to a discovery controller. When
|
||||
this argument is used, only discovery log entries whose target port
|
||||
traddr's match the traddr of the discovery controller will be connected
|
||||
to. This eliminates the ability to do referrals by the discovery
|
||||
controller.
|
||||
|
||||
Revert the commit so that the "--matching" argument is not default
|
||||
behavior.
|
||||
|
||||
Signed-off-by: James Smart <jsmart2021@gmail.com>
|
||||
CC: Martin Wilck <mwilck@suse.com>
|
||||
Signed-off-by: Daniel Wagner <dwagner@suse.de>
|
||||
Link: https://lore.kernel.org/r/20211217193232.29034-1-jsmart2021@gmail.com
|
||||
---
|
||||
nvmf-autoconnect/systemd/nvmf-connect@.service | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/nvmf-autoconnect/systemd/nvmf-connect@.service b/nvmf-autoconnect/systemd/nvmf-connect@.service
|
||||
index 5fbf081..c60f146 100644
|
||||
--- a/nvmf-autoconnect/systemd/nvmf-connect@.service
|
||||
+++ b/nvmf-autoconnect/systemd/nvmf-connect@.service
|
||||
@@ -11,4 +11,4 @@ Requires=nvmf-connect.target
|
||||
[Service]
|
||||
Type=simple
|
||||
Environment="CONNECT_ARGS=%i"
|
||||
-ExecStart=/bin/sh -c "nvme connect-all --matching --quiet `/bin/echo -e '${CONNECT_ARGS}'`"
|
||||
+ExecStart=/bin/sh -c "nvme connect-all --quiet `/bin/echo -e '${CONNECT_ARGS}'`"
|
||||
--
|
||||
2.27.0
|
||||
|
@ -0,0 +1,86 @@
|
||||
From 1264c6323937c4a0342174fdd9be5a66ab1eaf24 Mon Sep 17 00:00:00 2001
|
||||
From: James Smart <jsmart2021@gmail.com>
|
||||
Date: Fri, 17 Dec 2021 14:20:22 -0800
|
||||
Subject: [PATCH 4/4] nvme-cli: Make connect-all matching be case insensitive
|
||||
|
||||
The comparison routine that checks discovery controller traddr with a
|
||||
discovery log traddr uses a simple strncmp. For FC, which kicks off
|
||||
connect-all requests vay systemd, the nvme-fc transport will build
|
||||
traddr strings with lower case hexadecimal. Some FC discovery
|
||||
controllers return traddr strings with upper case hexadecimal. There
|
||||
was is no rqmt in the NVME-FC spec that it be upper or lower case.
|
||||
Given the case difference, the connect-all fails the match logic and
|
||||
doesn't connect to storage.
|
||||
|
||||
Revise the traddr comparison routine to duplicate the strings and
|
||||
convert them to lower case for comparison.
|
||||
|
||||
Signed-off-by: James Smart <jsmart2021@gmail.com>
|
||||
Signed-off-by: Daniel Wagner <dwagner@suse.de>
|
||||
Link: https://lore.kernel.org/r/20211217222022.30516-1-jsmart2021@gmail.com
|
||||
---
|
||||
fabrics.c | 26 +++++++++++++++++++++++++-
|
||||
1 file changed, 25 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/fabrics.c b/fabrics.c
|
||||
index 0766729..a1e2593 100644
|
||||
--- a/fabrics.c
|
||||
+++ b/fabrics.c
|
||||
@@ -34,6 +34,7 @@
|
||||
#include <stddef.h>
|
||||
#include <syslog.h>
|
||||
#include <time.h>
|
||||
+#include <ctype.h>
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <arpa/inet.h>
|
||||
@@ -681,6 +682,12 @@ static int space_strip_len(int max, const char *str)
|
||||
return i + 1;
|
||||
}
|
||||
|
||||
+static void strtolower(char *str)
|
||||
+{
|
||||
+ for ( ; *str; str++)
|
||||
+ *str = tolower(*str);
|
||||
+}
|
||||
+
|
||||
static void print_discovery_log(struct nvmf_disc_rsp_page_hdr *log, int numrec,
|
||||
int instance)
|
||||
{
|
||||
@@ -1385,7 +1392,9 @@ static bool cargs_match_found(struct nvmf_disc_rsp_page_entry *entry)
|
||||
|
||||
static bool should_connect(struct nvmf_disc_rsp_page_entry *entry)
|
||||
{
|
||||
+ char *dctrl_traddr, *log_traddr;
|
||||
int len;
|
||||
+ bool connect = true;
|
||||
|
||||
if (cargs_match_found(entry))
|
||||
return false;
|
||||
@@ -1398,7 +1407,22 @@ static bool should_connect(struct nvmf_disc_rsp_page_entry *entry)
|
||||
return true;
|
||||
|
||||
len = space_strip_len(NVMF_TRADDR_SIZE, entry->traddr);
|
||||
- return !strncmp(fabrics_cfg.traddr, entry->traddr, len);
|
||||
+
|
||||
+ dctrl_traddr = strdup(fabrics_cfg.traddr);
|
||||
+ log_traddr = strndup(entry->traddr, len);
|
||||
+ if (!dctrl_traddr || !log_traddr)
|
||||
+ goto free_exit;
|
||||
+
|
||||
+ strtolower(dctrl_traddr);
|
||||
+ strtolower(log_traddr);
|
||||
+
|
||||
+ connect = (strlen(dctrl_traddr) == len) &&
|
||||
+ !strcmp(dctrl_traddr, log_traddr);
|
||||
+
|
||||
+free_exit:
|
||||
+ free(log_traddr);
|
||||
+ free(dctrl_traddr);
|
||||
+ return connect;
|
||||
}
|
||||
|
||||
static int connect_ctrls(struct nvmf_disc_rsp_page_hdr *log, int numrec)
|
||||
--
|
||||
2.27.0
|
||||
|
13
SOURCES/nvme-cli-makefile-dont-install-host-params-patch
Normal file
13
SOURCES/nvme-cli-makefile-dont-install-host-params-patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- nvme-cli-1.9/Makefile.orig 2020-05-27 14:04:56.259961135 -0400
|
||||
+++ nvme-cli-1.9/Makefile 2020-05-27 14:05:22.796185371 -0400
|
||||
@@ -125,8 +125,8 @@
|
||||
$(INSTALL) -m 644 -T ./etc/discovery.conf.in $(DESTDIR)$(SYSCONFDIR)/nvme/discovery.conf; \
|
||||
fi
|
||||
|
||||
-install-spec: install-bin install-man install-bash-completion install-zsh-completion install-etc install-systemd install-udev install-dracut
|
||||
-install: install-spec install-hostparams
|
||||
+install-spec: install-bin install-man install-bash-completion install-zsh-completion install-systemd install-udev install-dracut
|
||||
+install: install-spec
|
||||
|
||||
nvme.spec: nvme.spec.in NVME-VERSION-FILE
|
||||
sed -e 's/@@VERSION@@/$(NVME_VERSION)/g' < $< > $@+
|
210
SPECS/nvme-cli.spec
Normal file
210
SPECS/nvme-cli.spec
Normal file
@ -0,0 +1,210 @@
|
||||
#%%global commit0 bdbb4da0979fbdc079cf98410cdb31cf799e83b3
|
||||
#%%global shortcommit0 %%(c=%%{commit0}; echo ${c:0:7})
|
||||
|
||||
Name: nvme-cli
|
||||
Version: 1.16
|
||||
Release: 3%{?dist}
|
||||
Summary: NVMe management command line interface
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://github.com/linux-nvme/nvme-cli
|
||||
Source0: https://github.com/linux-nvme/%{name}/archive/v%{version}.tar.gz
|
||||
|
||||
Patch0: nvme-cli-makefile-dont-install-host-params-patch
|
||||
Patch1: 0001-fabrics-fix-nvme-connect-segfault-if-transport-type-.patch
|
||||
Patch2: 0002-fabrics-fix-a-buffer-overrun.patch
|
||||
Patch3: 0003-bash-Fix-nvme-completion.patch
|
||||
Patch4: 0004-nvme-do-not-leak-an-open-file-handle.patch
|
||||
Patch5: 0005-nvme-topology-fix-memory-leaks-in-nvme_logical_block.patch
|
||||
Patch6: 0006-nvme-cli-nvmf-connect-.service-Remove-matching-from-.patch
|
||||
Patch7: 0007-nvme-cli-Make-connect-all-matching-be-case-insensiti.patch
|
||||
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: gcc
|
||||
BuildRequires: systemd-devel
|
||||
Requires: util-linux
|
||||
|
||||
%description
|
||||
nvme-cli provides NVM-Express user space tooling for Linux.
|
||||
|
||||
%prep
|
||||
#%%setup -qn %%{name}-%%{commit0}
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
|
||||
|
||||
%build
|
||||
|
||||
# CFLAGS on the command line breaks the build. It works okay as an
|
||||
# environment variable, though. See:
|
||||
# https://github.com/linux-nvme/nvme-cli/pull/480
|
||||
CFLAGS="%{optflags}" make PREFIX=/usr LDFLAGS="%{__global_ldflags}" %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
%make_install PREFIX=/usr UDEVDIR="%{_udevrulesdir}/.." SYSTEMDDIR="%{_unitdir}/.."
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/nvme
|
||||
|
||||
# hostid and hostnqn are supposed to be unique per machine. We obviously
|
||||
# can't package them.
|
||||
#rm -f %{buildroot}%{_sysconfdir}/nvme/hostid
|
||||
#rm -f %{buildroot}%{_sysconfdir}/nvme/hostnqn
|
||||
|
||||
# Do not install the dracut rule yet. See rhbz 1742764
|
||||
rm -f %{buildroot}/usr/lib/dracut/dracut.conf.d/70-nvmf-autoconnect.conf
|
||||
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%{_sbindir}/nvme
|
||||
%{_mandir}/man1/nvme*.gz
|
||||
%{_datadir}/bash-completion/completions/nvme
|
||||
%{_datadir}/zsh/site-functions/_nvme
|
||||
%dir %{_sysconfdir}/nvme
|
||||
%{_unitdir}/nvmefc-boot-connections.service
|
||||
%{_unitdir}/nvmf-autoconnect.service
|
||||
%{_unitdir}/nvmf-connect.target
|
||||
%{_unitdir}/nvmf-connect@.service
|
||||
%{_udevrulesdir}/70-nvmf-autoconnect.rules
|
||||
%{_udevrulesdir}/71-nvmf-iopolicy-netapp.rules
|
||||
# Do not install the dracut rule yet. See rhbz 1742764
|
||||
# /usr/lib/dracut/dracut.conf.d/70-nvmf-autoconnect.conf
|
||||
|
||||
%post
|
||||
if [ $1 -eq 1 ] || [ $1 -eq 2 ]; then
|
||||
if [ ! -s %{_sysconfdir}/nvme/hostnqn ]; then
|
||||
echo $(nvme gen-hostnqn) > %{_sysconfdir}/nvme/hostnqn
|
||||
fi
|
||||
if [ ! -s %{_sysconfdir}/nvme/hostid ]; then
|
||||
uuidgen > %{_sysconfdir}/nvme/hostid
|
||||
fi
|
||||
|
||||
# apply udev and systemd changes that we did
|
||||
systemctl enable nvmefc-boot-connections
|
||||
systemctl daemon-reload
|
||||
udevadm control --reload-rules && udevadm trigger
|
||||
exit 0
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Mon Feb 07 2022 Maurizio Lombardi <mlombard@redhat.com> - 1.16-3
|
||||
- Add a few bugfixes
|
||||
|
||||
* Mon Dec 13 2021 Maurizio Lombardi <mlombard@redhat.com> - 1.16-2
|
||||
- Update to the latest version
|
||||
|
||||
* Thu Dec 09 2021 Maurizio Lombardi <mlombard@redhat.com> - 1.14-4
|
||||
- Fix handling of the ctrl_loss_tmo parameter
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com>
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Mon Jun 14 2021 Maurizio Lombardi <mlombard@redhat.com> - 1.14-2
|
||||
- Fix for bz1962422 (nvme flush failed from from v5.13-rc1)
|
||||
|
||||
* Mon May 03 2021 Maurizio Lombardi <mlombard@redhat.com> - 1.14-1
|
||||
- Update to the latest upstream version
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com>
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Fri Mar 19 2021 Maurizio Lombardi <mlombard@redhat.com> - 1.12-1
|
||||
- Update to 1.13 and add postin scriptlet
|
||||
|
||||
* Sat Apr 25 2020 luto@kernel.org - 1.11.1-1
|
||||
- Update to 1.11
|
||||
|
||||
* Thu Mar 19 2020 luto@kernel.org - 1.10.1-1
|
||||
- Update to 1.10.1
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Oct 02 2019 luto@kernel.org - 1.9-1
|
||||
- Update to 1.9
|
||||
- Certain fabric functionality may not work yet due to missing dracut
|
||||
support and missing hostid and hostnqn configuration.
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Mon Apr 15 2019 luto@kernel.org - 1.8.1-1
|
||||
- Update to 1.8.1-1.
|
||||
- Remove a build hack.
|
||||
|
||||
* Sun Feb 24 2019 luto@kernel.org - 1.7-2
|
||||
- Create /etc/nvme
|
||||
|
||||
* Sun Feb 24 2019 luto@kernel.org - 1.7-1
|
||||
- Bump to 1.7
|
||||
- Clean up some trivial rpmlint complaints
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Jul 24 2018 luto@kernel.org - 1.6-1
|
||||
- Update to 1.6
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Nov 22 2017 luto@kernel.org - 1.4-1
|
||||
- Update to 1.4
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon May 22 2017 luto@kernel.org - 1.3-1
|
||||
- Update to 1.3
|
||||
|
||||
* Wed Apr 19 2017 luto@kernel.org - 1.2-2
|
||||
- Update to 1.2
|
||||
- 1.2-1 never existed
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Feb 01 2017 luto@kernel.org - 1.1-1
|
||||
- Update to 1.1
|
||||
|
||||
* Sun Nov 20 2016 luto@kernel.org - 1.0-1
|
||||
- Update to 1.0
|
||||
|
||||
* Mon Oct 31 2016 luto@kernel.org - 0.9-1
|
||||
- Update to 0.9
|
||||
|
||||
* Thu Jun 30 2016 luto@kernel.org - 0.8-1
|
||||
- Update to 0.8
|
||||
|
||||
* Tue May 31 2016 luto@kernel.org - 0.7-1
|
||||
- Update to 0.7
|
||||
|
||||
* Fri Mar 18 2016 luto@kernel.org - 0.5-1
|
||||
- Update to 0.5
|
||||
|
||||
* Sun Mar 06 2016 luto@kernel.org - 0.4-1
|
||||
- Update to 0.4
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.2-3.20160112gitbdbb4da
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jan 20 2016 luto@kernel.org - 0.2-2.20160112gitbdbb4da
|
||||
- Update to new upstream commit, fixing #49. "nvme list" now works.
|
||||
|
||||
* Wed Jan 13 2016 luto@kernel.org - 0.2-1.20160112gitde3e0f1
|
||||
- Initial import.
|
Loading…
Reference in New Issue
Block a user