numatop/0001-configure.ac-Fix-build...

43 lines
1.4 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From 2715969f92f5e8d6c60488a65ccef73fef57fa6e Mon Sep 17 00:00:00 2001
From: Zhengjun Xing <zhengjun.xing@linux.intel.com>
Date: Mon, 31 Oct 2022 14:22:32 +0800
Subject: [PATCH 01/15] configure.ac : Fix build error when libnuma is missed
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
When libnuma is installed after running autogen.sh (which didnt fails) it
silently fails linking with missing symbols. To avoid this issue just make
autoconf error out if libnuma is missing.
Signed-off-by: Zhengjun Xing <zhengjun.xing@linux.intel.com>
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index fd945f4..36edcc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.69])
-AC_INIT([numatop], [v2.1], [yao.jin@intel.com])
+AC_INIT([numatop], [v2.3], [zhengjun.xing@intel.com])
AM_INIT_AUTOMAKE([-Wno-portability no-dist-gzip dist-xz foreign subdir-objects])
AC_CONFIG_SRCDIR([common/numatop.c])
AC_CONFIG_HEADERS([config.h])
@@ -18,7 +18,7 @@ AC_PROG_CC
AC_PROG_INSTALL
# Checks for libraries.
-AC_CHECK_LIB([numa], [numa_free])
+AC_CHECK_LIB([numa], [numa_free], [], [ AC_MSG_ERROR([numactl-devel or libnuma-dev(el) is required but was not found]) exit -1])
AC_CHECK_LIB([pthread], [pthread_create])
PKG_CHECK_MODULES([CHECK], [check])
--
2.31.1