Don't order service after syslog.target (#1055209).
- Build with $RPM_OPT_FLAGS and $RPM_LD_FLAGS. - Fix build with -Werror=format-security.
This commit is contained in:
parent
114d81481f
commit
22497671b8
25
0001-Fix-build-with-Werror-format-security.patch
Normal file
25
0001-Fix-build-with-Werror-format-security.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 6ab732334bc765d4b5883ddde0e9891b4813d136 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
|
||||||
|
Date: Mon, 20 Jan 2014 22:25:58 +0200
|
||||||
|
Subject: [PATCH 1/2] Fix build with -Werror=format-security
|
||||||
|
|
||||||
|
---
|
||||||
|
numad.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/numad.c b/numad.c
|
||||||
|
index 2d8ae95..3e2816b 100644
|
||||||
|
--- a/numad.c
|
||||||
|
+++ b/numad.c
|
||||||
|
@@ -141,7 +141,7 @@ void numad_log(int level, const char *fmt, ...) {
|
||||||
|
}
|
||||||
|
char buf[BUF_SIZE];
|
||||||
|
time_t ts = time(NULL);
|
||||||
|
- sprintf(buf, ctime(&ts));
|
||||||
|
+ sprintf(buf, "%s", ctime(&ts));
|
||||||
|
char *p = &buf[strlen(buf) - 1];
|
||||||
|
*p++ = ':';
|
||||||
|
*p++ = ' ';
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
28
0002-Don-t-order-service-after-syslog.target.patch
Normal file
28
0002-Don-t-order-service-after-syslog.target.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 49cb22039f299350bb0d19b372e1662a38d29018 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
|
||||||
|
Date: Sun, 19 Jan 2014 17:29:50 +0200
|
||||||
|
Subject: [PATCH 2/2] Don't order service after syslog.target
|
||||||
|
|
||||||
|
http://www.freedesktop.org/wiki/Software/systemd/syslog/
|
||||||
|
https://fedorahosted.org/fpc/ticket/177#comment:2
|
||||||
|
http://lists.opensuse.org/archive/opensuse-packaging/2013-05/msg00102.html
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1055209
|
||||||
|
---
|
||||||
|
numad.service | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/numad.service b/numad.service
|
||||||
|
index 478559a..73a4f34 100644
|
||||||
|
--- a/numad.service
|
||||||
|
+++ b/numad.service
|
||||||
|
@@ -1,6 +1,5 @@
|
||||||
|
[Unit]
|
||||||
|
Description=numad - The NUMA daemon that manages application locality.
|
||||||
|
-After=syslog.target
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
Type=forking
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
13
numad.spec
13
numad.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: numad
|
Name: numad
|
||||||
Version: 0.5
|
Version: 0.5
|
||||||
Release: 12.20130814git%{?dist}
|
Release: 13.20130814git%{?dist}
|
||||||
Summary: NUMA user daemon
|
Summary: NUMA user daemon
|
||||||
|
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
@ -14,6 +14,8 @@ URL: http://git.fedorahosted.org/git/?p=numad.git
|
|||||||
# tar --exclude-vcs -cJf numad-0.5git.tar.xz numad-0.5git/
|
# tar --exclude-vcs -cJf numad-0.5git.tar.xz numad-0.5git/
|
||||||
Source0: %{name}-%{version}git.tar.xz
|
Source0: %{name}-%{version}git.tar.xz
|
||||||
Patch0: numad-0.5git-pthread.patch
|
Patch0: numad-0.5git-pthread.patch
|
||||||
|
Patch1: 0001-Fix-build-with-Werror-format-security.patch
|
||||||
|
Patch2: 0002-Don-t-order-service-after-syslog.target.patch
|
||||||
|
|
||||||
Requires: systemd-units, initscripts
|
Requires: systemd-units, initscripts
|
||||||
Requires(post): systemd-units, initscripts
|
Requires(post): systemd-units, initscripts
|
||||||
@ -30,9 +32,11 @@ and memory to minimize memory latency and thus provide optimum performance.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}git
|
%setup -q -n %{name}-%{version}git
|
||||||
%patch0 -p0
|
%patch0 -p0
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make CFLAGS="-std=gnu99 -g" LDFLAGS="-lpthread -lrt"
|
make CFLAGS="$RPM_OPT_FLAGS -std=gnu99" LDFLAGS="$RPM_LD_FLAGS -lpthread -lrt"
|
||||||
|
|
||||||
%install
|
%install
|
||||||
mkdir -p %{buildroot}%{_bindir}
|
mkdir -p %{buildroot}%{_bindir}
|
||||||
@ -61,6 +65,11 @@ make install prefix=%{buildroot}/usr
|
|||||||
%systemd_postun numad.service
|
%systemd_postun numad.service
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 20 2014 Ville Skyttä <ville.skytta@iki.fi> - 0.5-13.20130814git
|
||||||
|
- Don't order service after syslog.target (#1055209).
|
||||||
|
- Build with $RPM_OPT_FLAGS and $RPM_LD_FLAGS.
|
||||||
|
- Fix build with -Werror=format-security.
|
||||||
|
|
||||||
* Wed Aug 14 2013 Jan Synáček <jsynacek@redhat.com> - 0.5-12.20130814git
|
* Wed Aug 14 2013 Jan Synáček <jsynacek@redhat.com> - 0.5-12.20130814git
|
||||||
- Update to 20130814
|
- Update to 20130814
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user