Upgrade numactl to 2.0.12
The existing patches can be dropped, since both are already present upstream (and one of them wasn't being applied anyways.) The newer config.{guess,sub} can also be dropped, since numactl 2.0.12 package contains scripts dating from 2017-11, which contain riscv64 arch-specific bits. Signed-off-by: Filipe Brandenburger <filbranden@gmail.com>
This commit is contained in:
parent
0673f33a6c
commit
fc5f7661b7
@ -1,41 +0,0 @@
|
|||||||
From 25691a084a2012a339395ade567dbae814e237e9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mike Frysinger <vapier@gentoo.org>
|
|
||||||
Date: Mon, 18 Apr 2016 18:49:51 -0400
|
|
||||||
Subject: [PATCH] include sys/sysmacros.h for major/minor
|
|
||||||
|
|
||||||
These functions are not part of any official spec, and glibc has always
|
|
||||||
kept them in sys/sysmacros.h. As glibc moves to conform to POSIX, and
|
|
||||||
more alternative C libraries come up, we need to include this header
|
|
||||||
explicitly to get the prototypes. Otherwise we fail to build like:
|
|
||||||
|
|
||||||
affinity.c: In function 'affinity_file':
|
|
||||||
affinity.c:177:7: warning: implicit declaration of function 'major' [-Wimplicit-function-declaration]
|
|
||||||
if (major(d) != maj || minor(d) != min)
|
|
||||||
^
|
|
||||||
affinity.c:177:26: warning: implicit declaration of function 'minor' [-Wimplicit-function-declaration]
|
|
||||||
if (major(d) != maj || minor(d) != min)
|
|
||||||
^
|
|
||||||
./.libs/libnuma.so: undefined reference to 'minor'
|
|
||||||
./.libs/libnuma.so: undefined reference to 'major'
|
|
||||||
collect2: error: ld returned 1 exit status
|
|
||||||
|
|
||||||
See downstream bug: https://bugs.gentoo.org/580098
|
|
||||||
---
|
|
||||||
affinity.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/affinity.c b/affinity.c
|
|
||||||
index c460acf..85597fc 100644
|
|
||||||
--- a/affinity.c
|
|
||||||
+++ b/affinity.c
|
|
||||||
@@ -40,6 +40,7 @@
|
|
||||||
#include <linux/rtnetlink.h>
|
|
||||||
#include <linux/netlink.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
+#include <sys/sysmacros.h>
|
|
||||||
#include <ctype.h>
|
|
||||||
#include <assert.h>
|
|
||||||
#include <regex.h>
|
|
||||||
--
|
|
||||||
2.15.1
|
|
||||||
|
|
1462
config.guess
vendored
1462
config.guess
vendored
File diff suppressed because it is too large
Load Diff
1823
config.sub
vendored
1823
config.sub
vendored
File diff suppressed because it is too large
Load Diff
@ -1,15 +0,0 @@
|
|||||||
diff -up numactl-2.0.9/numactl.c.orig numactl-2.0.9/numactl.c
|
|
||||||
--- numactl-2.0.9/numactl.c.orig 2014-07-31 15:42:21.474060364 +0200
|
|
||||||
+++ numactl-2.0.9/numactl.c 2014-07-31 15:42:32.894085763 +0200
|
|
||||||
@@ -242,6 +242,11 @@ void hardware(void)
|
|
||||||
int prevnode=-1;
|
|
||||||
int skip=0;
|
|
||||||
int maxnode = numa_max_node();
|
|
||||||
+
|
|
||||||
+ if (numa_available() < 0) {
|
|
||||||
+ printf("No NUMA available on this system\n");
|
|
||||||
+ exit(1);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
for (i=0; i<=maxnode; i++)
|
|
||||||
if (numa_bitmask_isbitset(numa_nodes_ptr, i))
|
|
25
numactl.spec
25
numactl.spec
@ -1,27 +1,18 @@
|
|||||||
Name: numactl
|
Name: numactl
|
||||||
Summary: Library for tuning for Non Uniform Memory Access machines
|
Summary: Library for tuning for Non Uniform Memory Access machines
|
||||||
Version: 2.0.11
|
Version: 2.0.12
|
||||||
Release: 10%{dist}
|
Release: 1%{dist}
|
||||||
# libnuma is LGPLv2 and GPLv2
|
# libnuma is LGPLv2 and GPLv2
|
||||||
# numactl binaries are GPLv2 only
|
# numactl binaries are GPLv2 only
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: ftp://oss.sgi.com/www/projects/libnuma/download
|
URL: https://github.com/numactl/numactl
|
||||||
Source0: ftp://oss.sgi.com/www/projects/libnuma/download/numactl-%{version}.tar.gz
|
Source0: https://github.com/numactl/numactl/releases/download/v2.0.12/numactl-2.0.12.tar.gz
|
||||||
|
|
||||||
# Later config.{guess,sub} which know about the riscv64 architecture.
|
|
||||||
# These can be removed as soon as upstream update their copies.
|
|
||||||
Source1: config.guess
|
|
||||||
Source2: config.sub
|
|
||||||
|
|
||||||
BuildRequires: libtool automake autoconf
|
BuildRequires: libtool automake autoconf
|
||||||
|
|
||||||
ExcludeArch: s390 %{arm}
|
ExcludeArch: s390 %{arm}
|
||||||
|
|
||||||
# Fix major/minor macros on glibc 2.27.
|
|
||||||
# Upstream commit 25691a084a2012a339395ade567dbae814e237e9.
|
|
||||||
Patch1: 0001-include-sys-sysmacros.h-for-major-minor.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Simple NUMA policy support. It consists of a numactl program to run
|
Simple NUMA policy support. It consists of a numactl program to run
|
||||||
other programs with a specific NUMA policy.
|
other programs with a specific NUMA policy.
|
||||||
@ -47,8 +38,6 @@ Provides development headers for numa library calls
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
%patch1 -p1
|
|
||||||
cp %{SOURCE1} %{SOURCE2} build-aux/
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --prefix=/usr --libdir=%{_libdir}
|
%configure --prefix=/usr --libdir=%{_libdir}
|
||||||
@ -71,7 +60,7 @@ make DESTDIR=$RPM_BUILD_ROOT install
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc README
|
%doc README.md
|
||||||
%{_bindir}/numactl
|
%{_bindir}/numactl
|
||||||
%{_bindir}/numademo
|
%{_bindir}/numademo
|
||||||
%{_bindir}/numastat
|
%{_bindir}/numastat
|
||||||
@ -89,12 +78,16 @@ make DESTDIR=$RPM_BUILD_ROOT install
|
|||||||
%{_libdir}/libnuma.so
|
%{_libdir}/libnuma.so
|
||||||
%exclude %{_libdir}/libnuma.a
|
%exclude %{_libdir}/libnuma.a
|
||||||
%exclude %{_libdir}/libnuma.la
|
%exclude %{_libdir}/libnuma.la
|
||||||
|
%{_libdir}/pkgconfig/numa.pc
|
||||||
%{_includedir}/numa.h
|
%{_includedir}/numa.h
|
||||||
%{_includedir}/numaif.h
|
%{_includedir}/numaif.h
|
||||||
%{_includedir}/numacompat1.h
|
%{_includedir}/numacompat1.h
|
||||||
%{_mandir}/man3/*.3*
|
%{_mandir}/man3/*.3*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 25 2018 Filipe Brandenburger <filbranden@gmail.com> - 2.0.12-1
|
||||||
|
- Rebased to version 2.0.12
|
||||||
|
|
||||||
* Wed Jul 25 2018 Filipe Brandenburger <filbranden@gmail.com>
|
* Wed Jul 25 2018 Filipe Brandenburger <filbranden@gmail.com>
|
||||||
- Fix check-rpaths warning about including /usr/lib64 in RPATH of the binaries.
|
- Fix check-rpaths warning about including /usr/lib64 in RPATH of the binaries.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user