include missing manpages

This commit is contained in:
Anton Arapov 2012-01-02 13:20:58 +01:00
parent 5ed43fff98
commit a27d58639d
4 changed files with 19 additions and 47 deletions

View File

@ -1,12 +0,0 @@
diff -up numactl-2.0.2/clearcache.c.orig numactl-2.0.2/clearcache.c
--- numactl-2.0.2/clearcache.c.orig 2008-09-29 16:08:38.000000000 -0400
+++ numactl-2.0.2/clearcache.c 2008-09-29 16:08:49.000000000 -0400
@@ -57,7 +57,7 @@ void clearcache(unsigned char *mem, unsi
#if defined(__i386__) || defined(__x86_64__)
unsigned i, cl, eax, feat;
/* get clflush unit and feature */
- asm("cpuid" : "=a" (eax), "=b" (cl), "=d" (feat) : "0" (1) : "cx");
+ asm("cpuid" : "=a" (eax), "=r" (cl), "=d" (feat) : "0" (1) : "cx");
if (!(feat & (1 << 19)))
fallback_clearcache();
cl = ((cl >> 8) & 0xff) * 8;

View File

@ -1,35 +0,0 @@
diff -up numactl-2.0.3/libnuma.c.orig numactl-2.0.3/libnuma.c
--- numactl-2.0.3/libnuma.c.orig 2009-08-10 09:59:24.000000000 -0400
+++ numactl-2.0.3/libnuma.c 2009-08-10 10:00:40.000000000 -0400
@@ -95,6 +95,19 @@ numa_init(void)
memset(&numa_no_nodes, 0, sizeof(numa_no_nodes));
}
+void
+numa_fini(void)
+{
+ if (numa_all_cpus_ptr)
+ numa_bitmask_free(numa_all_cpus_ptr);
+ if (numa_all_nodes_ptr)
+ numa_bitmask_free(numa_all_nodes_ptr);
+ if (numa_no_nodes_ptr)
+ numa_bitmask_free(numa_no_nodes_ptr);
+ if (nodes_allowed_list)
+ free(nodes_allowed_list);
+}
+
/*
* The following bitmask declarations, bitmask_*() routines, and associated
* _setbit() and _getbit() routines are:
diff -up numactl-2.0.3/Makefile.orig numactl-2.0.3/Makefile
--- numactl-2.0.3/Makefile.orig 2009-06-10 08:30:03.000000000 -0400
+++ numactl-2.0.3/Makefile 2009-08-10 10:00:00.000000000 -0400
@@ -81,7 +81,7 @@ stream_main.o: stream_main.c
libnuma.so.1: versions.ldscript
libnuma.so.1: libnuma.o syscall.o distance.o
- ${CC} ${LDFLAGS} -shared -Wl,-soname=libnuma.so.1 -Wl,--version-script,versions.ldscript -Wl,-init,numa_init -o libnuma.so.1 $(filter-out versions.ldscript,$^)
+ ${CC} ${LDFLAGS} -shared -Wl,-soname=libnuma.so.1 -Wl,--version-script,versions.ldscript -Wl,-init,numa_init -Wl,-fini,numa_fini -o libnuma.so.1 $(filter-out versions.ldscript,$^)
libnuma.so: libnuma.so.1
ln -sf libnuma.so.1 libnuma.so

View File

@ -0,0 +1,14 @@
diff -up numactl-2.0.7/Makefile.manpages numactl-2.0.7/Makefile
--- numactl-2.0.7/Makefile.manpages 2012-01-02 13:14:07.130829736 +0100
+++ numactl-2.0.7/Makefile 2012-01-02 13:15:38.030922245 +0100
@@ -137,7 +137,10 @@ install: numactl migratepages migspeed n
install -m 0755 numademo ${prefix}/bin
install -m 0755 memhog ${prefix}/bin
mkdir -p ${prefix}/share/man/man2 ${prefix}/share/man/man8 ${prefix}/share/man/man3
+ install -m 0644 migspeed.8 ${prefix}/share/man/man8
+ install -m 0644 migratepages.8 ${prefix}/share/man/man8
install -m 0644 numactl.8 ${prefix}/share/man/man8
+ install -m 0644 numastat.8 ${prefix}/share/man/man8
install -m 0644 numa.3 ${prefix}/share/man/man3
( cd ${prefix}/share/man/man3 ; for i in $$(./manlinks) ; do ln -sf numa.3 $$i.3 ; done )
mkdir -p ${libdir}

View File

@ -9,6 +9,7 @@ Source0: ftp://oss.sgi.com/www/projects/libnuma/download/numactl-%{version}.tar.
Buildroot: %{_tmppath}/%{name}-buildroot
Patch1: numactl-2.0.3-rc3-no-nodes-warning.patch
Patch2: numactl-2.0.7-manpages.patch
ExcludeArch: s390 s390x %{arm}
@ -28,6 +29,7 @@ Provides development headers for numa library calls
%prep
%setup -q -n %{name}-%{version}
%patch1 -p1
%patch2 -p1
%build
make CFLAGS="$RPM_OPT_FLAGS -I."
@ -69,6 +71,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/*.3*
%changelog
* Mon Jan 01 2012 Anton Arapov <anton@redhat.com> - 2.0.7-3
- Include missing manpages
* Sat Jun 18 2011 Peter Robinson <pbrobinson@gmail.com> - 2.0.7-2
- Exclude ARM platforms