59681d22e6
Also fix building with cmocka >= 1.1.6
32 lines
901 B
Diff
32 lines
901 B
Diff
From 2c879a0ffa70cee33329291d7576ec971d420da2 Mon Sep 17 00:00:00 2001
|
|
From: Andreas Schneider <asn@samba.org>
|
|
Date: Fri, 17 Feb 2023 17:51:27 +0100
|
|
Subject: [PATCH] cmake: Fix cmocka >= 1.1.6 find_package() in CONFIG mode
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Andreas Schneider <asn@samba.org>
|
|
Reviewed-by: Pavel Filipenský <pfilipensky@samba.org>
|
|
---
|
|
tests/CMakeLists.txt | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
|
index 3b94076..733cc4e 100644
|
|
--- a/tests/CMakeLists.txt
|
|
+++ b/tests/CMakeLists.txt
|
|
@@ -1,5 +1,9 @@
|
|
project(tests C)
|
|
|
|
+if (TARGET cmocka::cmocka)
|
|
+ set(CMOCKA_LIBRARY cmocka::cmocka)
|
|
+endif()
|
|
+
|
|
set(TESTSUITE_LIBRARIES nss_utils ${NWRAP_REQUIRED_LIBRARIES} ${CMOCKA_LIBRARY})
|
|
string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LOWER)
|
|
|
|
--
|
|
2.39.2
|
|
|