Update to version 1.1.15
Also fix building with cmocka >= 1.1.6
This commit is contained in:
parent
812d0d4640
commit
59681d22e6
2
.gitignore
vendored
2
.gitignore
vendored
@ -19,3 +19,5 @@
|
|||||||
/nss_wrapper-1.1.12.tar.gz.asc
|
/nss_wrapper-1.1.12.tar.gz.asc
|
||||||
/nss_wrapper-1.1.13.tar.gz
|
/nss_wrapper-1.1.13.tar.gz
|
||||||
/nss_wrapper-1.1.13.tar.gz.asc
|
/nss_wrapper-1.1.13.tar.gz.asc
|
||||||
|
/nss_wrapper-1.1.15.tar.gz
|
||||||
|
/nss_wrapper-1.1.15.tar.gz.asc
|
||||||
|
31
nss_wrapper-fix-cmocka-1.1.6+-support.patch
Normal file
31
nss_wrapper-fix-cmocka-1.1.6+-support.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From 2c879a0ffa70cee33329291d7576ec971d420da2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andreas Schneider <asn@samba.org>
|
||||||
|
Date: Fri, 17 Feb 2023 17:51:27 +0100
|
||||||
|
Subject: [PATCH] cmake: Fix cmocka >= 1.1.6 find_package() in CONFIG mode
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||||
|
Reviewed-by: Pavel Filipenský <pfilipensky@samba.org>
|
||||||
|
---
|
||||||
|
tests/CMakeLists.txt | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
||||||
|
index 3b94076..733cc4e 100644
|
||||||
|
--- a/tests/CMakeLists.txt
|
||||||
|
+++ b/tests/CMakeLists.txt
|
||||||
|
@@ -1,5 +1,9 @@
|
||||||
|
project(tests C)
|
||||||
|
|
||||||
|
+if (TARGET cmocka::cmocka)
|
||||||
|
+ set(CMOCKA_LIBRARY cmocka::cmocka)
|
||||||
|
+endif()
|
||||||
|
+
|
||||||
|
set(TESTSUITE_LIBRARIES nss_utils ${NWRAP_REQUIRED_LIBRARIES} ${CMOCKA_LIBRARY})
|
||||||
|
string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LOWER)
|
||||||
|
|
||||||
|
--
|
||||||
|
2.39.2
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: nss_wrapper
|
Name: nss_wrapper
|
||||||
Version: 1.1.13
|
Version: 1.1.15
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
Summary: A wrapper for the user, group and hosts NSS API
|
Summary: A wrapper for the user, group and hosts NSS API
|
||||||
@ -10,6 +10,8 @@ Source0: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz
|
|||||||
Source1: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz.asc
|
Source1: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz.asc
|
||||||
Source2: nss_wrapper.keyring
|
Source2: nss_wrapper.keyring
|
||||||
|
|
||||||
|
Patch0: nss_wrapper-fix-cmocka-1.1.6+-support.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gnupg2
|
BuildRequires: gnupg2
|
||||||
@ -84,6 +86,11 @@ sed -i '1 s|/usr/bin/env\ perl|/usr/bin/perl|' %{buildroot}%{_bindir}/nss_wrappe
|
|||||||
%{_libdir}/libnss_wrapper.so*
|
%{_libdir}/libnss_wrapper.so*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 27 2023 Andreas Schneider <asn@redhat.com> - 1.1.13-3
|
||||||
|
- Update to version 1.1.15
|
||||||
|
https://gitlab.com/cwrap/nss_wrapper/-/blob/nss_wrapper-1.1.15/CHANGELOG
|
||||||
|
- Fix building with cmocka >= 1.1.6
|
||||||
|
|
||||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.13-2
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.13-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (nss_wrapper-1.1.13.tar.gz) = 763d7c61588c10492e34213e47415cc92df896838357093b85b4a8be7a88ca6e2cbe9697498aa54f5d31b3ead5baa24290e4275c4be6efca0e0da5767208ed5d
|
SHA512 (nss_wrapper-1.1.15.tar.gz) = 803dfb67e042800e60f4735177384ff3b9348f4c96c02e62ae0b449583542fdaf443eb1fa48b5d5e4ea6fe0d81ce84f340bd406c968c05f71b5c64dd499feacd
|
||||||
SHA512 (nss_wrapper-1.1.13.tar.gz.asc) = 51b9af7904675859dabb60210e1875eea229b24092d56fcd42a12a66170dd5eb290c258029307f39fd153e149e267c464b9263ff42c205b1d9e4c9c41ec276b1
|
SHA512 (nss_wrapper-1.1.15.tar.gz.asc) = 36ab3bc5cd2a26b5b07930191c3d1accef214e9744644769e02102b49e5d8d8054311dbd364295d5bc2979538e80c110a8d935fb6b5039a9b893d60d6a653fae
|
||||||
|
Loading…
Reference in New Issue
Block a user