14 lines
530 B
Diff
14 lines
530 B
Diff
Index: nss/coreconf/Linux.mk
|
|
===================================================================
|
|
--- nss.orig/coreconf/Linux.mk
|
|
+++ nss/coreconf/Linux.mk
|
|
@@ -144,7 +144,7 @@ ifdef USE_PTHREADS
|
|
endif
|
|
|
|
DSO_CFLAGS = -fPIC
|
|
-DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections
|
|
+DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections $(DSO_LDFLAGS)
|
|
# The linker on Red Hat Linux 7.2 and RHEL 2.1 (GNU ld version 2.11.90.0.8)
|
|
# incorrectly reports undefined references in the libraries we link with, so
|
|
# we don't use -z defs there.
|