cb85c9e1da
- Statically link the pem module against system freebl found in buildroot - Disable sha224-related powerup selftest until we update softokn - Disable sha224 and rsapss tests which nss-softokn 3.12.x doesn't support - nss-softokn 3.12.9 was submitted for FIPS 140 minor revalidation
17 lines
595 B
Diff
17 lines
595 B
Diff
diff -up ./mozilla/security/coreconf/Linux.mk.sytemfreebl ./mozilla/security/coreconf/Linux.mk
|
|
--- ./mozilla/security/coreconf/Linux.mk.sytemfreebl 2011-12-03 22:07:23.924156119 -0800
|
|
+++ ./mozilla/security/coreconf/Linux.mk 2011-12-03 22:08:28.322328345 -0800
|
|
@@ -182,6 +182,12 @@ endif
|
|
USE_SYSTEM_ZLIB = 1
|
|
ZLIB_LIBS = -lz
|
|
|
|
+USE_SYSTEM_NSSUTIL = 1
|
|
+NSSUTIL_LIBS = -lnssutil3
|
|
+
|
|
+USE_SYSTEM_FREEBL = 1
|
|
+FREEBL_LIBS = -lfreebl3
|
|
+
|
|
# The -rpath '$$ORIGIN' linker option instructs this library to search for its
|
|
# dependencies in the same directory where it resides.
|
|
ifeq ($(BUILD_SUN_PKG), 1)
|