25 lines
1.1 KiB
Diff
25 lines
1.1 KiB
Diff
diff -up ./coreconf/config.gypi.orig ./coreconf/config.gypi
|
|
--- ./coreconf/config.gypi.orig 2020-06-16 15:50:59.000000000 -0700
|
|
+++ ./coreconf/config.gypi 2020-10-15 16:05:37.542761192 -0700
|
|
@@ -363,7 +363,7 @@
|
|
'_DEFAULT_SOURCE', # for <endian.h> functions, strdup, realpath, and getentropy
|
|
'_BSD_SOURCE', # for the above in glibc <= 2.19
|
|
'_POSIX_SOURCE', # for <signal.h>
|
|
- 'SQL_MEASURE_USE_TEMP_DIR', # use tmpdir for the access calls
|
|
+ 'SDB_MEASURE_USE_TEMP_DIR', # use tmpdir for the access calls
|
|
],
|
|
}],
|
|
[ 'OS=="dragonfly" or OS=="freebsd"', {
|
|
diff -up ./coreconf/Linux.mk.orig ./coreconf/Linux.mk
|
|
--- ./coreconf/Linux.mk.orig 2020-10-15 16:05:04.794591674 -0700
|
|
+++ ./coreconf/Linux.mk 2020-10-15 16:05:37.543761197 -0700
|
|
@@ -21,7 +21,7 @@ ifeq ($(USE_PTHREADS),1)
|
|
endif
|
|
|
|
DEFAULT_COMPILER = gcc
|
|
-DEFINES += -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_SOURCE -DSQL_MEASURE_USE_TEMP_DIR
|
|
+DEFINES += -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_SOURCE -DSDB_MEASURE_USE_TEMP_DIR
|
|
|
|
ifeq ($(OS_TARGET),Android)
|
|
ifndef ANDROID_NDK
|