Update to nss-3.16.2
- Resolves: Bug 1114319 - nss-3.16.2 is available - Remove no longer needed patch
This commit is contained in:
parent
60816050f2
commit
fd6a1f2171
2
.gitignore
vendored
2
.gitignore
vendored
@ -8,4 +8,4 @@ TestCA.ca.cert
|
||||
TestUser50.cert
|
||||
TestUser51.cert
|
||||
/nss-pem-20140125.tar.bz2
|
||||
/nss-3.16.1.tar.gz
|
||||
/nss-3.16.2.tar.gz
|
||||
|
@ -1,38 +0,0 @@
|
||||
diff -up nss/tests/all.sh.crypto nss/tests/all.sh
|
||||
--- nss/tests/all.sh.crypto 2013-05-28 14:43:24.000000000 -0700
|
||||
+++ nss/tests/all.sh 2013-06-13 12:14:12.741082184 -0700
|
||||
@@ -299,9 +299,10 @@ fi
|
||||
# created, we check for modutil to know whether the build
|
||||
# is complete. If a new file is created after that, the
|
||||
# following test for modutil should check for that instead.
|
||||
+# Except when building softoken only where shlibsign is the last one built.
|
||||
+export LAST_BUILT=[ ${NSS_BUILD_SOFTOKEN_ONLY} -eq "1" ] && shlibsign || modutil
|
||||
|
||||
-if [ ! -f ${DIST}/${OBJDIR}/bin/modutil -a \
|
||||
- ! -f ${DIST}/${OBJDIR}/bin/modutil.exe ]; then
|
||||
+if [ ! -f ${DIST}/${OBJDIR}/bin/${LAST_BUILT}${PROG_SUFFIX} -a ]; then
|
||||
echo "Build Incomplete. Aborting test." >> ${LOGFILE}
|
||||
html_head "Testing Initialization"
|
||||
Exit "Checking for build"
|
||||
diff -up nss/tests/cipher/cipher.sh.crypto nss/tests/cipher/cipher.sh
|
||||
--- nss/tests/cipher/cipher.sh.crypto 2013-05-28 14:43:24.000000000 -0700
|
||||
+++ nss/tests/cipher/cipher.sh 2013-06-13 11:58:00.956064976 -0700
|
||||
@@ -129,6 +129,16 @@ if [ ! -x ${DIST}/${OBJDIR}/bin/bltest${
|
||||
return 0
|
||||
fi
|
||||
cipher_init
|
||||
-cipher_main
|
||||
-cipher_gcm
|
||||
+if [ "${NSS_BUILD_SOFTOKEN_ONLY}" = "1" ]; then
|
||||
+ echo "Skipping cipher_gcm because this is a softoken only build"
|
||||
+ cipher_main
|
||||
+elif [ "${NSS_BUILD_WITHOUT_SOFTOKEN}" = "1" ]; then
|
||||
+ echo "Skipping cipher_main because this an nss without softoken build"
|
||||
+ cipher_gcm
|
||||
+else
|
||||
+ # default is to run both
|
||||
+ cipher_init
|
||||
+ cipher_main
|
||||
+ cipher_gcm
|
||||
+fi
|
||||
cipher_cleanup
|
16
nss.spec
16
nss.spec
@ -1,6 +1,6 @@
|
||||
%global nspr_version 4.10.5
|
||||
%global nss_util_version 3.16.1
|
||||
%global nss_softokn_version 3.16.1
|
||||
%global nspr_version 4.10.6
|
||||
%global nss_util_version 3.16.2
|
||||
%global nss_softokn_version 3.16.2
|
||||
%global unsupported_tools_directory %{_libdir}/nss/unsupported-tools
|
||||
%global allTools "certutil cmsutil crlutil derdump modutil pk12util pp signtool signver ssltap vfychain vfyserv"
|
||||
|
||||
@ -18,8 +18,8 @@
|
||||
|
||||
Summary: Network Security Services
|
||||
Name: nss
|
||||
Version: 3.16.1
|
||||
Release: 4%{?dist}
|
||||
Version: 3.16.2
|
||||
Release: 1%{?dist}
|
||||
License: MPLv2.0
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
Group: System Environment/Libraries
|
||||
@ -82,8 +82,6 @@ Patch25: nsspem-use-system-freebl.patch
|
||||
Patch40: nss-3.14.0.0-disble-ocsp-test.patch
|
||||
# Fedora / RHEL-only patch, the templates directory was originally introduced to support mod_revocator
|
||||
Patch47: utilwrap-include-templates.patch
|
||||
# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=902171
|
||||
Patch48: nss-versus-softoken-tests.patch
|
||||
# TODO remove when we switch to building nss without softoken
|
||||
Patch49: nss-skip-bltest-and-fipstest.patch
|
||||
# This patch uses the gcc-iquote dir option documented at
|
||||
@ -178,7 +176,6 @@ low level services.
|
||||
%patch25 -p0 -b .systemfreebl
|
||||
%patch40 -p0 -b .noocsptest
|
||||
%patch47 -p0 -b .templates
|
||||
%patch48 -p0 -b .crypto
|
||||
%patch49 -p0 -b .skipthem
|
||||
%patch50 -p0 -b .iquote
|
||||
|
||||
@ -750,6 +747,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Jun 29 2014 Elio Maldonado <emaldona@redhat.com> - 3.16.2-1
|
||||
- Update to nss-3.16.2
|
||||
|
||||
* Sun Jun 15 2014 Elio Maldonado <emaldona@redhat.com> - 3.16.1-4
|
||||
- Remove unwanted source directories at end of %%prep so it truly does it
|
||||
- Skip the cipher suite already run as part of the nss-softokn build
|
||||
|
2
sources
2
sources
@ -8,4 +8,4 @@ f998b70c1be25e8bb9f5fdb5d50eb6f2 TestCA.ca.cert
|
||||
1b7b6808cd77d5df29bf5bb9e5fac967 TestUser50.cert
|
||||
ab0b56dd505a995425c03e5266f7c8d6 TestUser51.cert
|
||||
b8a94e863c852e1f8b75e930e76f8640 nss-pem-20140125.tar.bz2
|
||||
97ccaa5d27aa59faf07c8b968dbaea1d nss-3.16.1.tar.gz
|
||||
afc6789c9d805db5be1e5f3c533394f1 nss-3.16.2.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user