Merge branch 'f16'
This commit is contained in:
commit
e8491da33f
20
nss.spec
20
nss.spec
@ -70,8 +70,6 @@ Patch25: nsspem-use-system-freebl.patch
|
|||||||
Patch26: nofipstest.patch
|
Patch26: nofipstest.patch
|
||||||
# sha224 isn't available we use 3.12 softokn
|
# sha224 isn't available we use 3.12 softokn
|
||||||
Patch27: nosha224.patch
|
Patch27: nosha224.patch
|
||||||
# Get rid of it as soon as we can
|
|
||||||
Patch28: terminalrecord.patch
|
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -160,7 +158,6 @@ low level services.
|
|||||||
%patch25 -p0 -b .systemfreebl
|
%patch25 -p0 -b .systemfreebl
|
||||||
%patch26 -p0 -b .nofipstest
|
%patch26 -p0 -b .nofipstest
|
||||||
%patch27 -p0 -b .nosha224
|
%patch27 -p0 -b .nosha224
|
||||||
%patch28 -p0 -b .terminalrecord
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -187,13 +184,16 @@ export PKG_CONFIG_ALLOW_SYSTEM_LIBS
|
|||||||
export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS
|
export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS
|
||||||
|
|
||||||
NSPR_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nspr | sed 's/-I//'`
|
NSPR_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nspr | sed 's/-I//'`
|
||||||
NSPR_LIB_DIR=`/usr/bin/pkg-config --libs-only-L nspr | sed 's/-L//'`
|
NSPR_LIB_DIR=%{_libdir}
|
||||||
|
|
||||||
export NSPR_INCLUDE_DIR
|
export NSPR_INCLUDE_DIR
|
||||||
export NSPR_LIB_DIR
|
export NSPR_LIB_DIR
|
||||||
|
|
||||||
NSS_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-util | sed 's/-I//'`
|
export FREEBL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-softokn | sed 's/-I//'`
|
||||||
NSS_LIB_DIR=`/usr/bin/pkg-config --libs-only-L nss-util | sed 's/-L//'`
|
export FREEBL_LIB_DIR=%{_libdir}
|
||||||
|
export USE_SYSTEM_FREEBL=1
|
||||||
|
# prevents running the sha224 portion of the powerup selftest when testing
|
||||||
|
export NO_SHA224_AVAILABLE=1
|
||||||
|
|
||||||
NSS_USE_SYSTEM_SQLITE=1
|
NSS_USE_SYSTEM_SQLITE=1
|
||||||
export NSS_USE_SYSTEM_SQLITE
|
export NSS_USE_SYSTEM_SQLITE
|
||||||
@ -241,7 +241,7 @@ export NSS_ECC_MORE_THAN_SUITE_B
|
|||||||
-e "s,%%NSS_VERSION%%,%{version},g" \
|
-e "s,%%NSS_VERSION%%,%{version},g" \
|
||||||
-e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
|
-e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
|
||||||
-e "s,%%NSSUTIL_VERSION%%,%{nss_util_version},g" \
|
-e "s,%%NSSUTIL_VERSION%%,%{nss_util_version},g" \
|
||||||
-e "s,%%SOFTOKEN_VERSION%%,%{nss_softokn_version},g" > \
|
-e "s,%%SOFTOKEN_VERSION%%,%{nss_softokn_fips_version},g" > \
|
||||||
./mozilla/dist/pkgconfig/nss.pc
|
./mozilla/dist/pkgconfig/nss.pc
|
||||||
|
|
||||||
NSS_VMAJOR=`cat mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
|
NSS_VMAJOR=`cat mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
|
||||||
@ -574,7 +574,11 @@ rm -rf $RPM_BUILD_ROOT/%{_includedir}/nss3/nsslowhash.h
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Sun Dec 04 2011 Elio Maldonado <emaldona@redhat.com> - 3.13.1-6
|
* Mon Dec 05 2011 Elio Maldonado <emaldona@redhat.com> - 3.13.1-6
|
||||||
|
- Removed unwanted /usr/include/nss3 in front of the normal cflags include path
|
||||||
|
- Removed unnecessary patch dealing with CERTDB_TERMINAL_RECORD, it's visible
|
||||||
|
|
||||||
|
* Sun Dec 04 2011 Elio Maldonado <emaldona@redhat.com> - 3.13.1-5
|
||||||
- Statically link the pem module against system freebl found in buildroot
|
- Statically link the pem module against system freebl found in buildroot
|
||||||
- Disabling sha224-related powerup selftest until we update softokn
|
- Disabling sha224-related powerup selftest until we update softokn
|
||||||
- Disable sha224 and pss tests which nss-softokn 3.12.x doesn't support
|
- Disable sha224 and pss tests which nss-softokn 3.12.x doesn't support
|
||||||
|
@ -1,13 +1,10 @@
|
|||||||
diff -up ./mozilla/security/coreconf/Linux.mk.sytemfreebl ./mozilla/security/coreconf/Linux.mk
|
diff -up ./mozilla/security/coreconf/Linux.mk.sytemfreebl ./mozilla/security/coreconf/Linux.mk
|
||||||
--- ./mozilla/security/coreconf/Linux.mk.sytemfreebl 2011-12-03 22:07:23.924156119 -0800
|
--- ./mozilla/security/coreconf/Linux.mk.sytemfreebl 2011-12-03 22:07:23.924156119 -0800
|
||||||
+++ ./mozilla/security/coreconf/Linux.mk 2011-12-03 22:08:28.322328345 -0800
|
+++ ./mozilla/security/coreconf/Linux.mk 2011-12-03 22:08:28.322328345 -0800
|
||||||
@@ -182,6 +182,12 @@ endif
|
@@ -182,6 +182,9 @@ endif
|
||||||
USE_SYSTEM_ZLIB = 1
|
USE_SYSTEM_ZLIB = 1
|
||||||
ZLIB_LIBS = -lz
|
ZLIB_LIBS = -lz
|
||||||
|
|
||||||
+USE_SYSTEM_NSSUTIL = 1
|
|
||||||
+NSSUTIL_LIBS = -lnssutil3
|
|
||||||
+
|
|
||||||
+USE_SYSTEM_FREEBL = 1
|
+USE_SYSTEM_FREEBL = 1
|
||||||
+FREEBL_LIBS = -lfreebl3
|
+FREEBL_LIBS = -lfreebl3
|
||||||
+
|
+
|
||||||
|
@ -1,90 +0,0 @@
|
|||||||
diff -up ./mozilla/security/nss/cmd/addbuiltin/addbuiltin.c.terminalrecord ./mozilla/security/nss/cmd/addbuiltin/addbuiltin.c
|
|
||||||
--- ./mozilla/security/nss/cmd/addbuiltin/addbuiltin.c.terminalrecord 2011-12-04 21:15:47.660672521 -0800
|
|
||||||
+++ ./mozilla/security/nss/cmd/addbuiltin/addbuiltin.c 2011-12-04 21:16:39.491674974 -0800
|
|
||||||
@@ -52,6 +52,14 @@
|
|
||||||
#include <io.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
|
|
||||||
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
|
|
||||||
+ * but invisible here for some reason
|
|
||||||
+ */
|
|
||||||
+#ifndef CERTDB_TERMINAL_RECORD
|
|
||||||
+#define CERTDB_TERMINAL_RECORD (1<<0)
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
void dumpbytes(unsigned char *buf, int len)
|
|
||||||
{
|
|
||||||
int i;
|
|
||||||
diff -up ./mozilla/security/nss/lib/certhigh/certvfy.c.terminalrecord ./mozilla/security/nss/lib/certhigh/certvfy.c
|
|
||||||
--- ./mozilla/security/nss/lib/certhigh/certvfy.c.terminalrecord 2011-09-13 17:28:47.000000000 -0700
|
|
||||||
+++ ./mozilla/security/nss/lib/certhigh/certvfy.c 2011-12-04 21:14:01.683678605 -0800
|
|
||||||
@@ -56,6 +56,14 @@
|
|
||||||
#include "pki3hack.h"
|
|
||||||
#include "base.h"
|
|
||||||
|
|
||||||
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
|
|
||||||
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
|
|
||||||
+ * but invisible here for some reason
|
|
||||||
+ */
|
|
||||||
+#ifndef CERTDB_TERMINAL_RECORD
|
|
||||||
+#define CERTDB_TERMINAL_RECORD (1<<0)
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/*
|
|
||||||
* Check the validity times of a certificate
|
|
||||||
*/
|
|
||||||
diff -up ./mozilla/security/nss/lib/libpkix/pkix_pl_nss/pki/pkix_pl_cert.c.terminalrecord ./mozilla/security/nss/lib/libpkix/pkix_pl_nss/pki/pkix_pl_cert.c
|
|
||||||
--- ./mozilla/security/nss/lib/libpkix/pkix_pl_nss/pki/pkix_pl_cert.c.terminalrecord 2011-09-14 16:16:16.000000000 -0700
|
|
||||||
+++ ./mozilla/security/nss/lib/libpkix/pkix_pl_nss/pki/pkix_pl_cert.c 2011-12-04 21:14:01.684678605 -0800
|
|
||||||
@@ -43,6 +43,14 @@
|
|
||||||
|
|
||||||
#include "pkix_pl_cert.h"
|
|
||||||
|
|
||||||
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
|
|
||||||
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
|
|
||||||
+ * but invisible here for some reason
|
|
||||||
+ */
|
|
||||||
+#ifndef CERTDB_TERMINAL_RECORD
|
|
||||||
+#define CERTDB_TERMINAL_RECORD (1<<0)
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
extern PKIX_PL_HashTable *cachedCertSigTable;
|
|
||||||
|
|
||||||
/* --Private-Cert-Functions------------------------------------- */
|
|
||||||
diff -up ./mozilla/security/nss/lib/pk11wrap/pk11nobj.c.terminalrecord ./mozilla/security/nss/lib/pk11wrap/pk11nobj.c
|
|
||||||
--- ./mozilla/security/nss/lib/pk11wrap/pk11nobj.c.terminalrecord 2011-04-12 17:10:26.000000000 -0700
|
|
||||||
+++ ./mozilla/security/nss/lib/pk11wrap/pk11nobj.c 2011-12-04 21:14:01.685678605 -0800
|
|
||||||
@@ -62,6 +62,14 @@
|
|
||||||
#include "pki.h"
|
|
||||||
#include "pkim.h"
|
|
||||||
|
|
||||||
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
|
|
||||||
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
|
|
||||||
+ * but invisible here for some reason
|
|
||||||
+ */
|
|
||||||
+#ifndef CERTDB_TERMINAL_RECORD
|
|
||||||
+#define CERTDB_TERMINAL_RECORD (1<<0)
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
extern const NSSError NSS_ERROR_NOT_FOUND;
|
|
||||||
|
|
||||||
CK_TRUST
|
|
||||||
diff -up ./mozilla/security/nss/lib/pki/pki3hack.c.terminalrecord ./mozilla/security/nss/lib/pki/pki3hack.c
|
|
||||||
--- ./mozilla/security/nss/lib/pki/pki3hack.c.terminalrecord 2011-04-12 17:10:26.000000000 -0700
|
|
||||||
+++ ./mozilla/security/nss/lib/pki/pki3hack.c 2011-12-04 21:14:01.686678605 -0800
|
|
||||||
@@ -76,6 +76,14 @@ static const char CVS_ID[] = "@(#) $RCSf
|
|
||||||
#include "secmod.h"
|
|
||||||
#include "nssrwlk.h"
|
|
||||||
|
|
||||||
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
|
|
||||||
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
|
|
||||||
+ * but invisible here for some reason
|
|
||||||
+ */
|
|
||||||
+#ifndef CERTDB_TERMINAL_RECORD
|
|
||||||
+#define CERTDB_TERMINAL_RECORD (1<<0)
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
NSSTrustDomain *g_default_trust_domain = NULL;
|
|
||||||
|
|
||||||
NSSCryptoContext *g_default_crypto_context = NULL;
|
|
Loading…
Reference in New Issue
Block a user