Resolves: RHEL-61296
+- fix shlibsign in FIPS mode +- remove dbm from pkgconfig
This commit is contained in:
parent
ae9a202e77
commit
e5a21dd021
12
nss-3.101-fix-shlibsign-fips.patch
Normal file
12
nss-3.101-fix-shlibsign-fips.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up ./cmd/shlibsign/shlibsign.c.shlibsign ./cmd/shlibsign/shlibsign.c
|
||||
--- ./cmd/shlibsign/shlibsign.c.shlibsign 2024-06-07 09:26:03.000000000 -0700
|
||||
+++ ./cmd/shlibsign/shlibsign.c 2024-10-31 10:49:28.637449054 -0700
|
||||
@@ -1426,7 +1426,7 @@ main(int argc, char **argv)
|
||||
} else {
|
||||
/* NON FIPS mode == C_GetFunctionList */
|
||||
pC_GetFunctionList = (CK_C_GetFunctionList)
|
||||
- PR_FindFunctionSymbol(lib, "C_GetFunctionList");
|
||||
+ PR_FindFunctionSymbol(lib, "NSC_GetFunctionList");
|
||||
}
|
||||
assert(pC_GetFunctionList != NULL);
|
||||
if (!pC_GetFunctionList) {
|
@ -21,7 +21,6 @@ Options:
|
||||
Dynamic Libraries:
|
||||
softokn3 - Requires full dynamic linking
|
||||
freebl3 - for internal use only (and glibc for self-integrity check)
|
||||
nssdbm3 - for internal use only
|
||||
Dymamically linked
|
||||
EOF
|
||||
exit $1
|
||||
|
@ -7,5 +7,5 @@ Name: NSS-SOFTOKN
|
||||
Description: Network Security Services Softoken PKCS #11 Module
|
||||
Version: %SOFTOKEN_VERSION%
|
||||
Requires: nspr >= %NSPR_VERSION%, nss-util >= %NSSUTIL_VERSION%
|
||||
Libs: -L${libdir} -lfreebl3 -lnssdbm3 -lsoftokn3
|
||||
Libs: -L${libdir} -lfreebl3 -lsoftokn3
|
||||
Cflags: -I${includedir}
|
||||
|
7
nss.spec
7
nss.spec
@ -1,6 +1,6 @@
|
||||
%global nss_version 3.101.0
|
||||
%global nspr_version 4.35.0
|
||||
%global baserelease 7
|
||||
%global baserelease 8
|
||||
%global nss_release %baserelease
|
||||
# NOTE: To avoid NVR clashes of nspr* packages:
|
||||
# use "%%global nspr_release %%[%%baserelease+n]" to handle offsets when
|
||||
@ -199,6 +199,7 @@ Patch84: nss-3.101-fix-pkcs12-pbkdf1-encoding.patch
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=676100
|
||||
Patch85: nss-3.101-fix-cms-abi-break.patch
|
||||
Patch86: nss-3.101-long-pwd-fix.patch
|
||||
Patch87: nss-3.101-fix-shlibsign-fips.patch
|
||||
|
||||
Patch100: nspr-config-pc.patch
|
||||
Patch101: nspr-gcc-atomics.patch
|
||||
@ -1200,6 +1201,10 @@ update-crypto-policies &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 4 2024 Bob Relyea <rrelyea@redhat.com> - 3.101.0-7
|
||||
- fix shlibsign in FIPS mode
|
||||
- remove dbm from pkgconfig
|
||||
|
||||
* Wed Sep 4 2024 Bob Relyea <rrelyea@redhat.com> - 3.101.0-7
|
||||
- fix cms abi breakage
|
||||
- fix long password issue on pbmac encodings
|
||||
|
Loading…
Reference in New Issue
Block a user