Update tests to be compatible with default NSS DB changed to sql (the default was changed in the nss-util package).
This commit is contained in:
parent
c4dce982fc
commit
cd77ff2c17
22
nss-sql-4-1377940-test.patch
Normal file
22
nss-sql-4-1377940-test.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff --git a/tests/merge/merge.sh b/tests/merge/merge.sh
|
||||
--- a/tests/merge/merge.sh
|
||||
+++ b/tests/merge/merge.sh
|
||||
@@ -93,17 +93,17 @@ merge_init()
|
||||
CONFLICT1DIR=conflict1
|
||||
CONFLICT2DIR=conflict2
|
||||
mkdir ${CONFLICT1DIR}
|
||||
mkdir ${CONFLICT2DIR}
|
||||
# in the upgrade mode (dbm->sql), make sure our test databases
|
||||
# are dbm databases.
|
||||
if [ "${TEST_MODE}" = "UPGRADE_DB" ]; then
|
||||
save=${NSS_DEFAULT_DB_TYPE}
|
||||
- NSS_DEFAULT_DB_TYPE= ; export NSS_DEFAULT_DB_TYPE
|
||||
+ NSS_DEFAULT_DB_TYPE=dbm ; export NSS_DEFAULT_DB_TYPE
|
||||
fi
|
||||
|
||||
certutil -N -d ${CONFLICT1DIR} -f ${R_PWFILE}
|
||||
certutil -N -d ${CONFLICT2DIR} -f ${R_PWFILE}
|
||||
certutil -A -n Alice -t ,, -i ${R_CADIR}/TestUser41.cert -d ${CONFLICT1DIR}
|
||||
# modify CONFLICTDIR potentially corrupting the database
|
||||
certutil -A -n "Alice #1" -t C,, -i ${R_CADIR}/TestUser42.cert -d ${CONFLICT1DIR} -f ${R_PWFILE}
|
||||
certutil -M -n "Alice #1" -t ,, -d ${CONFLICT1DIR} -f ${R_PWFILE}
|
10
nss.spec
10
nss.spec
@ -9,7 +9,7 @@ Name: nss
|
||||
Version: 3.33.0
|
||||
# for Rawhide, please always use release >= 2
|
||||
# for Fedora release branches, please use release < 2 (1.0, 1.1, ...)
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: MPLv2.0
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
Group: System Environment/Libraries
|
||||
@ -105,7 +105,8 @@ Patch73: nss-sql-2-1382278-a.patch
|
||||
Patch74: nss-sql-2-1382278-b.patch
|
||||
Patch75: nss-sql-3-1395495-a.patch
|
||||
Patch76: nss-sql-3-1395495-b.patch
|
||||
|
||||
# Fix upgrade_db test use dbm by default, required with default sql
|
||||
Patch77: nss-sql-4-1377940-test.patch
|
||||
|
||||
%description
|
||||
Network Security Services (NSS) is a set of libraries designed to
|
||||
@ -196,6 +197,7 @@ pushd nss
|
||||
%patch74 -p1 -b .1382278-b
|
||||
%patch75 -p1 -b .1395495-a
|
||||
%patch76 -p1 -b .1395495-b
|
||||
%patch77 -p1 -b .1377940
|
||||
|
||||
popd
|
||||
|
||||
@ -772,6 +774,10 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Nov 7 2017 Kai Engert <kaie@redhat.com> - 3.33.0-4
|
||||
- Update tests to be compatible with default NSS DB changed to sql
|
||||
(the default was changed in the nss-util package).
|
||||
|
||||
* Tue Oct 24 2017 Kai Engert <kaie@redhat.com> - 3.33.0-3
|
||||
- rhbz#1505487, backport upstream fixes required for rhbz#1496560
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user