- Update to NSS_3_12_BETA3
This commit is contained in:
parent
a2b7a459f1
commit
bddacee193
@ -1,2 +1,2 @@
|
||||
nss-pem-20080124.tar.bz2
|
||||
nss-3.11.99.4-stripped.tar.gz
|
||||
nss-3.11.99.5-stripped.tar.gz
|
||||
|
130
bug432146.patch
130
bug432146.patch
@ -1,130 +0,0 @@
|
||||
Index: mozilla/security/nss/lib/freebl/mpi/mp_comba.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/nss/lib/freebl/mpi/mp_comba.c,v
|
||||
retrieving revision 1.2
|
||||
diff -u -u -8 -p -r1.2 mp_comba.c
|
||||
--- mozilla/security/nss/lib/freebl/mpi/mp_comba.c 16 Aug 2005 19:25:48 -0000 1.2
|
||||
+++ mozilla/security/nss/lib/freebl/mpi/mp_comba.c 14 Feb 2008 22:36:54 -0000
|
||||
@@ -87,22 +87,22 @@ __asm__ (
|
||||
"adcq $0,%2 \n\t" \
|
||||
"addq %%rax,%0 \n\t" \
|
||||
"adcq %%rdx,%1 \n\t" \
|
||||
"adcq $0,%2 \n\t" \
|
||||
:"=r"(c0), "=r"(c1), "=r"(c2): "0"(c0), "1"(c1), "2"(c2), "g"(i), "g"(j) :"%rax","%rdx","%cc");
|
||||
|
||||
#define SQRADDSC(i, j) \
|
||||
__asm__ ( \
|
||||
- "movq %6,%%rax \n\t" \
|
||||
- "mulq %7 \n\t" \
|
||||
+ "movq %3,%%rax \n\t" \
|
||||
+ "mulq %4 \n\t" \
|
||||
"movq %%rax,%0 \n\t" \
|
||||
"movq %%rdx,%1 \n\t" \
|
||||
"xorq %2,%2 \n\t" \
|
||||
- :"=r"(sc0), "=r"(sc1), "=r"(sc2): "0"(sc0), "1"(sc1), "2"(sc2), "g"(i), "g"(j) :"%rax","%rdx","%cc");
|
||||
+ :"=r"(sc0), "=r"(sc1), "=r"(sc2): "g"(i), "g"(j) :"%rax","%rdx","%cc");
|
||||
|
||||
#define SQRADDAC(i, j) \
|
||||
__asm__ ( \
|
||||
"movq %6,%%rax \n\t" \
|
||||
"mulq %7 \n\t" \
|
||||
"addq %%rax,%0 \n\t" \
|
||||
"adcq %%rdx,%1 \n\t" \
|
||||
"adcq $0,%2 \n\t" \
|
||||
@@ -111,17 +111,17 @@ __asm__ (
|
||||
#define SQRADDDB \
|
||||
__asm__ ( \
|
||||
"addq %3,%0 \n\t" \
|
||||
"adcq %4,%1 \n\t" \
|
||||
"adcq %5,%2 \n\t" \
|
||||
"addq %3,%0 \n\t" \
|
||||
"adcq %4,%1 \n\t" \
|
||||
"adcq %5,%2 \n\t" \
|
||||
- :"=r"(c0), "=r"(c1), "=r"(c2), "=r"(sc0), "=r"(sc1), "=r"(sc2) : "0"(c0), "1"(c1), "2"(c2), "3"(sc0), "4"(sc1), "5"(sc2) : "%cc");
|
||||
+ :"=&r"(c0), "=&r"(c1), "=&r"(c2) : "r"(sc0), "r"(sc1), "r"(sc2), "0"(c0), "1"(c1), "2"(c2) : "%cc");
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
void s_mp_mul_comba_4(const mp_int *A, const mp_int *B, mp_int *C)
|
||||
{
|
||||
mp_digit c0, c1, c2, at[8];
|
||||
@@ -645,19 +645,17 @@ void s_mp_mul_comba_32(const mp_int *A,
|
||||
mp_clamp(C);
|
||||
COMBA_FINI;
|
||||
}
|
||||
|
||||
|
||||
|
||||
void s_mp_sqr_comba_4(const mp_int *A, mp_int *B)
|
||||
{
|
||||
- mp_digit *a, b[8], c0, c1, c2, sc0, sc1, sc2;
|
||||
- /* get rid of some compiler warnings */
|
||||
- sc0 = 0; sc1 = 0; sc2 = 0;
|
||||
+ mp_digit *a, b[8], c0, c1, c2;
|
||||
|
||||
a = A->dp;
|
||||
COMBA_START;
|
||||
|
||||
/* clear carries */
|
||||
CLEAR_CARRY;
|
||||
|
||||
/* output 0 */
|
||||
@@ -700,18 +698,16 @@ void s_mp_sqr_comba_4(const mp_int *A, m
|
||||
B->sign = ZPOS;
|
||||
memcpy(B->dp, b, 8 * sizeof(mp_digit));
|
||||
mp_clamp(B);
|
||||
}
|
||||
|
||||
void s_mp_sqr_comba_8(const mp_int *A, mp_int *B)
|
||||
{
|
||||
mp_digit *a, b[16], c0, c1, c2, sc0, sc1, sc2;
|
||||
- /* get rid of some compiler warnings */
|
||||
- sc0 = 0; sc1 = 0; sc2 = 0;
|
||||
|
||||
a = A->dp;
|
||||
COMBA_START;
|
||||
|
||||
/* clear carries */
|
||||
CLEAR_CARRY;
|
||||
|
||||
/* output 0 */
|
||||
@@ -794,18 +790,16 @@ void s_mp_sqr_comba_8(const mp_int *A, m
|
||||
B->sign = ZPOS;
|
||||
memcpy(B->dp, b, 16 * sizeof(mp_digit));
|
||||
mp_clamp(B);
|
||||
}
|
||||
|
||||
void s_mp_sqr_comba_16(const mp_int *A, mp_int *B)
|
||||
{
|
||||
mp_digit *a, b[32], c0, c1, c2, sc0, sc1, sc2;
|
||||
- /* get rid of some compiler warnings */
|
||||
- sc0 = 0; sc1 = 0; sc2 = 0;
|
||||
|
||||
a = A->dp;
|
||||
COMBA_START;
|
||||
|
||||
/* clear carries */
|
||||
CLEAR_CARRY;
|
||||
|
||||
/* output 0 */
|
||||
@@ -969,18 +963,16 @@ void s_mp_sqr_comba_16(const mp_int *A,
|
||||
memcpy(B->dp, b, 32 * sizeof(mp_digit));
|
||||
mp_clamp(B);
|
||||
}
|
||||
|
||||
|
||||
void s_mp_sqr_comba_32(const mp_int *A, mp_int *B)
|
||||
{
|
||||
mp_digit *a, b[64], c0, c1, c2, sc0, sc1, sc2;
|
||||
- /* get rid of some compiler warnings */
|
||||
- sc0 = 0; sc1 = 0; sc2 = 0;
|
||||
|
||||
a = A->dp;
|
||||
COMBA_START;
|
||||
|
||||
/* clear carries */
|
||||
CLEAR_CARRY;
|
||||
|
||||
/* output 0 */
|
44
nss-fix-tests.patch
Normal file
44
nss-fix-tests.patch
Normal file
@ -0,0 +1,44 @@
|
||||
diff -up ./mozilla/security/nss/tests/header.prex ./mozilla/security/nss/tests/header
|
||||
--- ./mozilla/security/nss/tests/header.prex 2008-03-17 21:36:11.000000000 +0100
|
||||
+++ ./mozilla/security/nss/tests/header 2008-03-17 21:36:47.000000000 +0100
|
||||
@@ -1114,8 +1114,8 @@ qa_stat_get_sysinfo()
|
||||
set_objdir()
|
||||
{
|
||||
Debug "set object dir"
|
||||
- OBJDIR=`cd ${TESTSCRIPTDIR}/common; gmake objdir_name`
|
||||
- OS_ARCH=`cd ${TESTSCRIPTDIR}/common; gmake os_arch`
|
||||
+ OBJDIR=`cd ${TESTSCRIPTDIR}/common; gmake --no-print-directory objdir_name`
|
||||
+ OS_ARCH=`cd ${TESTSCRIPTDIR}/common; gmake --no-print-directory os_arch`
|
||||
|
||||
#at this point $MASTERBUILD needs to be either NT or unix
|
||||
|
||||
diff -up ./mozilla/security/nss/tests/nsspath.prex ./mozilla/security/nss/tests/nsspath
|
||||
--- ./mozilla/security/nss/tests/nsspath.prex 2008-03-17 21:37:10.000000000 +0100
|
||||
+++ ./mozilla/security/nss/tests/nsspath 2008-03-17 21:37:23.000000000 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
set PWD=`pwd`
|
||||
source /u/sonmi/bin/nssdir $*
|
||||
-set OBJDIR=`(cd mozilla/security/nss/tests/common; gmake objdir_name)`
|
||||
+set OBJDIR=`(cd mozilla/security/nss/tests/common; gmake --no-print-directory objdir_name)`
|
||||
setenv PATH `perl /u/sonmi/bin/path_uniq -s "${PATH}:${UXDIST}/${OBJDIR}/bin"`
|
||||
if ( `uname -n` == "iws-perf" ) then
|
||||
setenv LD_LIBRARY_PATH "${UXDIST}/${OBJDIR}/lib:/opt/nfast/toolkits/pkcs11"
|
||||
diff -up ./mozilla/security/nss/tests/common/init.sh.prex ./mozilla/security/nss/tests/common/init.sh
|
||||
--- ./mozilla/security/nss/tests/common/init.sh.prex 2008-03-17 21:37:32.000000000 +0100
|
||||
+++ ./mozilla/security/nss/tests/common/init.sh 2008-03-17 21:38:52.000000000 +0100
|
||||
@@ -269,10 +269,10 @@ if [ -z "${INIT_SOURCED}" -o "${INIT_SOU
|
||||
DIST=${DIST-${MOZILLA_ROOT}/dist}
|
||||
SECURITY_ROOT=${SECURITY_ROOT-${MOZILLA_ROOT}/security/nss}
|
||||
TESTDIR=${TESTDIR-${MOZILLA_ROOT}/tests_results/security}
|
||||
- OBJDIR=`(cd $COMMON; $MAKE objdir_name)`
|
||||
- OS_ARCH=`(cd $COMMON; $MAKE os_arch)`
|
||||
- DLL_PREFIX=`(cd $COMMON; $MAKE dll_prefix)`
|
||||
- DLL_SUFFIX=`(cd $COMMON; $MAKE dll_suffix)`
|
||||
+ OBJDIR=`(cd $COMMON; $MAKE --no-print-directory objdir_name)`
|
||||
+ OS_ARCH=`(cd $COMMON; $MAKE --no-print-directory os_arch)`
|
||||
+ DLL_PREFIX=`(cd $COMMON; $MAKE --no-print-directory dll_prefix)`
|
||||
+ DLL_SUFFIX=`(cd $COMMON; $MAKE --no-print-directory dll_suffix)`
|
||||
OS_NAME=`uname -s | sed -e "s/-[0-9]*\.[0-9]*//" | sed -e "s/-WOW64//"`
|
||||
|
||||
BINDIR="${DIST}/${OBJDIR}/bin"
|
9
nss.spec
9
nss.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Summary: Network Security Services
|
||||
Name: nss
|
||||
Version: 3.11.99.4
|
||||
Version: 3.11.99.5
|
||||
Release: 1%{?dist}
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
@ -33,8 +33,7 @@ Source12: %{name}-pem-20080124.tar.bz2
|
||||
Patch1: nss-no-rpath.patch
|
||||
Patch2: nss-nolocalsql.patch
|
||||
Patch6: nss-enable-pem.patch
|
||||
Patch7: bug432146.patch
|
||||
|
||||
patch7: nss-fix-tests.patch
|
||||
|
||||
%description
|
||||
Network Security Services (NSS) is a set of libraries designed to
|
||||
@ -89,7 +88,7 @@ low level services.
|
||||
%patch1 -p0
|
||||
%patch2 -p0
|
||||
%patch6 -p0 -b .libpem
|
||||
%patch7 -p0
|
||||
%patch7 -p0 -b .prex
|
||||
|
||||
|
||||
%build
|
||||
@ -445,6 +444,8 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Mar 17 2008 Kai Engert <kengert@redhat.com> - 3.11.99.5-1
|
||||
- Update to NSS_3_12_BETA3
|
||||
* Fri Feb 22 2008 Kai Engert <kengert@redhat.com> - 3.11.99.4-1
|
||||
- NSS 3.12 Beta 2
|
||||
- Use /usr/lib{64} as devel libdir, create symbolic links.
|
||||
|
Loading…
Reference in New Issue
Block a user