Update to nss-3.17.4
- remove a patch rendered obsolete by the rebase
This commit is contained in:
parent
c70e45537d
commit
8c142e52fe
2
.gitignore
vendored
2
.gitignore
vendored
@ -8,4 +8,4 @@ TestCA.ca.cert
|
||||
TestUser50.cert
|
||||
TestUser51.cert
|
||||
/nss-pem-20140125.tar.bz2
|
||||
/nss-3.17.3.tar.gz
|
||||
/nss-3.17.4.tar.gz
|
||||
|
@ -1,34 +0,0 @@
|
||||
diff -up nss/tests/dbtests/dbtests.sh.646045 nss/tests/dbtests/dbtests.sh
|
||||
--- nss/tests/dbtests/dbtests.sh.646045 2013-04-04 13:31:55.000000000 -0700
|
||||
+++ nss/tests/dbtests/dbtests.sh 2013-04-04 15:57:46.298127149 -0700
|
||||
@@ -168,6 +168,9 @@ dbtest_main()
|
||||
cat $RONLY_DIR/* > /dev/null
|
||||
fi
|
||||
|
||||
+ # skipping the next two tests when user is root,
|
||||
+ # otherwise they would fail due to rooty powers
|
||||
+ if [[ $EUID -ne 0 ]] then
|
||||
${BINDIR}/dbtest -d $RONLY_DIR
|
||||
ret=$?
|
||||
if [ $ret -ne 46 ]; then
|
||||
@@ -175,6 +178,10 @@ dbtest_main()
|
||||
else
|
||||
html_passed "Dbtest r/w didn't work in an readonly dir $ret"
|
||||
fi
|
||||
+ else
|
||||
+ html_passed "Skipping Dbtest r/w in a readonly dir because user is root"
|
||||
+ fi
|
||||
+ if [[ $EUID -ne 0 ]] then
|
||||
${BINDIR}/certutil -D -n "TestUser" -d .
|
||||
ret=$?
|
||||
if [ $ret -ne 255 ]; then
|
||||
@@ -182,6 +189,9 @@ dbtest_main()
|
||||
else
|
||||
html_passed "Certutil didn't work in an readonly dir $ret"
|
||||
fi
|
||||
+ else
|
||||
+ html_passed "Skipping Certutil delete cert in an readonly directory test because user is root"
|
||||
+ fi
|
||||
|
||||
Echo "test opening the database ronly in a readonly directory"
|
||||
|
13
nss.spec
13
nss.spec
@ -1,6 +1,6 @@
|
||||
%global nspr_version 4.10.7
|
||||
%global nss_util_version 3.17.3
|
||||
%global nss_softokn_version 3.17.3
|
||||
%global nss_util_version 3.17.4
|
||||
%global nss_softokn_version 3.17.4
|
||||
%global unsupported_tools_directory %{_libdir}/nss/unsupported-tools
|
||||
%global allTools "certutil cmsutil crlutil derdump modutil pk12util signtool signver ssltap vfychain vfyserv"
|
||||
|
||||
@ -18,8 +18,8 @@
|
||||
|
||||
Summary: Network Security Services
|
||||
Name: nss
|
||||
Version: 3.17.3
|
||||
Release: 4%{?dist}
|
||||
Version: 3.17.4
|
||||
Release: 1%{?dist}
|
||||
License: MPLv2.0
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
Group: System Environment/Libraries
|
||||
@ -74,7 +74,6 @@ Patch2: add-relro-linker-option.patch
|
||||
Patch3: renegotiate-transitional.patch
|
||||
Patch6: nss-enable-pem.patch
|
||||
Patch16: nss-539183.patch
|
||||
Patch18: nss-646045.patch
|
||||
# must statically link pem against the freebl in the buildroot
|
||||
# Needed only when freebl on tree has new APIS
|
||||
Patch25: nsspem-use-system-freebl.patch
|
||||
@ -173,7 +172,6 @@ low level services.
|
||||
%patch3 -p0 -b .transitional
|
||||
%patch6 -p0 -b .libpem
|
||||
%patch16 -p0 -b .539183
|
||||
%patch18 -p0 -b .646045
|
||||
# link pem against buildroot's freebl, essential when mixing and matching
|
||||
%patch25 -p0 -b .systemfreebl
|
||||
%patch40 -p0 -b .noocsptest
|
||||
@ -783,6 +781,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jan 28 2015 Elio Maldonado <emaldona@redhat.com> - 3.17.4-1
|
||||
- Update to nss-3.17.4
|
||||
|
||||
* Sat Jan 24 2015 Ville Skyttä <ville.skytta@iki.fi> - 3.17.3-4
|
||||
- Own the %%{_datadir}/doc/nss-tools dir
|
||||
|
||||
|
2
sources
2
sources
@ -8,4 +8,4 @@ f998b70c1be25e8bb9f5fdb5d50eb6f2 TestCA.ca.cert
|
||||
1b7b6808cd77d5df29bf5bb9e5fac967 TestUser50.cert
|
||||
ab0b56dd505a995425c03e5266f7c8d6 TestUser51.cert
|
||||
b8a94e863c852e1f8b75e930e76f8640 nss-pem-20140125.tar.bz2
|
||||
fba7489e1b26f2a0bfe5527430fd61e1 nss-3.17.3.tar.gz
|
||||
a77df26072cabf8afb26911b6fa9b755 nss-3.17.4.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user