Fix compile issues found during the Fedora 38 rebuild.
(SECStatus is an enum and can't be assigned to and int)
This commit is contained in:
parent
ea71f8dfa8
commit
7983668370
24
nss-3.85-fedora-rebuild-errors.patch
Normal file
24
nss-3.85-fedora-rebuild-errors.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up ./lib/ssl/ssl3exthandle.c.rebuild_errors ./lib/ssl/ssl3exthandle.c
|
||||
--- ./lib/ssl/ssl3exthandle.c.rebuild_errors 2023-01-24 09:26:36.520183263 -0800
|
||||
+++ ./lib/ssl/ssl3exthandle.c 2023-01-24 09:27:07.715379228 -0800
|
||||
@@ -201,7 +201,7 @@ ssl3_FreeSniNameArray(TLSExtensionData *
|
||||
* Clients sends a filled in session ticket if one is available, and otherwise
|
||||
* sends an empty ticket. Servers always send empty tickets.
|
||||
*/
|
||||
-PRInt32
|
||||
+SECStatus
|
||||
ssl3_ClientSendSessionTicketXtn(const sslSocket *ss, TLSExtensionData *xtnData,
|
||||
sslBuffer *buf, PRBool *added)
|
||||
{
|
||||
diff -up ./lib/ssl/sslsnce.c.rebuild_errors ./lib/ssl/sslsnce.c
|
||||
--- ./lib/ssl/sslsnce.c.rebuild_errors 2023-01-24 09:44:52.714977837 -0800
|
||||
+++ ./lib/ssl/sslsnce.c 2023-01-24 09:46:20.993510435 -0800
|
||||
@@ -1820,7 +1820,7 @@ ssl_GetSelfEncryptKeyPair(SECKEYPublicKe
|
||||
return SECSuccess;
|
||||
}
|
||||
|
||||
-static PRBool
|
||||
+static SECStatus
|
||||
ssl_GenerateSelfEncryptKeys(void *pwArg, PRUint8 *keyName,
|
||||
PK11SymKey **aesKey, PK11SymKey **macKey);
|
||||
|
6
nss.spec
6
nss.spec
@ -134,6 +134,9 @@ Patch40: nss-no-dbm-man-page.patch
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1774659
|
||||
Patch51: nss-3.79-dbtool.patch
|
||||
|
||||
# fix rebuilds error
|
||||
Patch52: nss-3.85-fedora-rebuild-errors.patch
|
||||
|
||||
Patch100: nspr-config-pc.patch
|
||||
Patch101: nspr-gcc-atomics.patch
|
||||
|
||||
@ -1091,6 +1094,9 @@ update-crypto-policies &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jan 24 2023 Bob Relyea - 3.87.0-2
|
||||
- Fix rebuild errors
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.87.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user