Hotfix: previous commit 2bdda3a
Signed-off-by: Frantisek Krenzelok <krenzelok.frantisek@gmail.com>
This commit is contained in:
parent
2bdda3a809
commit
746cb03e25
@ -1,17 +1,8 @@
|
|||||||
diff --git a/lib/freebl/Makefile b/lib/freebl/Makefile
|
diff --git a/lib/freebl/Makefile b/lib/freebl/Makefile
|
||||||
|
index 74e8e65..8995752 100644
|
||||||
--- a/lib/freebl/Makefile
|
--- a/lib/freebl/Makefile
|
||||||
+++ b/lib/freebl/Makefile
|
+++ b/lib/freebl/Makefile
|
||||||
@@ -560,6 +560,9 @@ else
|
@@ -568,7 +568,6 @@ ifneq ($(shell $(CC) -? 2>&1 >/dev/null </dev/null | sed -e 's/:.*//;1q'),lcc)
|
||||||
endif # Solaris for non-sparc family CPUs
|
|
||||||
endif # target == SunO
|
|
||||||
|
|
||||||
+# As the result of the bug https://bugzilla.mozilla.org/show_bug.cgi?id=1836925
|
|
||||||
+# we currently totally removing the support of Vale implementation of Curve25519
|
|
||||||
+SUPPORTS_VALE_CURVE25519 = 0
|
|
||||||
ifdef USE_64
|
|
||||||
# no __int128 at least up to lcc 1.23 (pretending to be gcc5)
|
|
||||||
# NB: CC_NAME is not defined here
|
|
||||||
@@ -568,7 +571,6 @@ ifneq ($(shell $(CC) -? 2>&1 >/dev/null </dev/null | sed -e 's/:.*//;1q'),lcc)
|
|
||||||
HAVE_INT128_SUPPORT = 1
|
HAVE_INT128_SUPPORT = 1
|
||||||
DEFINES += -DHAVE_INT128_SUPPORT
|
DEFINES += -DHAVE_INT128_SUPPORT
|
||||||
else ifeq (1,$(CC_IS_GCC))
|
else ifeq (1,$(CC_IS_GCC))
|
||||||
@ -20,9 +11,23 @@ diff --git a/lib/freebl/Makefile b/lib/freebl/Makefile
|
|||||||
HAVE_INT128_SUPPORT = 1
|
HAVE_INT128_SUPPORT = 1
|
||||||
DEFINES += -DHAVE_INT128_SUPPORT
|
DEFINES += -DHAVE_INT128_SUPPORT
|
||||||
diff --git a/lib/freebl/freebl.gyp b/lib/freebl/freebl.gyp
|
diff --git a/lib/freebl/freebl.gyp b/lib/freebl/freebl.gyp
|
||||||
|
index 65f9a80..23940ef 100644
|
||||||
--- a/lib/freebl/freebl.gyp
|
--- a/lib/freebl/freebl.gyp
|
||||||
+++ b/lib/freebl/freebl.gyp
|
+++ b/lib/freebl/freebl.gyp
|
||||||
@@ -934,11 +934,6 @@
|
@@ -866,12 +866,6 @@
|
||||||
|
}],
|
||||||
|
],
|
||||||
|
}],
|
||||||
|
- [ 'supports_vale_curve25519==1', {
|
||||||
|
- 'defines': [
|
||||||
|
- # The Makefile does version-tests on GCC, but we're not doing that here.
|
||||||
|
- 'HACL_CAN_COMPILE_INLINE_ASM',
|
||||||
|
- ],
|
||||||
|
- }],
|
||||||
|
[ 'OS=="linux" or OS=="android"', {
|
||||||
|
'conditions': [
|
||||||
|
[ 'target_arch=="x64"', {
|
||||||
|
@@ -934,11 +928,6 @@
|
||||||
'variables': {
|
'variables': {
|
||||||
'module': 'nss',
|
'module': 'nss',
|
||||||
'conditions': [
|
'conditions': [
|
||||||
@ -34,3 +39,19 @@ diff --git a/lib/freebl/freebl.gyp b/lib/freebl/freebl.gyp
|
|||||||
[ 'target_arch=="x64" or target_arch=="arm64" or target_arch=="aarch64"', {
|
[ 'target_arch=="x64" or target_arch=="arm64" or target_arch=="aarch64"', {
|
||||||
'have_int128_support%': 1,
|
'have_int128_support%': 1,
|
||||||
}, {
|
}, {
|
||||||
|
diff --git a/lib/freebl/freebl_base.gypi b/lib/freebl/freebl_base.gypi
|
||||||
|
index d198c44..34b6b3c 100644
|
||||||
|
--- a/lib/freebl/freebl_base.gypi
|
||||||
|
+++ b/lib/freebl/freebl_base.gypi
|
||||||
|
@@ -151,11 +151,6 @@
|
||||||
|
'ecl/curve25519_32.c',
|
||||||
|
],
|
||||||
|
}],
|
||||||
|
- ['supports_vale_curve25519==1', {
|
||||||
|
- 'sources': [
|
||||||
|
- 'verified/Hacl_Curve25519_64.c',
|
||||||
|
- ],
|
||||||
|
- }],
|
||||||
|
['(target_arch!="ppc64" and target_arch!="ppc64le") or disable_altivec==1', {
|
||||||
|
'sources': [
|
||||||
|
# Gyp does not support per-file cflags, so working around like this.
|
||||||
|
Loading…
Reference in New Issue
Block a user