- Update to 3.11.7, but freebl/softokn remain at 3.11.5.
- Use a workaround to avoid mozilla bug 51429.
This commit is contained in:
parent
7d533dae82
commit
731ecc11ff
@ -1 +1 @@
|
||||
nss-3.11.5.tar.gz
|
||||
nss-3.11.7-fbst3115-stripped.tar.gz
|
||||
|
20
fake-kstat.h
Normal file
20
fake-kstat.h
Normal file
@ -0,0 +1,20 @@
|
||||
struct tag_kstat_t
|
||||
{
|
||||
struct tag_kstat_t *ks_next;
|
||||
char* ks_data;
|
||||
PRUint32 ks_data_size;
|
||||
int ks_ndata;
|
||||
};
|
||||
|
||||
struct tag_kstat_ctl_t
|
||||
{
|
||||
struct tag_kstat_t *kc_chain;
|
||||
};
|
||||
|
||||
typedef struct tag_kstat_t kstat_t;
|
||||
typedef struct tag_kstat_ctl_t kstat_ctl_t;
|
||||
|
||||
#define kstat_open() NULL
|
||||
#define kstat_read(a,b,c) -1
|
||||
#define kstat_close(x) -1
|
||||
|
@ -1,26 +0,0 @@
|
||||
#!/bin/sh
|
||||
FREEBLDIR=./mozilla/security/nss/lib/freebl
|
||||
set -e
|
||||
|
||||
mv ${FREEBLDIR}/ecl/ecl-exp.h ${FREEBLDIR}/save
|
||||
rm -rf ${FREEBLDIR}/ecl/tests
|
||||
rm -rf ${FREEBLDIR}/ecl/CVS
|
||||
for i in ${FREEBLDIR}/ecl/* ; do
|
||||
echo clobbering $i
|
||||
> $i
|
||||
done
|
||||
mv ${FREEBLDIR}/save ${FREEBLDIR}/ecl/ecl-exp.h
|
||||
|
||||
for j in ${FREEBLDIR}/ec.*; do
|
||||
echo unifdef $j
|
||||
cat $j | \
|
||||
awk 'BEGIN {ech=1; prt=0;} \
|
||||
/^#[ \t]*ifdef.*NSS_ENABLE_ECC/ {ech--; next;} \
|
||||
/^#[ \t]*if/ {if(ech < 1) ech--;} \
|
||||
{if(ech>0) {;print $0};} \
|
||||
/^#[ \t]*endif/ {if(ech < 1) ech++;} \
|
||||
{if (prt && (ech<=0)) {;print $0}; } \
|
||||
{if (ech>0) {prt=0;} } \
|
||||
/^#[ \t]*else/ {if (ech == 0) prt=1;}' > $j.hobbled && \
|
||||
mv $j.hobbled $j
|
||||
done
|
11
nss-use-netstat-hack.patch
Normal file
11
nss-use-netstat-hack.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ./mozilla/security/coreconf/config.mk.org 2007-05-25 01:53:04.000000000 +0200
|
||||
+++ ./mozilla/security/coreconf/config.mk 2007-05-25 01:52:58.000000000 +0200
|
||||
@@ -185,3 +185,8 @@
|
||||
ifdef NSS_ALLOW_UNSUPPORTED_CRITICAL
|
||||
DEFINES += -DNSS_ALLOW_UNSUPPORTED_CRITICAL
|
||||
endif
|
||||
+
|
||||
+ifdef USE_NETSTAT_HACK
|
||||
+DEFINES += -DSOLARIS
|
||||
+INCLUDES += -I../fake
|
||||
+endif
|
23
nss.spec
23
nss.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Summary: Network Security Services
|
||||
Name: nss
|
||||
Version: 3.11.5
|
||||
Version: 3.11.7
|
||||
Release: 2%{?dist}
|
||||
License: MPL/GPL/LGPL
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
@ -16,16 +16,17 @@ BuildRequires: gawk
|
||||
Provides: mozilla-nss
|
||||
Obsoletes: mozilla-nss
|
||||
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Source0: %{name}-%{version}-fbst3115-stripped.tar.gz
|
||||
Source1: nss.pc.in
|
||||
Source2: nss-config.in
|
||||
Source3: blank-cert8.db
|
||||
Source4: blank-key3.db
|
||||
Source5: blank-secmod.db
|
||||
Source6: nss-clobber.sh
|
||||
Source7: fake-kstat.h
|
||||
|
||||
Patch1: nss-no-rpath.patch
|
||||
Patch2: nss-smartcard-auth.patch
|
||||
Patch3: nss-use-netstat-hack.patch
|
||||
|
||||
%description
|
||||
Network Security Services (NSS) is a set of libraries designed to
|
||||
@ -75,9 +76,11 @@ low level services.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
sh %{SOURCE6} > /dev/null
|
||||
%patch1 -p0
|
||||
%patch2 -p0 -b .smartcard-auth.patch
|
||||
%patch3 -p0
|
||||
%{__mkdir_p} mozilla/security/nss/lib/fake/
|
||||
cp -i %{SOURCE7} mozilla/security/nss/lib/fake/kstat.h
|
||||
|
||||
%build
|
||||
|
||||
@ -114,6 +117,14 @@ export USE_64
|
||||
|
||||
%{__make} -C ./mozilla/security/coreconf
|
||||
%{__make} -C ./mozilla/security/dbm
|
||||
%{__make} -C ./mozilla/security/nss export
|
||||
|
||||
%{__make} -C ./mozilla/security/nss/lib/util
|
||||
%{__make} -C ./mozilla/security/nss/lib/freebl
|
||||
|
||||
touch ./mozilla/security/nss/lib/freebl/unix_rand.c
|
||||
USE_NETSTAT_HACK=1 %{__make} -C ./mozilla/security/nss/lib/freebl
|
||||
|
||||
%{__make} -C ./mozilla/security/nss
|
||||
|
||||
# Set up our package file
|
||||
@ -355,6 +366,10 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jun 01 2007 Kai Engert <kengert@redhat.com> - 3.11.7-2
|
||||
- Update to 3.11.7, but freebl/softokn remain at 3.11.5.
|
||||
- Use a workaround to avoid mozilla bug 51429.
|
||||
|
||||
* Fri Mar 02 2007 Kai Engert <kengert@redhat.com> - 3.11.5-2
|
||||
- Fix rhbz#230545, failure to enable FIPS mode
|
||||
- Fix rhbz#220542, make NSS more tolerant of resets when in the
|
||||
|
Loading…
Reference in New Issue
Block a user