removed patches that have moved to nss-softokn
This commit is contained in:
parent
3069fb3fb9
commit
7298efec27
@ -1,52 +0,0 @@
|
|||||||
diff -up ./mozilla/security/nss/lib/Makefile.nolocalsql ./mozilla/security/nss/lib/Makefile
|
|
||||||
--- ./mozilla/security/nss/lib/Makefile.nolocalsql 2007-07-19 23:36:49.000000000 +0200
|
|
||||||
+++ ./mozilla/security/nss/lib/Makefile 2009-04-14 17:07:40.000000000 +0200
|
|
||||||
@@ -62,11 +62,11 @@ ifeq ($(OS_TARGET), WINCE)
|
|
||||||
DIRS := $(filter-out fortcrypt,$(DIRS))
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifndef MOZILLA_CLIENT
|
|
||||||
-ifndef NSS_USE_SYSTEM_SQLITE
|
|
||||||
-DIRS := sqlite $(DIRS)
|
|
||||||
-endif
|
|
||||||
-endif
|
|
||||||
+#ifndef MOZILLA_CLIENT
|
|
||||||
+#ifndef NSS_USE_SYSTEM_SQLITE
|
|
||||||
+#DIRS := sqlite $(DIRS)
|
|
||||||
+#endif
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#######################################################################
|
|
||||||
# (5) Execute "global" rules. (OPTIONAL) #
|
|
||||||
diff -up ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn.nolocalsql ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn
|
|
||||||
--- ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn.nolocalsql 2007-07-19 23:36:50.000000000 +0200
|
|
||||||
+++ ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn 2009-04-14 17:07:40.000000000 +0200
|
|
||||||
@@ -46,9 +46,9 @@ MAPFILE = $(OBJDIR)/nssdbm.def
|
|
||||||
|
|
||||||
DEFINES += -DSHLIB_SUFFIX=\"$(DLL_SUFFIX)\" -DSHLIB_PREFIX=\"$(DLL_PREFIX)\" -DSOFTOKEN_LIB_NAME=\"$(notdir $(SHARED_LIBRARY))\"
|
|
||||||
|
|
||||||
-ifdef MOZILLA_CLIENT
|
|
||||||
-INCLUDES += -I$(DIST)/include/sqlite3
|
|
||||||
-endif
|
|
||||||
+#ifdef MOZILLA_CLIENT
|
|
||||||
+#INCLUDES += -I$(DIST)/include/sqlite3
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
CSRCS = \
|
|
||||||
dbmshim.c \
|
|
||||||
diff -up ./mozilla/security/nss/lib/softoken/manifest.mn.nolocalsql ./mozilla/security/nss/lib/softoken/manifest.mn
|
|
||||||
--- ./mozilla/security/nss/lib/softoken/manifest.mn.nolocalsql 2009-03-25 17:21:37.000000000 +0100
|
|
||||||
+++ ./mozilla/security/nss/lib/softoken/manifest.mn 2009-04-14 17:07:40.000000000 +0200
|
|
||||||
@@ -47,9 +47,9 @@ MAPFILE = $(OBJDIR)/softokn.def
|
|
||||||
|
|
||||||
DEFINES += -DSHLIB_SUFFIX=\"$(DLL_SUFFIX)\" -DSHLIB_PREFIX=\"$(DLL_PREFIX)\" -DSOFTOKEN_LIB_NAME=\"$(notdir $(SHARED_LIBRARY))\" -DSHLIB_VERSION=\"$(LIBRARY_VERSION)\"
|
|
||||||
|
|
||||||
-ifdef MOZILLA_CLIENT
|
|
||||||
-INCLUDES += -I$(DIST)/include/sqlite3
|
|
||||||
-endif
|
|
||||||
+#ifdef MOZILLA_CLIENT
|
|
||||||
+#INCLUDES += -I$(DIST)/include/sqlite3
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
EXPORTS = \
|
|
||||||
secmodt.h \
|
|
@ -1,23 +0,0 @@
|
|||||||
diff -rupN nss-3.12.3.99.3-orig/mozilla/security/nss/lib/freebl/stubs.c nss-3.12.3.99.3/mozilla/security/nss/lib/freebl/stubs.c
|
|
||||||
--- ./mozilla/security/nss/lib/freebl/stubs.c 2009-03-28 19:21:50.000000000 -0700
|
|
||||||
+++ ./mozilla/security/nss/lib/freebl/stubs.c 2009-06-08 20:37:20.000000000 -0700
|
|
||||||
@@ -558,8 +558,8 @@ FREEBL_InitStubs()
|
|
||||||
return SECFailure;
|
|
||||||
}
|
|
||||||
rv = freebl_InitNSPR(nspr);
|
|
||||||
- freebl_releaseLibrary(nspr);
|
|
||||||
if (rv != SECSuccess) {
|
|
||||||
+ freebl_releaseLibrary(nspr);
|
|
||||||
return rv;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
@@ -570,8 +570,8 @@ FREEBL_InitStubs()
|
|
||||||
return SECFailure;
|
|
||||||
}
|
|
||||||
rv = freebl_InitNSSUtil(nssutil);
|
|
||||||
- freebl_releaseLibrary(nssutil);
|
|
||||||
if (rv != SECSuccess) {
|
|
||||||
+ freebl_releaseLibrary(nssutil);
|
|
||||||
return rv;
|
|
||||||
}
|
|
||||||
}
|
|
Loading…
Reference in New Issue
Block a user