fix gcc47 issue causing xulrunner to ftbfs in rawhide
This commit is contained in:
parent
81470bd3c4
commit
6e9d7578fc
12
nss-fix-gcc47-secmodt.patch
Normal file
12
nss-fix-gcc47-secmodt.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up ./mozilla/security/nss/lib/softoken/secmodt.h.gcc47 ./mozilla/security/nss/lib/softoken/secmodt.h
|
||||||
|
--- ./mozilla/security/nss/lib/softoken/secmodt.h.gcc47 2012-01-30 16:14:41.179494528 -0500
|
||||||
|
+++ ./mozilla/security/nss/lib/softoken/secmodt.h 2012-01-30 16:14:48.287424482 -0500
|
||||||
|
@@ -338,7 +338,7 @@ typedef PRUint32 PK11AttrFlags;
|
||||||
|
#define SECMOD_SLOT_FLAGS "slotFlags=[RSA,DSA,DH,RC2,RC4,DES,RANDOM,SHA1,MD5,MD2,SSL,TLS,AES,Camellia,SEED,SHA256,SHA512]"
|
||||||
|
|
||||||
|
#define SECMOD_MAKE_NSS_FLAGS(fips,slot) \
|
||||||
|
-"Flags=internal,critical"fips" slotparams=("#slot"={"SECMOD_SLOT_FLAGS"})"
|
||||||
|
+"Flags=internal,critical" fips" slotparams=("#slot"={" SECMOD_SLOT_FLAGS"})"
|
||||||
|
|
||||||
|
#define SECMOD_INT_NAME "NSS Internal PKCS #11 Module"
|
||||||
|
#define SECMOD_INT_FLAGS SECMOD_MAKE_NSS_FLAGS("",1)
|
9
nss.spec
9
nss.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: Network Security Services
|
Summary: Network Security Services
|
||||||
Name: nss
|
Name: nss
|
||||||
Version: 3.13.1
|
Version: 3.13.1
|
||||||
Release: 12%{?dist}
|
Release: 13%{?dist}
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -73,6 +73,9 @@ Patch28: nsspem-bz754771.patch
|
|||||||
# This patch is currently meant for f16 and f15 only
|
# This patch is currently meant for f16 and f15 only
|
||||||
#Patch29: nss-ssl-cbc-random-iv-off-by-default.patch
|
#Patch29: nss-ssl-cbc-random-iv-off-by-default.patch
|
||||||
Patch30: bz784672-protect-against-calls-before-nss_init.patch
|
Patch30: bz784672-protect-against-calls-before-nss_init.patch
|
||||||
|
# Fix gcc 4.7 c++ issue in secmodt.h
|
||||||
|
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=50917
|
||||||
|
Patch31: nss-fix-gcc47-secmodt.patch
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -164,6 +167,7 @@ low level services.
|
|||||||
# activate only if requested for f17
|
# activate only if requested for f17
|
||||||
#%patch29 -p0 -b .770682
|
#%patch29 -p0 -b .770682
|
||||||
%patch30 -p0 -b .784672
|
%patch30 -p0 -b .784672
|
||||||
|
%patch31 -p0 -b .gcc47
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -578,6 +582,9 @@ rm -rf $RPM_BUILD_ROOT/%{_includedir}/nss3/nsslowhash.h
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 30 2012 Tom Callaway <spot@fedoraproject.org> - 3.13.1-13
|
||||||
|
- fix issue with gcc 4.7 in secmodt.h and C++11 user-defined literals
|
||||||
|
|
||||||
* Thu Jan 26 2012 Elio Maldonado <emaldona@redhat.com> - 3.13.1-12
|
* Thu Jan 26 2012 Elio Maldonado <emaldona@redhat.com> - 3.13.1-12
|
||||||
- Resolves: Bug 784672 - nss should protect against being called before nss_Init
|
- Resolves: Bug 784672 - nss should protect against being called before nss_Init
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user