Initial import

This commit is contained in:
Colin Walters 2014-04-03 17:37:47 -04:00
parent 2a61ff30e4
commit e5b4e9f563
4 changed files with 74 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/v2.18.1.tar.gz

View File

@ -0,0 +1,31 @@
From d8b586ca4108a50c9badce61c8e820779c58e764 Mon Sep 17 00:00:00 2001
From: Michael Marineau <mike@marineau.org>
Date: Tue, 17 Dec 2013 22:51:27 -0800
Subject: [PATCH] Explicitly link to libc.
Previously the library was linked using the -nostdlib flag which made
ldd --verbose look suspicious but everything still worked by virtue of
libpthread dynamically linking to libc. I don't know of any particular
reason for using -nostdlib and the documentation doesn't list it.
http://www.gnu.org/software/libc/manual/html_node/Adding-another-Service-to-NSS.html
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 8d9b7d2..6b56baf 100644
--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@ O := files-pwd.o \
files-have_o_cloexec.o
CFLAGS += $(EXTRA_CFLAGS) -pthread -fpic
-LDFLAGS += $(CFLAGS) -Wl,-soname,$T -Wl,-as-needed -nostdlib -lpthread
+LDFLAGS += $(CFLAGS) -Wl,-soname,$T -Wl,-as-needed -lpthread
CPPFLAGS += -D_GNU_SOURCE
ifneq ($(strip $(DATADIR)),)
--
1.8.3.1

41
nss-altfiles.spec Normal file
View File

@ -0,0 +1,41 @@
%global commit 89f3f0b390f3bbc58d8964b11a517173ed4eed78
%global shortcommit %(c=%{commit}; echo ${c:0:7})
Summary: NSS module to look up users in /usr/lib/passwd too
Name: nss-altfiles
Version: 2.18.1
Release: 1%{?dist}
#VCS: https://github.com/aperezdc/nss-altfiles
Source0: https://github.com/aperezdc/nss-altfiles/archive/v%{version}.tar.gz
# From pull request: https://github.com/marineam/nss-altfiles/commit/dda5073238b88b4537f2d2707b0ef67bdd11fe06
Patch0: 0001-Explicitly-link-to-libc.patch
License: LGPLv2+
URL: https://github.com/aperezdc/nss-altfiles
BuildRequires: glibc-devel
%description
When installed, this package allows looking up users
in %{prefix}/lib/passwd, similarly, groups in %{prefix}/lib/group.
%prep
%autosetup
%build
env CFLAGS=%{_optflags} ./configure --prefix=%{_prefix} --libdir=%{_libdir}
make %{?_smp_mflags}
%install
make install DESTDIR=$RPM_BUILD_ROOT
%files
%doc README.md
%{_libdir}/*.so.*
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%changelog
* Sat Mar 22 2014 Colin Walters <walters@verbum.org>
- Initial packaging

View File

@ -0,0 +1 @@
9b7974fe70147d38f778b2ef7d153405 v2.18.1.tar.gz