import nss-altfiles-2.18.1-12.el8
This commit is contained in:
commit
4e2d01b632
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/v2.18.1.tar.gz
|
1
.nss-altfiles.metadata
Normal file
1
.nss-altfiles.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
65ca705337cee4b1042896709cb5b537874e672e SOURCES/v2.18.1.tar.gz
|
41
SOURCES/ldflags.patch
Normal file
41
SOURCES/ldflags.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
Only in nss-altfiles-2.18.1.new: config.mk
|
||||||
|
diff -ur nss-altfiles-2.18.1/configure nss-altfiles-2.18.1.new/configure
|
||||||
|
--- nss-altfiles-2.18.1/configure 2014-03-14 13:13:43.000000000 +0000
|
||||||
|
+++ nss-altfiles-2.18.1.new/configure 2019-04-02 14:44:03.399819940 +0000
|
||||||
|
@@ -34,13 +34,14 @@
|
||||||
|
#
|
||||||
|
test -n "${CXXFLAGS}" && EXTRA_CXXFLAGS=${CXXFLAGS}
|
||||||
|
test -n "${CFLAGS}" && EXTRA_CFLAGS=${CFLAGS}
|
||||||
|
+test -n "${LDFLAGS}" && EXTRA_LDFLAGS=${LDFLAGS}
|
||||||
|
|
||||||
|
# Inspect arguments and generate config.mk
|
||||||
|
#
|
||||||
|
echo "# autogenerated by: $0 $*" > config.mk
|
||||||
|
for var in "$@" ; do
|
||||||
|
case ${var} in
|
||||||
|
- CFLAGS=* | CXXFLAGS=*)
|
||||||
|
+ CFLAGS=* | CXXFLAGS=* | LDFLAGS=* )
|
||||||
|
echo "Setting EXTRA_${var}"
|
||||||
|
echo "EXTRA_${var}" >> config.mk
|
||||||
|
;;
|
||||||
|
Only in nss-altfiles-2.18.1.new: debugfiles.list
|
||||||
|
Only in nss-altfiles-2.18.1.new: debuglinks.list
|
||||||
|
Only in nss-altfiles-2.18.1.new: debugsourcefiles.list
|
||||||
|
Only in nss-altfiles-2.18.1.new: debugsources.list
|
||||||
|
Only in nss-altfiles-2.18.1.new: elfbins.list
|
||||||
|
Only in nss-altfiles-2.18.1.new: files-grp.o
|
||||||
|
Only in nss-altfiles-2.18.1.new: files-have_o_cloexec.o
|
||||||
|
Only in nss-altfiles-2.18.1.new: files-pwd.o
|
||||||
|
Only in nss-altfiles-2.18.1.new: libnss_altfiles.so.2
|
||||||
|
diff -ur nss-altfiles-2.18.1/Makefile nss-altfiles-2.18.1.new/Makefile
|
||||||
|
--- nss-altfiles-2.18.1/Makefile 2014-03-14 13:13:43.000000000 +0000
|
||||||
|
+++ nss-altfiles-2.18.1.new/Makefile 2019-04-02 14:44:28.023780755 +0000
|
||||||
|
@@ -10,7 +10,7 @@
|
||||||
|
files-have_o_cloexec.o
|
||||||
|
|
||||||
|
CFLAGS += $(EXTRA_CFLAGS) -pthread -fpic
|
||||||
|
-LDFLAGS += $(CFLAGS) -Wl,-soname,$T -Wl,-as-needed -nostdlib -lpthread
|
||||||
|
+LDFLAGS += $(CFLAGS) $(EXTRA_LDFLAGS) -Wl,-soname,$T -Wl,-as-needed -nostdlib -lpthread
|
||||||
|
CPPFLAGS += -D_GNU_SOURCE
|
||||||
|
|
||||||
|
ifneq ($(strip $(DATADIR)),)
|
74
SPECS/nss-altfiles.spec
Normal file
74
SPECS/nss-altfiles.spec
Normal file
@ -0,0 +1,74 @@
|
|||||||
|
%global commit 89f3f0b390f3bbc58d8964b11a517173ed4eed78
|
||||||
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
|
|
||||||
|
Summary: NSS module to look up users in /usr/lib/passwd too
|
||||||
|
Name: nss-altfiles
|
||||||
|
Version: 2.18.1
|
||||||
|
Release: 12%{?dist}
|
||||||
|
#VCS: https://github.com/aperezdc/nss-altfiles
|
||||||
|
Source0: https://github.com/aperezdc/nss-altfiles/archive/v%{version}.tar.gz
|
||||||
|
# From pull request: https://github.com/marineam/nss-altfiles/commit/dda5073238b88b4537f2d2707b0ef67bdd11fe06
|
||||||
|
# FIXME: Change nss-altfiles to not use glibc internal symbols
|
||||||
|
#Patch0: 0001-Explicitly-link-to-libc.patch
|
||||||
|
Patch1: ldflags.patch
|
||||||
|
License: LGPLv2+
|
||||||
|
URL: https://github.com/aperezdc/nss-altfiles
|
||||||
|
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
|
||||||
|
%description
|
||||||
|
When installed, this package allows looking up users
|
||||||
|
in %{prefix}/lib/passwd, similarly, groups in %{prefix}/lib/group.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup
|
||||||
|
|
||||||
|
%build
|
||||||
|
./configure --prefix=%{_prefix} --libdir=%{_libdir} CFLAGS="%{optflags}" LDFLAGS="%{build_ldflags}"
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc README.md
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Apr 02 2019 Colin Walters <walters@redhat.com> - 2.18.1-12
|
||||||
|
- Add system LDFLAGS
|
||||||
|
- Resolves: rhbz#1630609
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.18.1-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.18.1-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.18.1-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.18.1-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.18.1-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.18.1-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.18.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 28 2014 Ville Skyttä <ville.skytta@iki.fi> - 2.18.1-3
|
||||||
|
- Build with $RPM_OPT_FLAGS
|
||||||
|
|
||||||
|
* Tue Apr 08 2014 Colin Walters <walters@verbum.org>
|
||||||
|
- Revert patch to link to libc, causes a dep on GLIBC_PRIVATE
|
||||||
|
|
||||||
|
* Sat Mar 22 2014 Colin Walters <walters@verbum.org>
|
||||||
|
- Initial packaging
|
Loading…
Reference in New Issue
Block a user